Вход | Регистрация


1С:Предприятие ::

Метки: 

Как можно запустить внешнюю обработку из ее модуля

Я
   Стэн5
 
22.09.17 - 13:59
Доброго дня!
есть код 
ВнешниеОбработки.Создать("Адрес\обработка 8.3..epf").Отладить();

вопрос:
Как находясь в модуле внешней обработки запустить ее?
 
  Рекламное место пустует
   DrShad
 
1 - 22.09.17 - 14:00
она уже запущена, если ты находишься в ее модуле
   Вафель
 
2 - 22.09.17 - 14:01
имеется ввиду открыть форму? никак
   Стэн5
 
3 - 22.09.17 - 14:05
(2) Да именно запустить ее, неужели никто еще не сумел этого сделать
   vicof
 
4 - 22.09.17 - 14:06
(3) Сервер не может вызывать клиента. Точка.
   Стэн5
 
5 - 22.09.17 - 14:09
(4) какой ты скучный
   DrShad
 
6 - 22.09.17 - 14:10
(4) +1
   Рэйв
 
7 - 22.09.17 - 14:12
(5)Если в итоге обработчик находся в модуле обработки, то просто вызови его.
Если в модуле формы - то как вариант скопипасти его функционал в модуль объекта
   Стэн5
 
8 - 22.09.17 - 14:20
(7) Не пойму что ты имеешь ввиду?

&НаСервере
Процедура КомандаВыполнитьНаСервере()    

// строка создания вставляется в "Вычислить выражение" на точке останова

ВнешниеОбработки.Создать("Адрес\обработка 8.3..epf").Отладить();                       

КонецПроцедуры

в этот момент создается обработка и я попадаю в ее модуль, как ее запустить в пользовательский режим?

Функция Отладить() Экспорт
//  и вот я тут, но как открыть?

//
КонецФункции
   Рэйв
 
9 - 22.09.17 - 14:23
(8) Если под "запустить в пользовательский режим" ты имеешь в виду открытие формы, то не забывай что ты находишься на сервере. Кому ты там собрался эту форму показывать?
   vicof
 
10 - 22.09.17 - 14:24
&НаКлиенте
Процедура КомандаВыполнить()

ОткрытьФорму();

Конецпроцедуры
 
  Рекламное место пустует
   Стэн5
 
11 - 22.09.17 - 14:27
(9) да это понятно, что на сервере, я ее для себя хочу открыть, но возможности с клиента нет!

Вот эту строку можно запустить только на сервере!
ВнешниеОбработки.Создать("Адрес\обработка 8.3..epf").Отладить();                       

и попасть из нее можно только в сервер ".Отладить();" отладить это экспортная процедура, если есть возможность создать обработку и попасть в ее форму и там отрабатывать то было бы супер
   Рэйв
 
12 - 22.09.17 - 14:31
(11)Кто мешает написать свой "Отладить" в модуле формы и открывать себе ее на здоровье?
   Стэн5
 
13 - 22.09.17 - 14:37
(12) отлично, как попасть в модуль формы? через ВнешниеОбработки.Создать("Адрес\обработка 8.3..epf")......?
   youalex
 
14 - 22.09.17 - 18:35
(13) ОткрытьФорму
   Стэн5
 
15 - 25.09.17 - 09:44
(14) ВнешниеОбработки.Создать("Адрес\обработка 8.3..epf").....

можно сделать только на сервере
   Рэйв
 
16 - 25.09.17 - 09:54
(15)
&НаКлиенте

Процедура ОткрытьОбработку(Команда)
    Перем стрИмя, стрАдрес;
    
    стрАдрес = "";
    Если НЕ ПоместитьФайл(стрАдрес, "D:\ИмяОбработки.epf", , Ложь) Тогда
        Возврат;
    КонецЕсли;
    
    стрИмя = ПодключитьВнешнююОбработку(стрАдрес);
    
    Основнаяформа = ПолучитьФорму("ВнешняяОбработка." + стрИмя + ".Форма.Форма");
    Основнаяформа.Открыть();
КонецПроцедур// ОткрытьОбработку()

 

&НаСервере

Функция ПодключитьВнешнююОбработку(Знач стрАдрес)

    Возврат ВнешниеОбработки.Подключить(стрАдрес);
КонецФункци// ПодключитьВнешнююОбработку()
   МимохожийОднако
 
17 - 25.09.17 - 09:57
(0) Где ты откопал метод .Отладить()?
   Рэйв
 
18 - 25.09.17 - 09:59
(14)Да сам написал экспортный.
   Рэйв
 
19 - 25.09.17 - 09:59
(18) к (17)
   МимохожийОднако
 
20 - 25.09.17 - 10:00
(19) Ты ТС?
   Рэйв
 
21 - 25.09.17 - 10:01
(20)Я телепат со стажем:-)



Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует