Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Подскажите где найти методы и свойства Этих АктивИксов

v7: Подскажите где найти методы и свойства Этих АктивИксов
Я
   botman4
 
21.09.17 - 16:30
//ImageCombo control        MSComCtlLib.ImageComboCtl.2

 
//    СоздатьКонтрол("MSComCtlLib.ImageComboCtl.2","ImageCombo");

//
//   //ImageList control         MSComCtlLib.ImageListCtrl.2

// 
//    СоздатьКонтрол("MSComCtlLib.ImageListCtrl.2","ImageList");

//
//   //ListView control          MSComCtlLib.ListViewCtrl.2

// 
//    СоздатьКонтрол("MSComCtlLib.ListViewCtrl.2","ListView");

//
//   //ProgressBar control       MSComCtlLib.ProgCtrl.2

// 
//    СоздатьКонтрол("MSComCtlLib.ProgCtrl.2","Prog");

//
//   //Slider control            MSComCtlLib.Slider.2

// 
//    СоздатьКонтрол("MSComCtlLib.Slider.2","Slider");

//
//   //StatusBar control         MSComCtlLib.SBarCtrl.2

// 
//    СоздатьКонтрол("MSComCtlLib.SBarCtrl.2","SBar");

//
//   //Toolbar control           MSComCtlLib.Toolbar.2

// 
//    СоздатьКонтрол("MSComCtlLib.Toolbar.2","Toolbar");

//
//   //TreeView control           MSComCtlLib.TreeViewCtrl.2

// 
//    СоздатьКонтрол("MSComCtlLib.TreeCtrl.2","Tree");

//    
//   //WMPlayer control

//     СоздатьКонтрол("WMPlayer.OCX.7","Wmp");
 
 
   Ёпрст
 
1 - 21.09.17 - 16:31
знакомый код..

Посмотреть в ворде/экселе в обозревателе объектов
   botman4
 
2 - 21.09.17 - 16:32
Да, код твой. Сейчас гляну, спасибо.
   Ёпрст
 
3 - 21.09.17 - 16:51
если че, Запусти Excel/word, нажми Alt+F11, затем F2.
   Ёпрст
 
4 - 21.09.17 - 16:52
там разберешься
   Ёпрст
 
5 - 21.09.17 - 16:56
Если нужного объекта нема - тыркаешь в Tools- reference- или втыкаешь галочки или ручонками указываешь путь до нужного ocx/dll
   botman4
 
6 - 21.09.17 - 21:04
все нашел, спасибо.
как победить "Sub Refresh()" ???


    Прог = СоздатьКонтрол("MSComCtlLib.ProgCtrl.2","Prog");
    Прог.Min = 1;
    Прог.Max = 100000;

    Для ы=1 По 100000 Цикл
        Прог.Value = ы;

        Форма.обновить()/// Но это фигня мне кажется, что тут нужно

                // Прог.Refresh(), но он не отрабатывает, ругается...


    КонецЦикла;
   botman4
 
7 - 21.09.17 - 21:11
Разобрался... аказыцца прокатывает просто
    Для ы=1 По 100000 Цикл
        Прог.Value = ы;
    КонецЦикла;
   botman4
 
8 - 21.09.17 - 21:13
Но все равно, что такое "Sub Refresh()" ???
   Ёпрст
 
9 - 22.09.17 - 10:15
(8) принудительная отрисовка контрола на форме.
   Ёпрст
 
10 - 22.09.17 - 10:16
этих прогресс-баров, как грязи.
 
 Рекламное место пустует
   Duke1C
 
11 - 22.09.17 - 10:24
Ну и для полноты картины не хватает кода самой функции "СоздатьКонтрол()"
   Ёпрст
 
12 - 22.09.17 - 10:36
(11)
//======================================================================

Функция СоздатьКонтрол(ИмяКонтрола,ИмяАтрибутаФормы)
    АктивХ   = СоздатьОбъект("АктивИкс") ;
    АктивХ.УстановитьАтрибут(Форма,ИмяАтрибутаФормы);
    АктивХ.СоздатьЭУ(ИмяКонтрола);
    Возврат АктивХ.Объект;
КонецФункции// СоздатьКонтрол
   botman4
 
13 - 23.09.17 - 22:34
(10) А чем пользуешься в качестве прогресс бара и закладок на форме, если не секрет?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует