Вход | Регистрация


1С:Предприятие ::

Метки: 

v7: Ошибка при разборе XML Значение не представляет агрегатный объект (ВыбратьУзел)

Я
   Buzztekk
 
21.09.17 - 10:18
Разбираю xml файл приход ТТН от ЕГАИС

На этапе доступа к значению узла "oref:ClientRegId" вылетает ошибка: ТЗ.ClientRegIdПроизв = UL.ВыбратьУзел("oref:ClientRegId").Значение; 
Значение не представляет агрегатный объект (ВыбратьУзел)

код:
Producer = Product.ВыбратьУзел("pref:Producer");
UL=Producer.ВыбратьУзел("oref:UL");
ТЗ.ClientRegIdПроизв = UL.ВыбратьУзел("oref:ClientRegId").Значение;  

причем до этого никогда такой ошибки не было. В xml файле присутствует узел такой узел, я вижу его
 
 
   Buzztekk
 
1 - 21.09.17 - 10:19
Что за полтергейст, помогите пожалуйста
   ТогдаКонецЕсли
 
2 - 21.09.17 - 10:24
посмотри отладчиком.
Что из себя представляет UL?
И откуда он?
   Buzztekk
 
3 - 21.09.17 - 10:29
UL - это узел, на него не ругается

так выглядит хмл файл:
<pref:Producer>
                            <oref:UL>
                                <oref:ClientRegId>0300001230014</oref:ClientRegId>
                                <oref:INN>5029104266</oref:INN>
.....
</oref:UL>
</pref:Producer>
   Buzztekk
 
4 - 21.09.17 - 10:31
Причем у меня есть похожий хмл файл, который прекрасно проходит вместе с такими же узлами
   Конь в пальто
 
5 - 21.09.17 - 10:33
(4) ну правда, глянь отладчиком
   Buzztekk
 
6 - 21.09.17 - 10:43
Да я не умею ей пользоваться.
Открыл отладку, открыл внешнюю обработку и что дальше?
Где кнопка плей?)
   ТогдаКонецЕсли
 
7 - 21.09.17 - 10:44
Есть подозрение, что следующий вопрос будет про отладчик))
   Конь в пальто
 
8 - 21.09.17 - 10:44
в гугл, ютуб
   ТогдаКонецЕсли
 
9 - 21.09.17 - 10:49
Ставь точку останова в этой строке, начинай разбирать файл обработкой. когда остановится в то этой точке, смотри значение
   ТогдаКонецЕсли
 
10 - 21.09.17 - 10:50
Кнопка плей!!! Супер.
 
 
   igork1966
 
11 - 21.09.17 - 11:00
(0) ну например у тебя в xml:
<pref:Producer>
<чтотоотличноеотUL>
....
</чтотоотличноеотUL>
</pref:Producer>
   Buzztekk
 
12 - 21.09.17 - 11:00
Дак а что толку то, не понимаю, запустил отладку, она снова ту же ошибку выдает
   Конь в пальто
 
13 - 21.09.17 - 11:02
точку останова воткни
   Ёпрст
 
14 - 21.09.17 - 11:02
уидай ужо сам xml сюда
   Конь в пальто
 
15 - 21.09.17 - 11:02
или по ошибке
   Конь в пальто
 
16 - 21.09.17 - 11:03
Епрст не изменился, добрый)
   Buzztekk
 
17 - 21.09.17 - 11:03
(11) Но тогда почему он не ругается на UL  
UL=Producer.ВыбратьУзел("oref:UL") а ругается на
UL.ВыбратьУзел("oref:ClientRegId").Значение

Да и к тому же узел UL есть в хмл файле - я же вижу его:
<pref:Producer>
                            <oref:UL>
                                <oref:ClientRegId>030000000014</oref:ClientRegId>
   Конь в пальто
 
18 - 21.09.17 - 11:04
эх
   Buzztekk
 
19 - 21.09.17 - 11:07
(13) Воткнул, если ставлю на этой строчке ТЗ.ClientRegIdПроизв = UL.ВыбратьУзел("oref:ClientRegId").Значение;  

то та же ошибка. Я не понимаю  что должен отладчик показать отличного. тоже самое
   igork1966
 
20 - 21.09.17 - 11:08
(17) потому что UL не узел (не найден), естественно у неопределено нет метода ВыбратьУзел
   Конь в пальто
 
21 - 21.09.17 - 11:09
... ну посмотри как пользоваться им - в гуглу мин за 15 поймешь
   Ёпрст
 
22 - 21.09.17 - 11:09
(16) есть такое, а тебя лет 8 небыло видно
   Конь в пальто
 
23 - 21.09.17 - 11:11
(22) а я гонял людей по округе, решил вернуться)
   Buzztekk
 
24 - 21.09.17 - 11:12
(14) http://file.karelia.ru/ngjkzs/
4965 который не работает
а 4844 который нормально проходил на той неделе
   Buzztekk
 
25 - 21.09.17 - 11:12
Хотя файлы идентичные в части этих узлов
   Ёпрст
 
26 - 21.09.17 - 11:22
(25)

<pref:Producer><oref:FO><oref:ClientRegId>050000027008</oref:ClientRegId>
   Ёпрст
 
27 - 21.09.17 - 11:22
на вот..дальше догадаешься, или как ?
   Ёпрст
 
28 - 21.09.17 - 11:22
у тя есть физик в файле, короче.
   Ёпрст
 
29 - 21.09.17 - 11:25
Точнее, FO - это клиентос таможенного союза
<pref:Producer><oref:FO><oref:ClientRegId>050000027008</oref:ClientRegId><oref:FullName>Фэмели Брюери БЕРНАРД / Родинный пивовар БЕРНАРД а.с.</oref:FullName><oref:ShortName>Фэмели Брюери БЕРНАРД /</oref:ShortName><oref:address><oref:Country>203</oref:Country><oref:description>5. кветна 1, 396 01 Гумполец, Чешская республика</oref:description></oref:address></oref:FO></pref:Producer>
   Ёпрст
 
30 - 21.09.17 - 11:27
ЗЫ: FO - импортный клиентос

ну и, если че, нужно писать проверку на это.
может быть
UL -  Юридическое лицо РФ
FL - Индивидуальный предприниматель РФ
TS - контрагент Таможенного Союза
FO - Иностранный клиентос
   Buzztekk
 
31 - 21.09.17 - 11:28
(26) Спасибо ЕПРСТ!! Я что то не допер все UL проверить, застопорился на первом а дальше и не смотрел)
Щас буду разбираться что с ним делать
   Buzztekk
 
32 - 21.09.17 - 11:28
(30) а я UL как Улица расшифровывал для себя))
   Buzztekk
 
33 - 21.09.17 - 11:30
(30) Еще раз спасибо! Прошу прощения за свою глупость и невнимательность
 
 



Список тем форума
Рекламное место пустует  
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует