Вход | Регистрация

1С:Предприятие ::

Метки: 

УТ 11.3 вывод на печать из команды

Я
   picom
 
21.09.17 - 08:08
Есть добавленный самодельный документ в УТ 11.3.
Вывод на печать макета из этого документа организован через команду.
При выводе на печать нет крупных кнопок печати, которые есть во всех типовых документах.
Подскажите самый простой способ вывода на печать из этой команды с нужными мне красивыми кнопками из БСП100500.
Код

&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
    ТабДокумент = Заполнялка(ПараметрКоманды);
    ТабДокумент.Показать("Шедевр");
КонецПроцедуры

&НаСервере
Функция Заполнялка(ДокСсылка) Экспорт
    ТабДокумент = Новый ТабличныйДокумент;
    
    ТабДокумент.АвтоМасштаб = истина ;
    ТабДокумент.ОтображатьСетку = Ложь;
    ТабДокумент.ТолькоПросмотр = Истина;
    ТабДокумент.ОтображатьЗаголовки = Ложь;
    
    
    Макет = ДокСсылка.ПолучитьОбъект().ПолучитьМакет("Шедевр");
    ОбластьМакета = Макет.ПолучитьОбласть("Шапка");
   
    ТабДокумент.Вывести(ОбластьМакета);
    Возврат ТабДокумент;
КонецФункции
 
  Рекламное место пустует
   Wirtuozzz
 
1 - 21.09.17 - 08:13
(0) чем не устраивает типовой вывод на печать?
   picom
 
2 - 21.09.17 - 08:27
(1) микроскопической кнопкой вывода на печать
   ildary
 
3 - 21.09.17 - 08:30
(2) Элементы.ПодменюПечать.Отображение = ОтображениеКнопки.КартинкаИТекст;

поместить в МодификацияКонфигурацииПереопределяемый.ПриСозданииНаСервере()

и ваши волосы стали шелковистыми
   ildary
 
4 - 21.09.17 - 08:32
Для универсальности (если лень прописывать условия) можно тупо поместить этот код в попытку.
   ildary
 
5 - 21.09.17 - 08:34
Я еще делаю так (чтобы подменю всегда было на одном и том же месте):

        Элем = Форма.Элементы.Найти( "ПодменюПечать" );// ПодменюПечать последнее в панели

        Если Элем <> Неопределено Тогда
            Элементы.Переместить( Элем, Форма.КоманднаяПанель );
        КонецЕсли;

а в (3) заменить строку на 

Форма.Элементы.ПодменюПечать.Отображение = ОтображениеКнопки.КартинкаИТекст;


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует