Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Перенос по плану обмена. Как переносить данные только после определенной даты?

Перенос по плану обмена. Как переносить данные только после определенной даты?
Я
   Босечка
 
20.09.17 - 09:50
Как переносить данные только после определенной даты? Есть функция предопределенная ПриОтправкеДанныхГлавному(ЭлементДанных, ОтправкаЭлемента). Что там надо прописать чтобы это получилось?
 
 
   FIXXXL
 
1 - 20.09.17 - 09:54
(0) на регистрацию данные как встают? кодом или авто?
   Босечка
 
2 - 20.09.17 - 09:57
авто
   Босечка
 
3 - 20.09.17 - 10:04
Так правильно будет?
Процедура ПриОтправкеДанныхГлавному(ЭлементДанных, ОтправкаЭлемента)
Если (Метаданные.Документы.ЗаказПокупателя.СтандартныеРеквизиты.Дата>Дата(2017,7,14) тогда 
        ОтправкаЭлемента = ОтправкаЭлементаДанных.Игнорировать;
        
        ПланыОбмена.УдалитьРегистрациюИзменений(ЭтотОбъект.Ссылка,ЭлементДанных);    
Конецесли;    
    
КонецПроцедуры
   Босечка
 
4 - 20.09.17 - 10:07
Как взять реквизит документа?
   FIXXXL
 
5 - 20.09.17 - 10:10
(4) СП
Параметры:

<ЭлементДанных>

При вызове обработчика события данный параметр содержит элемент данных, изменение которого зарегистрировано и который должен быть помещен в сообщение обмена данными. Элементами данных могут быть КонстантаМенеджерЗначения.<Имя константы>, объекты базы данных, наборы записей регистров, последовательностей или перерасчетов.

от него бери, какие Метаданные???
   Босечка
 
6 - 20.09.17 - 10:13
Думаете так пойдет?
Процедура ПриОтправкеДанныхГлавному(ЭлементДанных, ОтправкаЭлемента)
Если ЭлементДанных.Дата>Дата(2017,7,14) тогда 
        ОтправкаЭлемента = ОтправкаЭлементаДанных.Игнорировать;
        
        ПланыОбмена.УдалитьРегистрациюИзменений(ЭтотОбъект.Ссылка,ЭлементДанных);    
Конецесли;    
    
КонецПроцедуры
   Босечка
 
7 - 20.09.17 - 10:14
А если одного типа с одной даты, а другого с другой?
   FIXXXL
 
8 - 20.09.17 - 10:16
(7) проверяй ТипЗнч(ЭлементДанных)
   FIXXXL
 
9 - 20.09.17 - 10:16
(6) отладчик в руки и алга! :)
   Босечка
 
10 - 20.09.17 - 10:19
Процедура ПриОтправкеДанныхГлавному(ЭлементДанных, ОтправкаЭлемента)
    Если  (ТипЗнч(ЭлементДанных)=Тип("ДокументСсылка.ЗаказПокупателя")) или (ТипЗнч(ЭлементДанных)=Тип("ДокументСсылка.РеализацияТоваровУслуг")) тогда
    ДатаГр=Дата(2017,7,14);
    иначе
    ДатаГр=Дата(2017,9,15);    
    Конецесли;
    
    Если ЭлементДанных.Дата>ДатаГр тогда 
        ОтправкаЭлемента = ОтправкаЭлементаДанных.Игнорировать;
        ПланыОбмена.УдалитьРегистрациюИзменений(ЭтотОбъект.Ссылка,ЭлементДанных);    
    Конецесли;    
КонецПроцедуры
 
 Рекламное место пустует
   Ёпрст
 
11 - 20.09.17 - 10:23
(10)
Воткни хотя бы возврат, если тип данных другой.
   Босечка
 
12 - 20.09.17 - 10:55
отладчик туда не входит и не работает ничего
   Ёпрст
 
13 - 20.09.17 - 10:58
Обмен по правилам ?
Если да, то проще это в праилах прописать и усё.
   Босечка
 
14 - 20.09.17 - 11:10
по правилам.
   Босечка
 
15 - 20.09.17 - 11:10
это понятно. Нон хотелось в плане...
   Fedor-1971
 
16 - 20.09.17 - 11:11
(10) Про справочники забыла, у них нет Даты
и да ЭлементДанных.Дата>ДатаГр - переносит данные не после, а ДО ДатаГр (знак поменяй для своего кода)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует