Вход | Регистрация


Исчезла кнопка "Заполнить" для ВПОТЧ БП 3.0.52.35

Исчезла кнопка "Заполнить" для ВПОТЧ БП 3.0.52.35
Я
   dkonakov
 
18.09.17 - 13:26
Добрый день, после обновления в документах исчезла кнопка "заполнить". Никто не сталкивался?
 
 
   ildary
 
1 - 18.09.17 - 14:10
(0) Извините, а что это за зверь такой - ВПОТЧ? Гугл и яндекс молчат.
   dkonakov
 
2 - 18.09.17 - 14:22
Пардон, внешние обработки табличных частей. Но я уже нашёл причину. Раньше в сведениях о внешней обработке было больше вольностей.
   vis_tmp
 
3 - 18.09.17 - 14:38
(2)Расскажи, что теперь надо там писать?
   ildary
 
4 - 18.09.17 - 14:46
(2) это свежий БСП счастье и радость нам приносит?
   vis_tmp
 
5 - 20.09.17 - 06:57
ТС пропал и не рассказал...
   dkonakov
 
6 - 20.09.17 - 18:19
(3) (4) Собственно, я раньше в СведенияхОВнешнейОбработке вызывал версию БСП текущей конфигурации. И всё работало. А теперь перестало, теперь нужно указывать версию БСП...
   dkonakov
 
7 - 20.09.17 - 18:26
Возможно, облегчу кому-то жизнь.

Было:
Функция СведенияОВнешнейОбработке() Экспорт
    
    ВерсияБСП = стандартныеподсистемысервер.версиябиблиотеки();
    ПараметрыРегистрации = Новый Структура;
    МассивНазначений = Новый Массив;
    МассивНазначений.Добавить("Документ.АктСверкиВзаиморасчетов");
    ПараметрыРегистрации.Вставить("Вид","ЗаполнениеОбъекта");
    ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
    ПараметрыРегистрации.Вставить("Версия", "1.0");
    ПараметрыРегистрации.Вставить("Наименование", "Заменить на УПД");
    ПараметрыРегистрации.Вставить("БезопасныйРежим", Ложь);
    ПараметрыРегистрации.Вставить("Информация", "Дополнительная обработка табличной части к документу АктСверкиВзаиморасчетов");
    ПараметрыРегистрации.Вставить("ВерсияБСП", ВерсияБСП);
    ТаблицаКоманд = Получить Таблицу Команд();
    ДобавитьКоманду(ТаблицаКоманд,
    "Заменить на УПД",
    "ЗаменитьНаУПД",
    "ЗаполнениеФормы", Ложь,,Истина);
    ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);
    Возврат ПараметрыРегистрации;
    
        
КонецФункции



Функция Получить Таблицу Команд()
  Команды = Новый ТаблицаЗначений;
  Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
  Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("Скрыть",Новый ОписаниеТипов("Булево"));
  Возврат Команды;
КонецФункции

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "",Скрыть=Ложь)
  НоваяКоманда = ТаблицаКоманд.Добавить();
  НоваяКоманда.Представление = Представление;
  НоваяКоманда.Идентификатор = Идентификатор;
  НоваяКоманда.Использование = Использование;
  НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
  НоваяКоманда.Модификатор = Модификатор;
  НоваяКоманда.Скрыть = Скрыть;
КонецПроцедуры


Стало:

Функция СведенияОВнешнейОбработке() Экспорт
    
    
    ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке("2.1.2.1");
    
    ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиЗаполнениеОбъекта();
    ПараметрыРегистрации.Версия = "1.0";
    ПараметрыРегистрации.Назначение.Добавить("Документ.АктСверкиВзаиморасчетов");
    
    НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
    НоваяКоманда.Представление = "Заменить на УПД";
    НоваяКоманда.Идентификатор = "ЗаменитьНаУПД";
    НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыЗаполнениеФормы();
    
    Возврат ПараметрыРегистрации;

    
    
КонецФункции
   Мисти
 
8 - 24.09.17 - 23:33
А как узнать, какая версия библиотеки?
У меня все внишние заполнения пропали только при переходе на новую платформу! Я еще не обновляла конфигурацию.
   Мисти
 
9 - 25.09.17 - 11:06
ау?
   dkonakov
 
10 - 28.09.17 - 10:50
(9) Версия бибилиотеки БСП? Пропишите у себя 2.1.2.1. должно заработать.
 
 Рекламное место пустует
   kalleka
 
11 - 06.10.17 - 16:50
Спасибо тебе, мил человек, за 5 минут проблему решил. И Яндексу за то что проиндексировал хорошо))

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует