Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Поле не найдено в СКД

Поле не найдено в СКД
Я
   serg-lom89
 
17.04.17 - 11:46
Добрый день


борюсь все с быстротой выполнения вывода СКД.
Сразу получаю первую схему компоновки.
Выполняю ее.

    
    МВТ = Новый МенеджерВременныхТаблиц;
    Запрос = Новый Запрос;
    Запрос.МенеджерВременныхТаблиц = МВТ;
    Запрос.Текст = МакетКомпоновки.НаборыДанных[0].Запрос;
    Для Каждого Параметр из МакетКомпоновки.ЗначенияПараметров Цикл
        Запрос.УстановитьПараметр(Параметр.Имя, Параметр.Значение);        
    КонецЦикла;
    РезультатЗапроса = Запрос.Выполнить();
    
    ТЗИтогКоличество =РезультатЗапроса.Выбрать();


Затем заполняю мою ТЗИтогКоличество .


Затем программно во вторую схему подставляю это результат как внешний набор данных.

    ВнешниеНаборыДанных = Новый Структура;
    ВнешниеНаборыДанных.Вставить("ОбъектСДанными", ТЗ_);

    ПроцессорКомпоновкиДанных.Инициализировать(МакетКомпоновки,ВнешниеНаборыДанных);


выполняю ,все выводит

Ставлю потом отбор какой нить и мне пишет

Ошибка компоновки макета
по причине:
Поле не найдено "Организация"
Хотя я строю по предприятию.

ЧЯДНТ?
 
 
   Buster007
 
1 - 17.04.17 - 11:48
Значит у тебя во вторую схему какое-то поле "организация" попало
   serg-lom89
 
2 - 17.04.17 - 11:51
(1) так я потом поля то сам заполняю
    КоллекцияПолей = СхемаКомпоновкиДанных.НаборыДанных[0].Поля;
    КоллекцияПолей.Очистить();
    
    
    
    
    
    
    
    
    
    
    Для каждого Колонка из   ТЗ_.Колонки Цикл
        ПолеНабора =     КоллекцияПолей.Добавить(Тип("ПолеНабораДанныхСхемыКомпоновкиДанных"));
        ПолеНабора.ПутьКДанным =  Колонка.Имя;
        ПолеНабора.Поле   =  Колонка.Имя;
    КонецЦикла;
   serg-lom89
 
3 - 17.04.17 - 11:51
СхемаКомпоновкиДанных = получитьМакет("МакетДанныхТЗ");
   serg-lom89
 
4 - 17.04.17 - 12:02
(1) и как найти это поле ?где оно храниться будет
   Buster007
 
5 - 17.04.17 - 12:10
Может схему приложишь 2ую?
   serg-lom89
 
6 - 17.04.17 - 12:11
(5) я схему программно строю...диаграмму программно вывожу
   Buster007
 
7 - 17.04.17 - 12:16
(6) Тогда тут сложно тебе чем-то помочь... "Ищите, Шура, ищите"
   serg-lom89
 
8 - 17.04.17 - 12:19
(7) что интересно получается

Когда я строю диаграмму,по предприятию,тогда работает отбор по предприятию и никакой другой отбор не работает.
Если я строю по организации,тогда отбор по организации работает и ни по каким другим отбором не работает.
   serg-lom89
 
9 - 17.04.17 - 12:34
вроде нашел...во второй схеме надо отборы убирать..счас буду тестить
   serg-lom89
 
10 - 17.04.17 - 13:43
первую проблему вроде поборол)))
    МВТ = Новый МенеджерВременныхТаблиц;
    Запрос = Новый Запрос;
    Запрос.МенеджерВременныхТаблиц = МВТ;
    Запрос.Текст = МакетКомпоновки.НаборыДанных[0].Запрос;
    Для Каждого Параметр из МакетКомпоновки.ЗначенияПараметров Цикл
        Запрос.УстановитьПараметр(Параметр.Имя, Параметр.Значение);        
    КонецЦикла;
    

    
    РезультатЗапроса = Запрос.Выполнить();
    
    ТЗИтогКоличество =РезультатЗапроса.Выбрать();
    



сейчас вот вторая....)))как максимально ускорить процесс выполнения?
 
 Рекламное место пустует

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует