Вход | Регистрация

1С:Предприятие ::

Метки: 

Печать многостраничных файлов TIF из внешней папки

Я
   Gaidar85
 
17.04.17 - 11:31
Здравствуйте!

Процедура ниже печатает справки прикрепленные к кодам серий номенклатуры из Реализации товаров, но есть и многостраничные файлы, 1с выводит теолько первую страницу таких файлов для печати, как вывести все страницы многостраничных TIF-ов?

Процедура ОсновныеДействияФормыПечать(Кнопка)
   
     Путь = "D:\Сканы TIFF\";
     ТипФайла = ".Tif";
     ТабДок =  Новый ТабличныйДокумент;      
     Для каждого стр из Товары цикл
        Если ЗначениеЗаполнено(стр.СерияНоменклатуры) Тогда
                       
              Макет = ПолучитьМакет("МакетКартинки");
               ОбластьКартинки = Макет.ПолучитьОбласть("ОбластьКартинка");
             Попытка
             Картинка = Новый Картинка(Путь+стр.СерияНоменклатуры.Код+ТипФайла);
               ОбластьКартинки.Рисунки.D1.Картинка = Картинка; 
             ТабДок.Вывести(ОбластьКартинки);    
              Исключение
             Продолжить;
              КонецПопытки;
          КонецЕсли;
      КонецЦикла;
      ТабДок.Показать();
КонецПроцедуры
 
 
   mistеr
 
1 - 17.04.17 - 11:59
(0) Либо разобрать на страницы, либо использовать внешнюю программу. IrfanView, например, умеет работать с многостраничными TIFF-ами.
   Gaidar85
 
2 - 17.04.17 - 13:03
Разобрать не получается , к каждой серии номенклатуры прикрепляется один файл.  Как вызывать IrfanView из 1с?
   mistеr
 
3 - 17.04.17 - 13:39
(2) Как обычно, КомандаСистемы()
   Gaidar85
 
4 - 17.04.17 - 16:34
Процедура ОсновныеДействияФормыПечатьPDF(Кнопка)
      МассивФайлов = Новый Массив;           
      Путь = "D:\Сканы TIFF\";
      ТипФайла = ".Tif";
      ТабДок =  Новый ТабличныйДокумент;      
      Для каждого стр из Товары цикл
          Если ЗначениеЗаполнено(стр.СерияНоменклатуры) Тогда
                             
                //Макет = ПолучитьМакет("МакетКартинки");

                 // ОбластьКартинки = Макет.ПолучитьОбласть("ОбластьКартинка");

                 Попытка
                 Картинка = Новый Картинка(Путь+стр.СерияНоменклатуры.Код+ТипФайла);
                 ЗапуститьПриложение("C:\Program Files\IrfanView\i_view64.exe "+СокрЛП(Путь+стр.СерияНоменклатуры.Код+ТипФайла)+"/resample /aspectratio /print", , Истина);
                  //ОбластьКартинки.Рисунки.D1.Картинка = Картинка; 

                //ТабДок.Вывести(ОбластьКартинки);     

                 Исключение
                 Сообщить("Строка №"+Стр.НомерСтроки+": "+ "не обнаружена справка" +" "+"для"+" "+стр.Номенклатура+", "+"код серии:"+" "+стр.СерияНоменклатуры.Код);
                 Продолжить;
                 КонецПопытки;
             КонецЕсли;
      КонецЦикла;
      ТабДок.Показать();
КонецПроцедуры

ЧИСЛО КОПИЙ ЗАДАТЬ НЕ МОГУ, В НАСТРОЙКАХ IrfanView НЕ СОХРАНЯЕТСЯ ЧИСЛО КОПИЙ
   Йохохо
 
5 - 17.04.17 - 16:51
а что делают вот эти ключи? "/resample /aspectratio /print"
   Gaidar85
 
6 - 17.04.17 - 18:34
Джа не знаю. пример из инета взял. Хотя пока нет необходимости в числе копий.


Список тем форума
Рекламное место пустует  
Программист всегда исправляет последнюю ошибку.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует