Вход | Регистрация

1С:Предприятие ::

Метки: 

Добавление колонок в ДанныеФормыКоллекция

Я
   Beuenj
 
17.04.17 - 07:49
Драсти. Не могу добавить колонки в таблицу которая лежит на управляемой форме. Пробовал разные варианты, не работает никак. Вот код на текущий момент:
    сч = 1;
    
    Для каждого СтрокаНастрек Из НастройкиЗагрузки Цикл
        Если Не ЗначениеЗаполнено(СтрокаНастрек.СсылкаНаДопРеквизит) Тогда Продолжить КонецЕсли; 
        ТЗ.Колонки.Добавить("к_" + сч, СтрокаНастрек.СсылкаНаДопРеквизит.ТипЗначения, СтрокаНастрек.НазваниеРеквизита, 10);
        сч = сч + 1;
    КонецЦикла;
    
    //теперь добавим нужное

    МассивКолонок = Новый Массив;
    Для каждого Колонка Из ТЗ.Колонки Цикл
        Если ИменаСтандартныхКолонк.Найти(Колонка.Имя) <> Неопределено Тогда Продолжить; КонецЕсли; 
        РеквизитФормы = Новый РеквизитФормы(Колонка.Имя, Колонка.ТипЗначения, "Данные", Колонка.Заголовок); 
        МассивКолонок.Добавить(РеквизитФормы); 
    КонецЦикла;
    Данные.Загрузить(ТЗ);
    ИзменитьРеквизиты(МассивКолонок);

ТЗ это таблица значений полученная методом
ТЗ = ДанныеФормыВЗначение(Данные, Тип("ТаблицаЗначений"));

ЗначениеВДанныеФормы делал это не к чему не приводит. Код отрабатывает без ошибок, в отладчике добавленные колонки видно, на форме колонок нет. Где может быть проблема?
 
  Рекламное место пустует
   Dmitry1c
 
1 - 17.04.17 - 07:54
(0) что-то не вижу кода, который добавляет колонки на управляемую форму. Вижу код, который добавляет колонки в реквизит формы "ДанныеФормыКоллекция"
   Beuenj
 
2 - 17.04.17 - 08:00
(1)Да вроде как планировалось что  ИзменитьРеквизиты(МассивКолонок); должен добавить колонки.
>>Вижу код, который добавляет колонки
До текущего момента думал, что это одно и тоже. А какой код добавит колонки в таблицу которая лежит на форме?
   Cyberhawk
 
3 - 17.04.17 - 08:11
"ИзменитьРеквизиты(МассивКолонок); должен добавить колонки" // Ошибаешься
   Cyberhawk
 
4 - 17.04.17 - 08:12
"какой код добавит колонки в таблицу которая лежит на форме?"

СП в помощь Элементы.Вставить
   Beuenj
 
5 - 17.04.17 - 08:29
(4)Тогда как я понял можно просто на сервере добавить колонки в таблицу значений, а потом на клиенте сделать "Элементы.Вставить" и в ИзменитьРеквизиты нет никакого смысла в данном конкретном случае?
   Cyberhawk
 
6 - 17.04.17 - 08:31
(5) Надо и то, и то делать
   Beuenj
 
7 - 17.04.17 - 11:10
(6)Непонятно какой тип должен быть у элемента. Нужен пример.
   Beuenj
 
8 - 17.04.17 - 11:20
(7)Все разобрался. Спасибо.


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует