Вход | Регистрация


Ширина колонок при формировании отчета

Ширина колонок при формировании отчета
Я
   Maniac
 
15.04.17 - 16:06
Есть отчет.
Формируется по макету.
Есть настройки отчета - таблица колонок.
У них есть настройка ширины.

В макете - унивесальная область выводимая по этому списку.

Надо чтобы при выводе секции у колонки была своя ширина.
Чота никак не получается!!!

В цикле пробежки по настройкам есть такой код

Макет.Область("Шапка|ДопКолонка").ШиринаКолонки = ДопКолонка.ШиринаКолонки;
            Секция = Макет.ПолучитьОбласть("Шапка|ДопКолонка");
            
            Секция.Параметры.ДопСвойство = ДопКолонка.Представление;    
            ТаблицаОтчета.Присоединить(Секция);


Но всегда почему то применяется ширина только последней строки в настройках
 
 
   RomanYS
 
1 - 15.04.17 - 17:06
если колонка уже выведена(например при выводе шапки) , то при присоединить ширина уже не будет браться из макета
   RomanYS
 
2 - 15.04.17 - 17:07
меняй ширину у областей выходного ТД, а не макета
   Maniac
 
3 - 15.04.17 - 17:14
Пытаюсь и так и так не получается
   Maniac
 
4 - 15.04.17 - 17:15
в (0) это до вывода Присоединить.
После тоже пробовал - не хочет
   Maniac
 
5 - 15.04.17 - 17:16
Вот так что то получается.
Но почему то все равно не та ширина что указываю (но все равно уже не одинаковая)

//Для Каждого ДопКолонка Из Объект.НастройкиКолонокЛиста Цикл

    //    ТекущаяОбласть = ТаблицаОтчета.НайтиТекст(ДопКолонка.Представление,,, Истина, Истина, Истина, Ложь);

    //    Если ТекущаяОбласть <> Неопределено Тогда    

    //        ТекущаяОбласть.ШиринаКолонки = ДопКолонка.ШиринаКолонки;

    //    КонецЕсли;    

    //КонецЦикла;
   Maniac
 
6 - 15.04.17 - 17:16
Это в самом конце даже пробую - после вообще полного вывода.

в (0) это при выводе шапки
   RomanYS
 
7 - 15.04.17 - 18:19
так работает?
Для инд = 1 по 10 Цикл
    ТаблицаОтчета.Область(,инд,,инд).ШиринаКолонки = инд;
КонецЦикла;
   Maniac
 
8 - 16.04.17 - 00:18
Да ! Спасибо. У меня там оказывается колонка была из двух ячеек))
И я не понимал почему почти тоже самое)
   Maniac
 
9 - 16.04.17 - 00:18
Пытаюсь найти теперь решение как форматированный документ можно было вывести в часть табличного.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует