Вход | Регистрация


Как посчитать количество записей в КорректировкаЗаписейРегистров?

Как посчитать количество записей в КорректировкаЗаписейРегистров?
Я
   gp42
 
15.04.17 - 06:55
Нужно посчитать количество записей в документе КорректировкаЗаписейРегистров, причем КорректировкаЗаписейРегистров делает движение только по одному регистру?

ВыборкаДок = Документы.КорректировкаЗаписейРегистров.Выбрать();
    Пока ВыборкаДок.Следующий() Цикл 
        об = ВыборкаДок.ПолучитьОбъект();
        ДвиженияКол = об.Движения.Количество();
        Для АА = 0 по об.Движения.Количество()-1 Цикл
            ДвиженияРег = Об.Движения.Получить(АА);
            Если Об.Движения.Получить(АА).Количество()>0 Тогда 
                Сообщить(""+Об.Движения.Получить(АА).Количество()+" "+об.Комментарий);
            КонецЕсли;
            
            
        КонецЦикла;

    КонецЦикла;




но не могу посчитать количество. Что не правильно ?
 
 
   Mankubus
 
1 - 15.04.17 - 07:37
Об.Движения.Получить(АА).Прочитать?
   Лефмихалыч
 
2 - 15.04.17 - 08:13
Выбрать Регистратор, Количество(НомерСтроки) как Уоличество
ИЗ РегистрНакопления.ЭтотТвойТолькоОДинРегистр
ГДЕ Регистратор ссылка Документ.КорректировкаЗаписейРегистров
и Активность
СГРУППИРОВАТЬ ПО Регистратор
   Лефмихалыч
 
3 - 15.04.17 - 08:15
Если еще и комментарий надо, то

Выбрать ВЫРАЗИТЬ(Регистратор как Документ.КорректировкаЗаписейРегистров) как Регистратор, Количество(НомерСтроки) как Уоличество 
ПОМЕСТИТЬ ВТ
ИЗ РегистрНакопления.ЭтотТвойТолькоОДинРегистр 
ГДЕ Регистратор ссылка Документ.КорректировкаЗаписейРегистров 
и Активность 
СГРУППИРОВАТЬ ПО Регистратор
;
ВЫБРАТЬ ВТ.Регистратор, ВТ.КОличество, ВТ.Регистратор.Комментарий
   gp42
 
4 - 15.04.17 - 08:47
Запрос к конкретному регистру это понятно
А я хотел через движения получить количество но только не получается (( почемуто.
   h-sp
 
5 - 15.04.17 - 12:21
(4) прочитать() забыл

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует