Вход | Регистрация



8.3 умножение в табличной части

8.3 умножение в табличной части
Я
   Котов Александр
 
14.04.17 - 21:20
Всем доброго времени суток!
Задача следующая, в 1С совсем не долго, 4 дня, особа набраться опыта времени не было, но пришлось в срочном порядке "липить" систему учета, поскольку не в какой особо не понимаю, взялся за 1С, ну или как то так.
На форуме впервые, долго копошится некогда - дело срочное, подскажите или дайте ссылку на решение вопроса. Админ не бань плиз
И так суть - есть 1С предприятие 8.3, есть в нем справочник, а в нем табличные части, а в них табличная часть1  в которой в свою очередь есть реквизиты , их  6. И так - Задача. два из них нужно перемножить и вывести в третий, во всех естественно тип-число, в форме вид-поле ввода. формулу использую следующую - "&НаКлиенте
Процедура ЛистЗаказаСуммаАвтоПодбор(Элемент, Текст, ДанныеВыбора, ПараметрыПолученияДанных, Ожидание, СтандартнаяОбработка)    
    Объект.ТабличнаяЧасть1.Сумма=Объект.ТабличнаяЧасть1.Количество*Объект.ТабличнаяЧасть1.Цена;
КонецПроцедуры"  
За ранние простите, если кому то смешно... Мне уже шестой час не смешно, не могу перемножить два значения....
 
 
   Котов Александр
 
1 - 14.04.17 - 21:22
Помогите пожалуйста. И еще вопрос - как и куда здесь фото сбросит?
   jsmith82
 
2 - 14.04.17 - 21:26
Прослезилсо
   Котов Александр
 
3 - 14.04.17 - 21:27
вот вообще не смешно....
   jsmith82
 
4 - 14.04.17 - 21:29
Что за событие странное? ЛистЗаказаАвтоПодбор
Это типа было так?
   jsmith82
 
5 - 14.04.17 - 21:29
Почему имя табличной части в имени события разнится с табличной частью в коде?
   jsmith82
 
6 - 14.04.17 - 21:31
&НаКлиенте
Процедура ТабличнаяЧасть1КоличествоПриИзменении(Элемент)

    СтрокаТаблицы = Элементы.ТабличнаяЧасть1.ТекущиеДанные;
    СтрокаТаблицы.Сумма = СтрокаТаблицы.Количество * СтрокаТаблицы.Цена;

КонецПроцедуры

   Котов Александр
 
7 - 14.04.17 - 21:33
по событию - Вызывается во время начала ожидания ввода текста
АвтоПодбор, AutoComplete
   Котов Александр
 
8 - 14.04.17 - 21:35
не проканал код, ошибки нет, но и сумма не меняется(
   ГеннадийУО
 
9 - 14.04.17 - 21:36
(0) Да ладно, русский языка велика и могуч?
   Котов Александр
 
10 - 14.04.17 - 21:37
whatsapp +375 25 504 45 97
 
 Рекламное место пустует
   ГеннадийУО
 
11 - 14.04.17 - 21:38
(10) Ну или как-то так...
   Котов Александр
 
12 - 14.04.17 - 21:49
при изменении автоматически создает следующую процедуру 
===>
&НаКлиенте
Процедура ЛистЗаказаЦенаПриИзменении(Элемент)
    // Вставить содержимое обработчика.

КонецПроцедуры
   Котов Александр
 
13 - 14.04.17 - 21:53
Я испробовал все варианты кроме правильных, в основном либо ничего не работает и о не выдает не ошибки не результата, лил пишет что то   типа --- Элементы.ЛистЗаказаЦена.ТекущиеДанные    {(1)}: Поле объекта не обнаружено (ТекущиеДанные)
   h-sp
 
14 - 14.04.17 - 22:58
Элементы.ЛистЗаказа.ТекущиеДанные
   Котов Александр
 
15 - 14.04.17 - 23:32
СПАСИБО!!!! Тебе - добрый человек!!!!
   Котов Александр
 
16 - 14.04.17 - 23:33
Оставь хоть какие то координаты - скажу  спасибо!
   Котов Александр
 
17 - 14.04.17 - 23:33
По процедуре
работает
&НаКлиенте
Процедура  ЛистЗаказаСуммаАвтоПодбор(Элемент, Текст, ДанныеВыбора, ПараметрыПолученияДанных, Ожидание, СтандартнаяОбработка)
     СтрокаТаблицы = Элементы.ЛистЗаказа.ТекущиеДанные;
    СтрокаТаблицы.Сумма = СтрокаТаблицы.Количество * СтрокаТаблицы.Цена;
КонецПроцедуры
   Котов Александр
 
18 - 14.04.17 - 23:35
но все ровно не так как надо.
   trooba
 
19 - 14.04.17 - 23:36
(18) Что не правильно?
   jsmith82
 
20 - 14.04.17 - 23:36
Какой нафиг АвтоПодбор?!
   jsmith82
 
21 - 14.04.17 - 23:37
&НаКлиенте 
Процедура ЛистЗаказаЦенаПриИзменении(Элемент)
     
    СтрокаТаблицы = Элементы.ЛистЗаказа.ТекущиеДанные;
       СтрокаТаблицы.Сумма = СтрокаТаблицы.Количество * СтрокаТаблицы.Цена;

КонецПроцедуры
   jsmith82
 
22 - 14.04.17 - 23:37
Такую же шляпу прилепи на событие Изменение поля Количество
   Котов Александр
 
23 - 14.04.17 - 23:38
&НаКлиенте
Процедура ЛистЗаказаЦенаОкончаниеВводаТекста(Элемент, Текст, ДанныеВыбора, ПараметрыПолученияДанных, СтандартнаяОбработка)
    СтрокаТаблицы = Элементы.ЛистЗаказа.ТекущиеДанные;
    СтрокаТаблицы.Сумма = СтрокаТаблицы.Количество * СтрокаТаблицы.Цена;
КонецПроцедуры
 вводимые данные 
кол. -3
цена -44 444
сумма 3 333
   Котов Александр
 
24 - 14.04.17 - 23:39
та же шляпа и если 
цена 3 333
   jsmith82
 
25 - 14.04.17 - 23:39
йомана...
   jsmith82
 
26 - 14.04.17 - 23:40
удали все эти процедуры. из палитры свойств тоже
создай процедуры при изменении количества и цены
код уже есть
   Котов Александр
 
27 - 14.04.17 - 23:40
кол -3
цен -2 
сумма -666
=)
   Котов Александр
 
28 - 14.04.17 - 23:41
фишка в том что хочу поле сумма "вид - поле надпись"
по симу при завершении "Вызывается после ввода текста при сходе с элемента управления
ОкончаниеВводаТекста, TextEditEnd" и вставляю процедуру =)
   Котов Александр
 
29 - 14.04.17 - 23:43
т.е. предпоследняя колонка активирует процедуру по сумме и вписывает ее в последнюю
   Котов Александр
 
30 - 14.04.17 - 23:45
вот так оказываться проще))))
НаКлиенте
Процедура ЛистЗаказаЦенаПриИзменении(Элемент)
    СтрокаТаблицы = Элементы.ЛистЗаказа.ТекущиеДанные;
    СтрокаТаблицы.Сумма = СтрокаТаблицы.Количество * СтрокаТаблицы.Цена;
КонецПроцедуры
   Котов Александр
 
31 - 14.04.17 - 23:45
и все работает)))
   Котов Александр
 
32 - 14.04.17 - 23:46
один минус, когда меняю количество не работает))
   Котов Александр
 
33 - 14.04.17 - 23:49
Вставил и там и там, все работает корректно!))) Еще раз - СПАСИБО!
&НаКлиенте
Процедура ЛистЗаказаЦенаПриИзменении(Элемент)
    СтрокаТаблицы = Элементы.ЛистЗаказа.ТекущиеДанные;
    СтрокаТаблицы.Сумма = СтрокаТаблицы.Количество * СтрокаТаблицы.Цена;
КонецПроцедуры

&НаКлиенте
Процедура ЛистЗаказаКоличествоПриИзменении(Элемент)
    СтрокаТаблицы = Элементы.ЛистЗаказа.ТекущиеДанные;
    СтрокаТаблицы.Сумма = СтрокаТаблицы.Количество * СтрокаТаблицы.Цена;
КонецПроцедуры
 
 
   Котов Александр
 
34 - 14.04.17 - 23:52
Или Все это можно как то проще записать?
   trooba
 
35 - 15.04.17 - 00:02
(34) Ложись спать, теоретик
   Котов Александр
 
36 - 15.04.17 - 00:12
Да Я бы с радостью, но еще пилить и пилить))
   Котов Александр
 
37 - 15.04.17 - 00:14
Господа, есть предложение, можно на удаленке))) whatsapp +375 25 504 45 97
   Mankubus
 
38 - 15.04.17 - 07:42


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует