Вход | Регистрация

1С:Предприятие ::

Метки: 

Изменение правил обмена для СинхронизацияДанныхЧерезУниверсальныйФормат

Я
   AceVi
 
14.04.17 - 13:01
Добрый день, просвятите пожалуйста.
Для любого стандартного плана обмена в макетах есть "ПравилаОбмена" которые мы можем отредактировать в "Конвертации данных 2.0".
А для СинхронизацияДанныхЧерезУниверсальныйФормат - правил нет есть только "ПравилаРегистрации".
Вопрос - где достать отредактировать и потом применить Правила обмена для универсального формата?
В кратце сама задача - наладить обмен между ERP и Бух3.0. Я хочу воспользоваться стандартным механизмом обмена потому что он поддерживает обработку "СопоставлениеОбъектовБаз".
Что я сделал - в меню синхронизации создал новую синхронизацию и т.к. правил ERP->Бух3.0 нет , зашел в универсальный формат - и там этот обмен есть.
Правильным ли путем я пошел? Можно написать свои правила обмена , но тогда я не смогу воспользоваться обработкой сопоставления? или смогу? Если я создам свой ПланОбмена, напишу для него свои правила , для этих правил будет работать обработка сопоставления?
 
 
   rozer76
 
1 - 14.04.17 - 13:11
ставишь кд3, там при запуске все рассказано как получить источник и приемник из хдто и модуля обмена данными
   MaxS
 
2 - 14.04.17 - 13:48
(0) Вы попробуйте для начала воспользоваться типовым функционалом, доработайте правила обмена если типовые не работают. В типовом обмене есть сопоставление и не зависит от того кто сделал правила.
И только потом делайте новый план обмена. Правда непонятно зачем. В любом случае если делать по документации на БСП, то и там будет сопоставление.
   AceVi
 
3 - 14.04.17 - 14:04
(2) Вы не поняли вопроса) Типовые правила работают, но например я хочу что бы физ лица не перезаписывались если они найдены(по уид или сопоставлению) в базе приемнике. А в стандартных правилах каждый справочник перезаписываеться. В КД2.0 есть галки для ПКО на эту тему.
И как раз механизм сопоставления мне нужен, но что то я хочу поменять, или скажем добавить новый придуманный мной справочник? как это сделать когда правил обмена я не нашел) (1) Ок попробую поставить КД3.0 сильно ли она отличается от 2.0? Много ли надо времени тому кто работал с 2.0 что бы освоить хотя бы базовый функционал 3.0?
   MaxS
 
4 - 14.04.17 - 14:19
(3) Дарю код
Функция НеЗамещатьСуществующий(ДанныеИБ, ПолученныеДанные)
    Если НЕ ДанныеИБ=Неопределено Тогда// Не замещать существующие объекты в приемнике при загрузке, а только создавать новые и заполнять их

        ПолученныеДанные = Неопределено;
        Возврат Истина;
    КонецЕсли;
    Возврат Ложь;
КонецФункции

Процедура ПКО_Справочник_ЕдиницыИзмерения_ПередЗаписьюПолученныхДанных(ПолученныеДанные, ДанныеИБ, КонвертацияСвойств, КомпонентыОбмена)
//...

    НеЗамещатьСуществующий(ДанныеИБ, ПолученныеДанные);
КонецПроцедуры

Правила обмена для КД3 есть. Отличается сильно. Если учиться методом научного тыка, то долго. Если на курсах, то 2 недели.
   AceVi
 
5 - 14.04.17 - 15:16
(4) Лучше подскажи где достать стандартные правила.
Я скачал КД 3 выгрузил из Бух EnterpriseData_1_0_beta загрузил все это в кд 3 - ну ок создалась конфигурация - но конвертация не создалась - где тогда достать именно стандартную конвертацию, чт о бы ее поправить а не  делать с 0.
   AceVi
 
6 - 14.04.17 - 15:32
(5) И вопрос в догонку - я смотрю ПКО в КД3 есть реквизит "Объект Формата" - а если я создал новый справочник , то его в этом реквизите нет, а как добавить?
   MaxS
 
7 - 14.04.17 - 16:49
(5) Нужно пересилить себя и прочитать наконец, то справку(текст первой страницы при открытии) в КД3.
EnterpriseData_1_0_beta не нужна. Лучше загрузить последнюю версию формата, который есть в обеих базах. Если в одной есть 1.4, в другой 1.3, то загружать 1.3.
Для начала можно попытаться научиться переносить нетиповой справочник каким-нибудь типовым объектом формата. Как придёт понимание, можно переходить к доработке формата обмена. Но это уже будет не совсем универсальный формат.
   MaxS
 
8 - 14.04.17 - 16:51
см. Конвертации - Загрузка правил синхронизации из файлов
   AceVi
 
9 - 14.04.17 - 17:01
(8) Смотрю. а кто подсказал бы быстрее было бы)


Список тем форума
Рекламное место пустует  
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует