Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Ошибка при возврате с сервера булево

Ошибка при возврате с сервера булево
Я
   Тюка
 
13.04.17 - 15:19
Добрый день. Покажите мне где у меня ошибка.
Из клиента ухожу на сервер, при попытки вернуться обратно ошибка
Ошибка при вызове метода контекста (ПолучитьИзХр)
    Рез=ПолучитьИзХр(ДанныеРасшифровки,Число(Расшифровка));
по причине:
Ошибка передачи данных между клиентом и сервером. Значение недопустимого типа.
по причине:
Ошибка преобразования данных XDTO:
НачалоСвойства: param    Форма: Элемент    Тип: {http://www.w3.org/2001/XMLSchema}anyType
по причине:
Ошибка отображения типов:
Отсутствует отображение для типа '{http://v8.1c.ru/8.1/data-composition-system/details}DetailsInformation'

ДанныеРасшифровки-строка
Расшифровка-число
Рез-булево, значение ему присваивается



&НаКлиенте
Процедура РезультатОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)
    
    СтандартнаяОбработка=Ложь;    
    
    Рез=ПолучитьИзХр(ДанныеРасшифровки,Число(Расшифровка));
    

        Сообщить("ляляля");
    
КонецПроцедуры

&НаСервере
Функция ПолучитьИзХр(ДанныеРасшифровки,Расшифровка)
    
     ДанныеРасшифровки         = ПолучитьИзВременногоХранилища(ДанныеРасшифровки);
     Поле = ДанныеРасшифровки.Элементы[Расшифровка].ПолучитьПоля()[0];
     
     Если  Поле.Поле="ПризнакОплаты" Тогда
         Рез=Истина;
     Иначе
        Рез=Ложь;  
     КонецЕсли;
    
    Возврат Рез;

     
КонецФункции;
 
 
   Тюка
 
1 - 13.04.17 - 15:27
это происходит в форме отчета на скд
   undertaker
 
2 - 13.04.17 - 15:29
надо попробовать или так
Функция ПолучитьИзХр(Знач ДанныеРасшифровки,Расшифровка)

или же переимновать переменную
ДанныеРасшифровки = ПолучитьИзВременногоХранилища(ДанныеРасшифровки);
   Вафель
 
3 - 13.04.17 - 15:29
у тебя сама расшифровка как-то передается туда-сюда
   Тюка
 
4 - 13.04.17 - 15:33
(2),(3) Ребята точно. Сама только что заметила. 30 мин до конца рабочего дня, уже мозг кипит.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует