Вход | Регистрация


Подсчет просроченных задач

Подсчет просроченных задач
Я
   falselight
 
13.04.17 - 07:58
Делаю подсчет количества просроченных задач.
Это когда СтрТз.ДатаВыполненияПланово меньше
ДатаВыполненияФактически или текущей даты.

делаю это после перебора запроса циклом, но как это сделать
в запросе?

То есть выбрать данные где СтрТз.ДатаВыполненияПланово меньше
ДатаВыполненияФактически или текущей даты.
И на сколько дней ещё вывести?

||
        Если ЗначениеЗаполнено(СтрТз.ДатаВыполненияФактически) Тогда
            Если НачалоДня(СтрТз.ДатаВыполненияПланово) >= НачалоДня(СтрТз.ДатаВыполненияФактически) Тогда
                Продолжить;
            КонецЕсли;
        Иначе
            Если НачалоДня(СтрТз.ДатаВыполненияПланово) >= НачалоДня(ТекущаяДата()) Тогда
                Продолжить;
            КонецЕсли;
        КонецЕсли;
 
 
   DrShad
 
1 - 13.04.17 - 09:20
запрос покажи

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует