Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

УПП - открытие изображения номенклатуры в браузере

УПП - открытие изображения номенклатуры в браузере
Я
   Нечай
 
12.04.17 - 22:50
Создал табличную часть в номенклатуре, в ней 2 реквизита, И_Изображение - в котором прописывается путь к файлу.

Выглядит так - скрин №1
https://yadi.sk/i/qKalwupn3GurAi

Добавил на форму элемента номенклатуры таблицу.
Выглядит так - скрин №2
https://yadi.sk/i/FBEJlNU73GurBT

Так это выглядит из под пользователя.
https://yadi.sk/i/DCEA0y3a3GurC3

Как мне сделать так, чтобы по нажатию на строку, где прописан путь, автоматически открывался браузер (либо Explorer, или Firefox) и сразу обращался на этот путь, соответственно и открывалась там картинка.
 
 
   CepeLLlka
 
1 - 12.04.17 - 22:58
(0)
Выполнить("путь к Iexplorer.exe с параметрами.")
   Нечай
 
2 - 12.04.17 - 23:11
А в каком событии это лучше всего сделать?

Пробовал через:
ЗапуститьПриложение("C:\Program Files (x86)\Internet Explorer\iexplore.exe Стр.И_Изображение");
Вроде все хорошо, только не получается вытащить из табличной части именно тот путь по которому нажимали.

Попробовал через:
Выполнить("C:\Program Files (x86)\Internet Explorer\iexplore.exe Стр.И_Изображение");

пишет Неопознанный оператор, что я тут не так сделал?
   AneJIbcuH
 
3 - 13.04.17 - 05:40
(2) Можно например так, у строки ТЧ в колонке И_Изображение  на форме, указать, что должна быть "кнопкаОткрытия", далее событие - "Открытие". Ну а там примерно такой код:

СтандартнаяОбработка = Ложь;
    
Если Не ПустаяСтрока(Элемент.Значение) Тогда
ЗапуститьПриложение("C:\Program Files (x86)\Internet Explorer\iexplore.exe Элемент.Значение");
        
КонецЕсли;
   Нечай
 
4 - 13.04.17 - 10:22
AneJIbcuH спасибо, так работает!)))
Только не получается вытянуть те данные которые в этой строке.
Пробовал Элемент.Значение, ТекущийЭлемент.Значение, ЭлементыФормы.ТабличноеПоле1.ТекущаяСтрока.И_Изображение.

Не получается.
   AneJIbcuH
 
5 - 13.04.17 - 11:09
(4) В какой этой строке? Не совсем понятно, что хочешь сделать и какое событие использовать.
   Нечай
 
6 - 13.04.17 - 11:15
Вот событие, то о котором ты написал.
https://yadi.sk/i/q7PUR0Fv3GvWmH

Вот код:
https://yadi.sk/i/kbTuqoal3GvWpD
   AneJIbcuH
 
7 - 13.04.17 - 11:26
(6) Если используешь данное событие, то пиши код как в (3).
Далее в пользовательском режиме, должна появиться такая кнопка: http://joxi.ru/zANG4B4UpnaWr9 при нажатии на нее открывает в браузере то что надо?
   Нечай
 
8 - 13.04.17 - 11:29
Хочу нажать на лупу, и что открылся Explorer и в него подставился тот путь который указан в той строчке которая выбрана.

https://yadi.sk/i/WsBrGXsQ3GvYK7
   Нечай
 
9 - 13.04.17 - 11:33
Да да, кнопка появилось все хорошо, если ручками пропишу путь то все открывается, а вот подставить тот путь который указан в строке не получается.
Если пишу Элемент.Значение - вот что получается
https://yadi.sk/i/dIdtWOEE3GvYzv
   AneJIbcuH
 
10 - 13.04.17 - 11:34
(8) В Элемент.Значение уже тот путь, который тебе нужен.
Проблема в "ЗапуститьПриложение("C:\Program Files (x86)\Internet Explorer\iexplore.exe Элемент.Значение")"

Попробуй в этом событии такой код написать:

СтандартнаяОбработка = Ложь;
    
Если Не ПустаяСтрока(Элемент.Значение) Тогда
        
НовыйФайл = Новый Файл(СокрЛП(Элемент.Значение));
        
Если НовыйФайл.Существует() Тогда
ЗапуститьПриложение("""" + НовыйФайл.ПолноеИмя + """");
        Иначе
            Сообщить("Файл """ + НовыйФайл.ПолноеИмя + """ не найден!", СтатусСообщения.Важное);
            Предупреждение("Файл не найден!");
        КонецЕсли;
 
 Рекламное место пустует
   AneJIbcuH
 
11 - 13.04.17 - 11:35
(10) Это должно открыть твою картинку, но не в браузере.
   AneJIbcuH
 
12 - 13.04.17 - 11:36
А там надо так:
СсылкаНаИз = "C:\Program Files (x86)\Internet Explorer\iexplore.exe" + " " + Элемент.Значение;

ЗапуститьПриложение(СсылкаНаИз )
   Нечай
 
13 - 13.04.17 - 11:55
Супер, работает и то и то). Спасибо большое!)
Сейчас протестирую на сервере.
А вопрос такой, 1 вариант будет ли открывать и картинки и pdf файлы. Тоесть у меня 2 варианта, путь к картинке и путь к pdf.
   AneJIbcuH
 
14 - 13.04.17 - 11:59
(13) Так попробуй и скажи!
   Нечай
 
15 - 14.04.17 - 11:27
Работает, спасибо большое)
   Нечай
 
16 - 23.04.17 - 18:06
Всем привет, подскажите еще пожалуйста,
как сделать так, чтобы при добавлении открывалось окошко и там выбирали файл(изображение или пдф) после чего, путь к этому файлу записывался.
   AneJIbcuH
 
17 - 24.04.17 - 06:18
(16) Если в ТЧ, то выбери событие "НачалоВыбора", там СтандартнаяОбработка = Ложь;

Далее запускаешь диалог выбора файла (Со своим фильтром расширений):

ДиалогВыбораФайла =    Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    ДиалогВыбораФайла.Фильтр                  =    "Файлы изображений JPEG (*.jpg)|*.jpg;*.jpeg";
    ДиалогВыбораФайла.Заголовок               =    "Выберите файл изображения";
    ДиалогВыбораФайла.ПредварительныйПросмотр =    Истина;
    ДиалогВыбораФайла.Расширение              =    "jpg";
    ДиалогВыбораФайла.ИндексФильтра           =    0;
    ДиалогВыбораФайла.ПроверятьСуществованиеФайла =    Ложь;
    
    Если Не ДиалогВыбораФайла.Выбрать() Тогда
        Возврат;
    КонецЕсли;
    
ИмяФайла = ДиалогВыбораФайла.ПолноеИмяФайла;

//Вот в ИмяФайла будет полный путь до твоего файла, его присваиваешь строке ТЧ
   Нечай
 
18 - 25.04.17 - 13:27
Спасибо еще раз) Работает!)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует