Вход | Регистрация


Обновление Бухгалтерии 3.0 для Казахстана

Обновление Бухгалтерии 3.0 для Казахстана
Я
   alekosansey
 
12.04.17 - 14:11
Добрый день. Ведем разработку 1с для своего предприятия. Пишем через хранилище конфигураций. Пришло время обновляться. Захватил я все объекты конфигурации выбрал пункт обновить конфигурацию. Все обновилось, но при запуске 1с предприятия выскакивает ошибка причем на типовой код({ОбщийМодуль.ПользователиКлиентСервер.Модуль(24)}: Поле объекта не обнаружено (АвторизованныйПользователь)Возврат СтандартныеПодсистемыКлиентПовтИсп.ПараметрыРаботыКлиентаПриЗапуске().АвторизованныйПользователь;))). Что может быть? Куда копать ? Заранее благодарен за ответ. Код поставщика не трогается и конфа стоит на поддержке.
 
 
   catena
 
1 - 12.04.17 - 14:13
А что там в СтандартныеПодсистемыКлиентПовтИсп.ПараметрыРаботыКлиентаПриЗапуске()?
   alekosansey
 
2 - 12.04.17 - 14:15
#Область ПрограммныйИнтерфейс


// Возвращает структуру параметров, необходимых для работы

// конфигурации на клиенте при запуске, т.е. в обработчиках событий.
// - ПередНачаломРаботыСистемы,

// - ПриНачалеРаботыСистемы
//

// Важно: при запуске недопустимо использовать команды сброса кэша
// повторно используемых модулей, иначе запуск может привести

// к непредсказуемым ошибкам и лишним серверным вызовам.
// 

// Возвращаемое значение:
//   ФиксированнаяСтруктура - структура параметров работы клиента при запуске.

//
Функция ПараметрыРаботыКлиентаПриЗапуске() Экспорт
    
    ИмяПараметра = "СтандартныеПодсистемы.ПараметрыПриЗапускеИЗавершенииПрограммы";
    Если ПараметрыПриложения[ИмяПараметра] = Неопределено Тогда
        ПараметрыПриложения.Вставить(ИмяПараметра, Новый Структура);
    КонецЕсли;
    ПараметрыПриЗапускеИЗавершенииПрограммы = ПараметрыПриложения["СтандартныеПодсистемы.ПараметрыПриЗапускеИЗавершенииПрограммы"];
    
    Параметры = Новый Структура;
    Параметры.Вставить("ПолученныеПараметрыКлиента", Неопределено);
    
    Если ПараметрыПриЗапускеИЗавершенииПрограммы.Свойство("ПолученныеПараметрыКлиента")
       И ТипЗнч(ПараметрыПриЗапускеИЗавершенииПрограммы.ПолученныеПараметрыКлиента) = Тип("Структура") Тогда
        
        Параметры.Вставить("ПолученныеПараметрыКлиента",
            ПараметрыПриЗапускеИЗавершенииПрограммы.ПолученныеПараметрыКлиента);
    КонецЕсли;
    
    Если ПараметрыПриЗапускеИЗавершенииПрограммы.Свойство("ПропуститьОчисткуСкрытияРабочегоСтола") Тогда
        Параметры.Вставить("ПропуститьОчисткуСкрытияРабочегоСтола");
    КонецЕсли;
    
#Если ВебКлиент Тогда

    ЭтоВебКлиент = Истина;
#Иначе

    ЭтоВебКлиент = Ложь;
#КонецЕсли

    
    СистемнаяИнформация = Новый СистемнаяИнформация;
    ЭтоLinuxКлиент = СистемнаяИнформация.ТипПлатформы = ТипПлатформы.Linux_x86
                  ИЛИ СистемнаяИнформация.ТипПлатформы = ТипПлатформы.Linux_x86_64;

    Параметры.Вставить("ПараметрЗапуска", ПараметрЗапуска);
    Параметры.Вставить("СтрокаСоединенияИнформационнойБазы", СтрокаСоединенияИнформационнойБазы());
    Параметры.Вставить("ЭтоВебКлиент",         ЭтоВебКлиент);
    Параметры.Вставить("ЭтоВебКлиентПодMacOS", ОбщегоНазначенияКлиентПовтИсп.ЭтоВебКлиентПодMacOS());
    Параметры.Вставить("ЭтоLinuxКлиент",       ЭтоLinuxКлиент);
    Параметры.Вставить("СкрытьРабочийСтолПриНачалеРаботыСистемы", Ложь);
    
    СистемнаяИнформация = Новый СистемнаяИнформация;
    ОперативнаяПамять = Окр(СистемнаяИнформация.ОперативнаяПамять / 1024, 1);
    Параметры.Вставить("ОперативнаяПамять", ОперативнаяПамять);
    
    ПараметрыКлиента = СтандартныеПодсистемыВызовСервера.ПараметрыРаботыКлиентаПриЗапуске(Параметры);
    
    // Обновление состояния скрытия рабочего стола на клиенте по состоянию на сервере.

    СтандартныеПодсистемыКлиент.СкрытьРабочийСтолПриНачалеРаботыСистемы(
        Параметры.СкрытьРабочийСтолПриНачалеРаботыСистемы, Истина);
    
    Возврат ПараметрыКлиента;
    
КонецФункции
   catena
 
3 - 12.04.17 - 14:18
(2)Что возвращает? В ПараметрыКлиента что лежит?
   alekosansey
 
4 - 12.04.17 - 14:31
КлючИЗначение    КлючИЗначение    "РазделениеВключено"    Ложь
КлючИЗначение    КлючИЗначение    "ДоступноИспользованиеРазделенныхДанных"    Истина
КлючИЗначение    КлючИЗначение    "ЭтоРазделеннаяКонфигурация"    Истина
КлючИЗначение    КлючИЗначение    "ЕстьДоступДляОбновленияВерсииПлатформы"    Истина
КлючИЗначение    КлючИЗначение    "ИменаПодсистем"    ФиксированноеСоответствие
КлючИЗначение    КлючИЗначение    "МинимальноНеобходимаяВерсияПлатформы"    "8.3.4.365"
КлючИЗначение    КлючИЗначение    "РаботаВПрограммеЗапрещена"    Ложь
КлючИЗначение    КлючИЗначение    "РекомендуемыйОбъемОперативнойПамяти"    2
КлючИЗначение    КлючИЗначение    "ТребуетсяПоказРекомендацииПоОбъемуОперативнойПамяти"    Ложь
КлючИЗначение    КлючИЗначение    "ОпцииИнтерфейса"    ФиксированнаяСтруктура
КлючИЗначение    КлючИЗначение    "НеобходимоОбновлениеПараметровРаботыПрограммы"    
КлючИЗначение    КлючИЗначение    "ИнформационнаяБазаФайловая"    Истина
   alekosansey
 
5 - 12.04.17 - 14:32
Up
   catena
 
6 - 12.04.17 - 14:34
(5)Ну что - ап? Ты же видишь, что нет там АвторизованныйПользователь?
   alekosansey
 
7 - 12.04.17 - 14:40
Но я же захожу под Администратором
   alekosansey
 
8 - 12.04.17 - 14:40
?
   catena
 
9 - 12.04.17 - 14:42
(7)ээ... И что? Это как-то противоречит тому, что там нет? АвторизованныйПользователь? У тебя ругается, что его нет. Либо про него забыли. Либо он недоустанавливается. Либо звони в сапу, либо лезь дальше в процедуру заполнения и смотри, где он там определяется/не определяется.
   alekosansey
 
10 - 12.04.17 - 14:46
все понял. Спасибо. В сапорт отправил запрос жду ответа. Пока буду ждать буду смотреть куда он ссылается. Спасибо за помощь
 
 Рекламное место пустует

Список тем форума
Рекламное место пустует  Рекламное место пустует
Миста — веселый ресурс со своими эксклюзивными тараканами Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует