Вход | Регистрация

1С:Предприятие ::

Метки: 

Конвертация данных: перенос документа в почти идентичную конфигурацию

Я
   Den_aka_Den
 
11.04.17 - 14:47
Делаю перенос документа с одной базы в другую. Использую  КД 2.1.6.2
Базы почти идентичные УТП для Казахстана, различаются только версиями. Переношу конкретно документ Реализация, а загружаю его как поступление. Не смог сам разобраться с двумя моментами:
1.    В справочнике Номенклатура не переносятся реквизиты: ЕдиницаХраненияОстатков и ЕдиницаДляОтчетов (тип СправочникСсылка.ЕдиницыИзмерения). Сам справочник ЕдиницыИзмерения подчинен Номенклатуре и нужные элементы справочника загружаются, но в реквизиты номенклатуры не попадают. В чем может быть проблема и как исправить?
2.    В подчинении справочнику Номенклатуры есть справочник Штрихкоды. По ссылкам эти штрих-коды не загружаются (ссылок просто нет). Как сделать чтобы по всем выгруженным товарам выгружались так же штрих-коды?
 
 
   Den_aka_Den
 
1 - 11.04.17 - 19:06
up
   Cyberhawk
 
2 - 11.04.17 - 19:07
А ты там кем? Сколько платят за решение вопроса?
   Vlad_69
 
3 - 11.04.17 - 19:36
Пример из книги Бояркина/Филатова смотрели?
Что в ПКС для реквизита "ЕдиницаХраненияОстатков" справочника "Номенклатура" и соответственно в ПКС для "Владелец" справочника "ЕдиницыИзмерения" ?
   Обработка
 
4 - 11.04.17 - 20:17
(0) Начни с переноса справочника номенклатуры для начала.
И каке версии у конф? Обычно принято говорить релизы.
А версия это уж платформа.
   Черный маклер
 
5 - 11.04.17 - 21:18
(0) можно в ПКО Номенклатура в ПриВыгрузке что-нить вроде
Выборка = Справочники.ЕдиницыИзмерения.Выбрать( , Источник); 
Пока Выборка.Следующий() Цикл
    ВыгрузитьПоПравилу(Выборка.Ссылка,,,,"ЕдиницыИзмерения");
КонецЦикла;
   Den_aka_Den
 
6 - 11.04.17 - 23:11
(3)
Такой книги к сожалению у меня нет.
В ПКС для реквизита "ЕдиницаХраненияОстатков" справочника "Номенклатура": ЕдиницыИзмерения
А в ПКС для "Владелец" справочника "ЕдиницыИзмерения": пусто.
Для выбора доступны два правила: Номенклатура и НоменклатурныеГруппы.
Похоже в этом и дело что ЕдиницыИзмерения подченины не только Номенклатуре.

(4) Мне не нужна вся номенклатура. Нужна только та что в документах. Версии такие: источник УправлениеТорговымПредприятиемДляКазахстана 2.0.3.6
приемник УправлениеТорговымПредприятиемДляКазахстана 2.0.10.7. В прочем не знаю чем это может помочь.
   Den_aka_Den
 
7 - 11.04.17 - 23:17
(5) Спасибо помогло. Но не для единиц измерения, а для Штрихкодов. Которые к тому же оказались не справочником, а регистром сведений :)
Код переделал вот так:
Если Не Источник.ЭтоГруппа Тогда
    ОтборПоВладельцу = Новый Структура("Владелец");
    ОтборПоВладельцу.Владелец = Источник;
    Выборка = РегистрыСведений.Штрихкоды.Выбрать(ОтборПоВладельцу);
    Пока Выборка.Следующий() Цикл
        ВыгрузитьПоПравилу(Выборка,,,,"Штрихкоды");
    КонецЦикла;
КонецЕсли;
   Den_aka_Den
 
8 - 12.04.17 - 08:08
По первому вопросу тоже нашел решение, сдесь же на форме.
Нужно было в ПКО ЕдиницыИзмерения ПередВыгрузкой прописать:

Если Правила.Номенклатура.Выгруженные[Источник.Владелец] = Неопределено Тогда
    ВыгрузитьПоПравилу(Источник.Владелец);
КонецЕсли;
   Йохохо
 
9 - 12.04.17 - 08:27
(8) аккуратней с задвоением при таком решении
   Vlad_69
 
10 - 12.04.17 - 10:29
Можно было и без "ВыгрузитьПоПравилу".

ПКО "Номенклатура", ПКС "ЕдиницаХраненияОстатков"
Обработчик "ПередВыгрузкой":

ИсходящиеДанные = Новый Структура("Владелец",Источник);

Для этого ПКС указываем правило "ЕдиницыИзмерения".

ПКО "ЕдиницыИзмерения" - ставим птицу "Не запоминать выгруженные объекты".
ПКС "Владелец": "Получить из входящих данных", и включить "поиск по свойству".
 
  Рекламное место пустует
   Den_aka_Den
 
11 - 12.04.17 - 13:52
(9) Задвоением чего? Куда смотреть?

(10) Твой вариант при выгрузке выдает ошибку:

Ошибка при выгрузке данных: {Обработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(1619)}: Ошибка получения свойства объекта из входящих данных
    ПКО                    =  ЕдиницыИзмерения  (Справочник: Единицы измерения)
    ПКС                    =  2  (--> Владелец)
    Объект                 =  шт  (Единицы измерения)
    СвойствоПриемника      =  Владелец  ()
    ОписаниеОшибки         =  Получение элемента по индексу для значения не определено
    ПозицияМодуля          =  Обработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(8219)
    КодСообщения           =  68
   Den_aka_Den
 
12 - 12.04.17 - 13:55
   Vlad_69
 
13 - 12.04.17 - 16:17
Брал из рабочего примера, странно.

Правда, когда в БСП-шный модуль прикручивал, делал в таком виде:

ИсходящиеДанные = Новый Структура("Владелец",Источник.Ссылка);
ВыгрузитьОбъект = Истина;

(без этого работать не хотело)
   rozer76
 
14 - 12.04.17 - 16:28
(8) попробуй сделать второе ПКО ЕдиницыИзмерения и его указать в ПКС ЕдиницаХраненияОстатков в номенклатуре


Список тем форума
  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует