Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Как отменить добавление в регистр.

Как отменить добавление в регистр.
Я
   MAPATNK2
 
11.11.16 - 15:37
Здравствуйте. Добавляю список элементов  в регистр. В регистре "ПередЗаписью(Отказ)" отбираю на дубликаты и пишу при появлении дубликата Отказ = истина. И он мне всю обработку закрывает. Почему? Как сделать так, чтобы он не все элементы отменял, а только тот, который попал под условие? Вот код:
Процедура ПередЗаписью(Отказ)
    A=0;
    Для каждого стр из этотОбъект цикл
        юник = стр.UniqID;
        Запрос = новый запрос;
        запрос.Текст = 
        "ВЫБРАТЬ
        |    ЗаписиЗвонков.UniqID
        |ИЗ
        |    РегистрСведений.ЗаписиЗвонков КАК ЗаписиЗвонков
        |ГДЕ
        |ЗаписиЗвонков.UniqID = &Юник";
        Запрос.УстановитьПараметр("Юник",юник);
        рез = Запрос.Выполнить().Выгрузить();
        Если рез.Количество()>0 тогда
            A=12;
        КонецЕсли;
    конецЦикла;
    еСЛИ A=12 тогда 
        Отказ = истина;
        КонецЕсли;
КонецПроцедуры
 
 
   Лефмихалыч
 
1 - 11.11.16 - 15:38
это не регистр, а справочник, если у него есть уникальный индентификатор
   Лефмихалыч
 
2 - 11.11.16 - 15:39
ну, и сделай UniqID единственным измерением и выкинь свой код к херам - платформа сама всё проконтролирует.
   MAPATNK2
 
3 - 11.11.16 - 15:40
Эх. Проще так. Спасибо (2)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует