Вход | Регистрация


Помогите сделать подбор в нетленке на упр форм

Помогите сделать подбор в нетленке на упр форм
Я
   picom
 
11.11.16 - 13:19
Полно статей как передать параметры на форму, а как их обратно получить при закрытии, кроме открывания модально не знаю.
Посвятите пожалуйста.
...
Форма документа
На ней кнопка с открытием подбора
&НаКлиенте
Процедура Подбор(Команда)
    ОткрытьФормуМодально("Обработка.ПодборТоваров.Форма.ПодборТоваров",,ЭтаФорма);
    ОкончаниеПодбора ();    
КонецПроцедуры
...
В окне подбора перед закрытием это
&НаКлиенте
Процедура ПередЗакрытием(Отказ, ЗавершениеРаботы, ТекстПредупреждения, СтандартнаяОбработка)
    Закрыть(ПередЗакрытиемС());
КонецПроцедуры
&НаСервере
Функция ПередЗакрытиемС()
    НовТЗ = Новый ТаблицаЗначений ;
    НовТЗ.Колонки.Добавить("Номенклатура") ;
    НовТЗ.Колонки.Добавить("Количество") ;
    
    Для каждого стр из Объект.Товары Цикл
        Если стр.Количество > 0 Тогда
            НовСтр = НовТЗ.Добавить();
            НовСтр.Номенклатура = стр.Номенклатура ; 
            НовСтр.Количество  = стр.Количество
        КонецЕсли;
    КонецЦикла;
    
    Возврат(НовТЗ);
КонецФункции
...
НО КАК ПЕРЕДАТЬ ПОЛУЧЕННУЮ ТАБЛИЦУЗНАЧЕНИЙ НА ФОРМУ ДОКУМЕНТА МНЕ ОБРАТНО ТО?
 
 
   Cyberhawk
 
1 - 11.11.16 - 13:22
Оповестить
   Cyberhawk
 
2 - 11.11.16 - 13:22
Также во владельце подчиненной формы сидит главная
   picom
 
3 - 11.11.16 - 13:23
(1) Если выдавите из себя чуть больше информации буду безмерно благодарен
   Cyberhawk
 
4 - 11.11.16 - 13:23
ТЗ "сериализуй" в виде массива структур, ну или передавай адрес ВХ со структурой
   Cyberhawk
 
5 - 11.11.16 - 13:23
(3) СП в помощь
   Garykom
 
6 - 11.11.16 - 13:24
(3) Поймите это блин самые основы УФ, без знания их лучше не подступать к современным конфам
   picom
 
7 - 11.11.16 - 13:25
(4) т.е. открывать все же модально?
   vyaz
 
8 - 11.11.16 - 13:25
В форме подбора:    АдресВХранилище = ПоместитьДанныеВоВременноеХранилище();
    
    СтруктураОповещения = Новый Структура;
    СтруктураОповещения.Вставить("АдресПодобранныхДанных", АдресВХранилище);
    
    ОповеститьОВыборе(СтруктураОповещения);
   Garykom
 
9 - 11.11.16 - 13:25
   Garykom
 
10 - 11.11.16 - 13:26
(7) не нужна никакая модальность совершенно
 
 Рекламное место пустует
   Cyberhawk
 
11 - 11.11.16 - 13:26
(7) Нет, разве при немодальном открытии во владельце не будет сидеть форма-источник?
   vyaz
 
12 - 11.11.16 - 13:26
в документе:
&НаКлиенте
Процедура ОбработкаВыбора(ВыбранноеЗначение, ИсточникВыбора)
    
    Если ТипЗнч(ВыбранноеЗначение) = Тип("Структура") И
        ВыбранноеЗначение.Свойство("АдресПодобранныхДанных") Тогда
        
        ОбработатьПодборНоменклатуры(ВыбранноеЗначение.АдресПодобранныхДанных);
        
    КонецЕсли;

КонецПроцедуры
   vyaz
 
13 - 11.11.16 - 13:27
&НаСервере
Функция ПоместитьДанныеВоВременноеХранилище()

    Возврат ПоместитьВоВременноеХранилище(Объект.ПодобраннаяНоменклатура.Выгрузить(), УникальныйИдентификатор);

КонецФункции// ПоместитьДанныеВоВременноеХранилище()
   vyaz
 
14 - 11.11.16 - 13:28
&НаСервере
Процедура ОбработатьПодборНоменклатуры(АдресПодобранныхДанных)

    ТаблицаПодбора = ПолучитьИзВременногоХранилища(АдресПодобранныхДанных);

дальше сам давай :)
   picom
 
15 - 11.11.16 - 13:36
(8) через хранилище я сделал, но мне так не нравится почему-то
   picom
 
16 - 11.11.16 - 13:56
Спасибо, все получилось
(1) + СП и все вышло

Список тем форума
Рекламное место пустует  Рекламное место пустует
Глупец, лишенный способности посмеяться над собой вместе с другими, не сможет долго выносить программирование.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует