Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Почему игнорируется расширение конфигурации ?

Почему игнорируется расширение конфигурации ?
Я
   abask
 
11.11.16 - 00:27
Платформа 8.3.9.1850

Конфигурация чистая (только созданная)

в конфигурации единственный объект Обработка "Тест"

в ней форма с единственной кнопкой

вот обработчик кнопки:

&НаСервере
Процедура Команда1НаСервере()
    Обработки.тест.ТестПроц();
КонецПроцедуры

&НаКлиенте
Процедура Команда1(Команда)
    Команда1НаСервере();
КонецПроцедуры


Вот модуль менеджера:

Процедура ТестПроц() Экспорт 
    Сообщить("ОК Проц");
КонецПроцедуры

Создал расширение
добавил в него обработку "тест"
вот модуль менеджера обработки из расширения:

&Перед ("ТестПроц")
Процедура НовПроц() Экспорт
    Сообщить("Нов Ок Проц");
КонецПроцедуры

в итоге обработка из расширения игнорируется
что не так?
 
 
   Злопчинский
 
1 - 11.11.16 - 03:20
Откуда сделали вывод что игнорируется?

И что будет ::::НаСервере::::: когда выполнится Сообщить...?
   mszsuz
 
2 - 11.11.16 - 06:47
(0) Совместимость в корне конфигурации и расширения выключены?
   oslokot
 
3 - 11.11.16 - 07:36
(1)  выполнится сообщить()
   oslokot
 
4 - 11.11.16 - 07:37
(0)  и 1с перезапустил?
   h-sp
 
5 - 11.11.16 - 09:24
а где вызов этой процедуры  НовПроц() ??
   vde69
 
6 - 11.11.16 - 09:27
если в расширении есть хоть одна ошибка то все расширение не грузится... при этом никаких сообщений...

я писал недавно об этом...

для меня такое поведение стало шоком и я полностью отказался от использования оных ...
   abask
 
7 - 11.11.16 - 10:22
(2) Совместимость стоит в обоих местах - Не использовать
   abask
 
8 - 11.11.16 - 10:25
(5) Согласно логике расширения она выполняется &Перед выполнением ТестПроц
   oslokot
 
9 - 11.11.16 - 10:26
Параметры: /РежимОтладки и вперёд!
   abask
 
10 - 11.11.16 - 10:26
(4) 1с перезапускал
 
 Рекламное место пустует
   oslokot
 
11 - 11.11.16 - 10:26
&Перед - это вообще выкинь
   oslokot
 
12 - 11.11.16 - 10:27
&Перед и иже с ними это бантики, мы и до них прекрасно справлялись
   abask
 
13 - 11.11.16 - 10:28
(11) (12) а как тогда расширение поймет в каком месте запускать НовПроц()
   abask
 
14 - 11.11.16 - 10:32
(9) когда запустил с параметром /debug вот что написало

11.11.2016 10:30:55
Ошибка расширения модуля 'Обработка.Тест.МодульМенеджера': расширение модуля запрещено из-за того, что расширение 'Расширение1' подключено в безопасном режиме
   Мойдодыр
 
15 - 11.11.16 - 10:38
http://v8.1c.ru/o7/201603module/index.htm
Серверные методы расширяются не всегда
   oslokot
 
16 - 11.11.16 - 10:45
(14) а да, сними галку безопасный режим с расширения.
   abask
 
17 - 11.11.16 - 10:50
(16) Все ОК - Заработало

(6) Когда запустил 1с с параметром /debug пошли сообщения об ошибках
   eks1985
 
18 - 11.11.16 - 10:52
(6) Начиная с 8.3.9 сообщения об ошибках выводятся

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует