Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Заявление о ввозе товаров

Заявление о ввозе товаров
Я
   Ugra
 
10.11.16 - 16:47
Всем привет. Ребят, помогите по Бухгалтерии 3.0.
Делаю заявление о ввозе товаров из Таможенного союза на основании поступления. у Контрагента 2 договора. в заявлении можно заполнять ТЧ только с одним договором. когда меняешь договор, пропадают док поступления прошлого договора. Можно заполнять по поступлению, но там в списке выбора выходят только те документы поступления, которые привязаны к договору который выбран. как в этом списке сделать чтобы отображались еще и остальные документы поступления?подскажите где убрать этот отбор договоров контрагента?в Конфигураторе это Документы/ЗаявлениеОВозеТоваров
 
 
   Лефмихалыч
 
1 - 10.11.16 - 16:48
что мешает ввести два заявления?
   Ugra
 
2 - 10.11.16 - 16:48
вот форма выбора основания.Но тут я не нашла где убрать отбор и чтобы в списке отображались все документы этого контрагента


#Область ОбработчикиСобытийФормы


&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    
    МассивВидовОпераци = Новый Массив;
    МассивВидовОпераци.Добавить(Перечисления.ВидыОперацийПоступлениеТоваровУслуг.ПокупкаКомиссия);
    МассивВидовОпераци.Добавить(Перечисления.ВидыОперацийПоступлениеТоваровУслуг.Товары);
    МассивВидовОпераци.Добавить(Перечисления.ВидыОперацийПоступлениеТоваровУслуг.Оборудование);
    
    ДокументыПоступления.Параметры.УстановитьЗначениеПараметра("Организация",               Параметры.Организация);
    ДокументыПоступления.Параметры.УстановитьЗначениеПараметра("Контрагент",                Параметры.Контрагент);
    ДокументыПоступления.Параметры.УстановитьЗначениеПараметра("Договор",                   Параметры.Договор);
    ДокументыПоступления.Параметры.УстановитьЗначениеПараметра("ТекущийДокумент",           Параметры.ТекущийДокумент);
    ДокументыПоступления.Параметры.УстановитьЗначениеПараметра("МассивВыбранныхДокументов", Параметры.МассивВыбранныхДокументов);
    ДокументыПоступления.Параметры.УстановитьЗначениеПараметра("МассивВидовОпераций",       МассивВидовОпераци);
    
    Если НЕ Параметры.ПоОдномуДокументу Тогда
        Элементы.ДокументыПоступления.РежимВыделения = РежимВыделенияТаблицы.Множественный
    КонецЕсли;
    
    Элементы.ДокументыПоступления.ТекущаяСтрока = Параметры.ТекущийДокумент;
    
    УстановитьУсловноеОформление();
    
КонецПроцедуры

#КонецОбласти

#Область ОбработчикиКомандФормы


&НаКлиенте
Процедура КомандаВыбрать(Команда)
    
     ОбработкаВыбораЗначения();
    
КонецПроцедуры

#КонецОбласти

#Область СлужебныеПроцедурыИФункции


&НаСервере
Процедура УстановитьУсловноеОформление()
    
    УсловноеОформление.Элементы.Очистить();

    
    // Уже выбранные документы отображаем серым цветом.


    ЭлементУО = УсловноеОформление.Элементы.Добавить();
    
    КомпоновкаДанныхКлиентСервер.ДобавитьОформляемоеПоле(ЭлементУО.Поля, "ДокументыПоступления");
    
    ОбщегоНазначенияКлиентСервер.ДобавитьЭлементКомпоновки(ЭлементУО.Отбор,
        "ДокументыПоступления.ДокументУжеВыбран", ВидСравненияКомпоновкиДанных.Равно, Истина);
    
    ЭлементУО.Оформление.УстановитьЗначениеПараметра("ЦветТекста", ЦветаСтиля.ТекстЗапрещеннойЯчейкиЦвет);

КонецПроцедуры

&НаКлиенте
Процедура ДокументыПоступленияВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь;
    
    ОбработкаВыбораЗначения();

КонецПроцедуры

&НаКлиенте
Процедура ОбработкаВыбораЗначения()
    
    Если Параметры.ПоОдномуДокументу Тогда
        ТекущиеДанные = Элементы.ДокументыПоступления.ТекущиеДанные;
        
        Если ТекущиеДанные = Неопределено Тогда
            Возврат;
        КонецЕсли;
    
        Если ТекущиеДанные.ДокументУжеВыбран Тогда 
            ПоказатьПредупреждение( , НСтр("ru='Этот документ уже выбран'"));
            Возврат;
        КонецЕсли;
        
        Результат = Новый Массив;
        Результат.Добавить(ТекущиеДанные.Ссылка);
        
    Иначе
        Результат = Элементы.ДокументыПоступления.ВыделенныеСтроки;
        
    КонецЕсли;
    
    ОповеститьОВыборе(Результат);
    
КонецПроцедуры

#КонецОбласти
   Ugra
 
3 - 10.11.16 - 16:49
при сдаче в налоговую нужно отправлять одно заявление по данному контрагенту.. он ж один.только договоров у него 2
   Лефмихалыч
 
4 - 10.11.16 - 16:59
(3) кто придумал этот бред?
Договор/контракт - это реквизит шапки заявления. Если поставки были по двум договорам, то и заявлений - как минимум два.

Ну, или переделывайте с поставщиком документы, чтобы там один договор везде был. Наверное...

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует