Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Значение не является значением объектного типа

Значение не является значением объектного типа
Я
   aleks_p99
 
10.11.16 - 15:30
Здравствуйте! В чем может быть причина следующей ошибки:
{Справочник.ПроизводственныеКалендари.Форма.ФормаЭлемента.Форма(92)}: Значение не является значением объектного типа (Получить)
ЦветОформленияДня = ЦветаВидовДней.Получить(ВидыДней.Получить(СтрокаОформленияПериода.Дата));


Код:
&НаКлиенте
Процедура КалендарьПриВыводеПериода(Элемент, ОформлениеПериода)
    
    Для Каждого СтрокаОформленияПериода Из ОформлениеПериода.Даты Цикл
        ЦветОформленияДня = ЦветаВидовДней.Получить(ВидыДней.Получить(СтрокаОформленияПериода.Дата));
        Если ЦветОформленияДня = Неопределено Тогда
            ЦветОформленияДня = ОбщегоНазначенияКлиент.ЦветСтиля("ВидДняПроизводственногоКалендаряНеУказанЦвет");
        КонецЕсли;
        СтрокаОформленияПериода.ЦветТекста = ЦветОформленияДня;
    КонецЦикла;
    
КонецПроцедуры
 
 
   lxs
 
1 - 10.11.16 - 15:33
В том, что у объекта ВидыДней нет такого метода видимо..
   Basilio
 
2 - 10.11.16 - 15:52
(1) + или у ЦветаВидовДней
   Жан Пердежон
 
3 - 10.11.16 - 15:59
(1)+ либо метод есть, но он не доступен на клиенте
   aleks_p99
 
4 - 10.11.16 - 16:04
Справочник скопирован полностью с готовой конфигурации
   aleks_p99
 
5 - 10.11.16 - 16:05
поэтому ошибки в коде не может быть
   Basilio
 
6 - 10.11.16 - 16:06
(5) ЛОЛ
   Basilio
 
7 - 10.11.16 - 16:07
поставь точку останова на 92 строку и посмотри значения ЦветаВидовДней и ВидыДней.
   Basilio
 
8 - 10.11.16 - 16:07
какой у этих объектов тип?
   aleks_p99
 
9 - 10.11.16 - 16:14
ВидДня Перечисления(Рабочий, суббота и т.п.), Для каждого элемента перечисление создано "Элемент стиля"
   aleks_p99
 
10 - 10.11.16 - 16:15
спасибо за помощь) Возможную ошибку нашел
 
 Рекламное место пустует
   aleks_p99
 
11 - 10.11.16 - 16:16
у меня "ВидыДней" неопределенно, в то время как в оригинале ФиксированноеСоответствие
   Basilio
 
12 - 10.11.16 - 16:22
(11) тип слетел при переносе из "готовой конфигурации"?
   aleks_p99
 
13 - 10.11.16 - 16:35
возможно, еще не проверял

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует