Вход | Регистрация


Планировщик 8.3 УНФ

Планировщик 8.3 УНФ
Я
   ZaprosMan
 
10.11.16 - 10:25
Здравствуйте товарищи.

Есть планировщик в УНФ.
Хочу выполненные задачи зачеркнутым шрифтом выводить.
Но вот что то не выводится.

Код+

НаСервере
Процедура ОбновитьДанныеПланировщикаСервер()
    
    Планировщик.Элементы.Очистить();
    Планировщик.ИнтервалыФона.Очистить();
    
    УстановитьОтображениеПланировщика();
    
    ПериодДанных = ПолучитьПериодДанных(ВариантПериода, ДатаОтображения);
    
    Планировщик.ТекущиеПериодыОтображения.Очистить();
    Планировщик.ТекущиеПериодыОтображения.Добавить(ПериодДанных.ДатаНачала, ПериодДанных.ДатаОкончания);
    
    ВыбранныеКалендари = Новый Массив;
    Для Каждого СтрокаКалендаря Из ДоступныеКалендари Цикл
        Если СтрокаКалендаря.Выбран Тогда
            ВыбранныеКалендари.Добавить(СтрокаКалендаря.Календарь);
        КонецЕсли;
    КонецЦикла;
    
    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    ЗаписиКалендаря.Ссылка КАК ЗаписьКалендаря,
        |    ЗаписиКалендаря.Наименование КАК Наименование,
        |    ЗаписиКалендаря.Начало КАК Начало,
        |    ЗаписиКалендаря.Окончание КАК Конец,
        |    ЗаписиКалендаря.Описание КАК Описание,
        |    ЗаписиКалендаря.Источник КАК Источник,
        |    ЗаписиКалендаря.НомерСтрокиИсточника КАК НомерСтрокиИсточника,
        |    ЗаписиКалендаря.Календарь КАК Календарь,
        |    ЗаписиКалендаря.РедактированиеЗапрещено КАК РедактированиеЗапрещено
        |ИЗ
        |    Справочник.ЗаписиКалендаряСотрудника КАК ЗаписиКалендаря
        |ГДЕ
        |    ЗаписиКалендаря.ПометкаУдаления = ЛОЖЬ
        |    И ЗаписиКалендаря.Начало < &ДатаОкончания
        |    И ЗаписиКалендаря.Окончание > &ДатаНачала
        |    И ЗаписиКалендаря.Календарь В(&ВыбранныеКалендари)
        |
        |УПОРЯДОЧИТЬ ПО
        |    Начало";
    
    Запрос.УстановитьПараметр("ДатаНачала", ПериодДанных.ДатаНачала);
    Запрос.УстановитьПараметр("ДатаОкончания", ПериодДанных.ДатаОкончания);
    Запрос.УстановитьПараметр("ВыбранныеКалендари", ВыбранныеКалендари);
    
    Выборка = Запрос.Выполнить().Выбрать();
    Отбор = Новый Структура("Календарь");
    
    Пока Выборка.Следующий() Цикл
        
        ЭлементПланировщика = Планировщик.Элементы.Добавить(Выборка.Начало, Выборка.Конец);
        ЭлементПланировщика.Значение = Новый Структура;
        ЭлементПланировщика.Значение.Вставить("Календарь", Выборка.Календарь);
        ЭлементПланировщика.Значение.Вставить("ЗаписьКалендаря", Выборка.ЗаписьКалендаря);
        ЭлементПланировщика.Значение.Вставить("Источник", Выборка.Источник);
        ЭлементПланировщика.Значение.Вставить("РедактированиеЗапрещено", Выборка.РедактированиеЗапрещено);
        ЭлементПланировщика.Значение.Вставить("НомерСтрокиИсточника", Выборка.НомерСтрокиИсточника);
        ЭлементПланировщика.Текст        = Выборка.Наименование;
        ЭлементПланировщика.Подсказка    = Выборка.Описание;
        
        Если ЗначениеЗаполнено(Выборка.Источник) Тогда
            МенеджерИсточника = ОбщегоНазначения.МенеджерОбъектаПоСсылке(Выборка.Источник);
            ЭлементПланировщика.Картинка = МенеджерИсточника.КартинкаЗаписиКалендаря(Выборка.Источник);
            ЭлементПланировщика.ЦветТекста = МенеджерИсточника.ЦветТекстаЗаписиКалендаря(Выборка.Источник);
        КонецЕсли;
        
        Отбор.Календарь = Выборка.Календарь;
        НайденныеСтроки = ДоступныеКалендари.НайтиСтроки(Отбор);
        Если НайденныеСтроки.Количество() > 0 Тогда
            ЭлементПланировщика.ЦветФона = РаботаСЦветомКлиентСервер.ЦветПоНомеруКартинки(НайденныеСтроки[0].ВариантЦвета);
        КонецЕсли;
        
        //Добавил ****** С.(10.11.2016) +

        Если ЭлементПланировщика.Значение.ЗаписьКалендаря.Выполнен Тогда
            Шрифт = Новый Шрифт(ЭлементПланировщика.Шрифт,,,,,,Истина);
            
            ЭлементПланировщика.Шрифт = Шрифт;
        КонецЕсли;
        //Добавил ****** С.(10.11.2016) -

    КонецЦикла;
    
КонецПроцедуры

///////
Код-

После выполнения процедуры:

ЭлементПланировщика.Шрифт    Авто, зачеркнутый    Шрифт

Но в календоре он как был не зачеркнутый так и остатся.

Кто делал подобное с планировщиком? Подскажите что не так?

Спасибо!!!!!
 
 
   ZaprosMan
 
1 - 10.11.16 - 11:02
Сделал картинкой, чето шрифт не работает.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует