Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Ошибки в коде не могу понять в чем ошибка. Хочу получить цены для документа

Ошибки в коде не могу понять в чем  ошибка. Хочу получить цены для документа
Я
   Zariiiiii
 
09.11.16 - 19:50
&НаСервереБезКонтекста
Функция ПолучитьЦенуИзРегистра(Номенклатура, Цена, Дата)
    
    Запрос = Новый Запрос;
    Запрос.Текст =
    
         "ВЫБРАТЬ
        |    ЦеныНоменклатуры.Цена
        |    ЦеныНоменклатуры.Период,
        |ИЗ
        |    РегистрСведений.ЦеныПоставщиков.СрезПервых(&Дата, Цена = &Цена) КАК ЦеныПоставщиковСрезПервых";
        |
        |ОБЪЕДИНИТЬ ВСЕ
        |ВЫБРАТЬ ПЕРВЫЕ 1
        |    ЦеныНоменклатуры.Цена,
        |    ЦеныНоменклатуры.Период,
        |ИЗ
        |    РегистрСведений.ЦеныПоставщиков.СрезПервых(&Дата, Цена = &Цена) КАК ЦеныПоставщиковСрезПервых";
        |
        |УПОРЯДОЧИТЬ ПО
        |    Период УБЫВ";
        
    Запрос.УстановитьПараметр("Дата", Дата);
    Запрос.УстановитьПараметр("Цена", Цена);
    
    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
         Вставить обработку выборки ВыборкаДетальныеЗаписи
    КонецЦикла;
    
    //}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА

        
   
КонецФункции
 
 
   Cyberhawk
 
1 - 09.11.16 - 19:51
Консоль запросов что говорит?
   МимохожийОднако
 
2 - 09.11.16 - 19:52
СрезПоследних не понравился?
   Zariiiiii
 
3 - 09.11.16 - 19:52
{Документ.ПродажаТоваров.Форма.ФормаДокумента.Форма(56,3)}: Ожидается ключевое слово 'КонецФункции' ('EndFunction')
        <<?>>| (Проверка: Сервер)
{Документ.ПродажаТоваров.Форма.ФормаДокумента.Форма(70,38)}: Ошибка в выражении
    РезультатЗапроса = Запрос.Выполнить(<<?>>); (Проверка: Сервер)
{Документ.ПродажаТоваров.Форма.ФормаДокумента.Форма(75,13)}: Неопознанный оператор
         Вставить <<?>>обработку выборки ВыборкаДетальныеЗаписи (Проверка: Сервер)
{Документ.ПродажаТоваров.Форма.ФормаДокумента.Форма(76,13)}: Обнаружено логическое завершение исходного текста модуля
    КонецЦикла;<<?>> (Проверка: Сервер)
{Документ.ПродажаТоваров.Форма.ФормаДокумента.Форма(56,3)}: Ожидается ключевое слово 'КонецФункции' ('EndFunction')
        <<?>>| (Проверка: Сервер)
{Документ.ПродажаТоваров.Форма.ФормаДокумента.Форма(70,28)}: Обнаружено логическое завершение исходного текста модуля
    РезультатЗапроса = Запрос.<<?>>Выполнить(); (Проверка: Сервер)
{Документ.ПродажаТоваров.Форма.ФормаДокумента.Форма(56,3)}: Ожидается ключевое слово 'КонецФункции' ('EndFunction')
        <<?>>| (Проверка: Тонкий клиент)
{Документ.ПродажаТоваров.Форма.ФормаДокумента.Форма(70,38)}: Ошибка в выражении
    РезультатЗапроса = Запрос.Выполнить(<<?>>); (Проверка: Тонкий клиент)
{Документ.ПродажаТоваров.Форма.ФормаДокумента.Форма(75,13)}: Неопознанный оператор
         Вставить <<?>>обработку выборки ВыборкаДетальныеЗаписи (Проверка: Тонкий клиент)
{Документ.ПродажаТоваров.Форма.ФормаДокумента.Форма(76,13)}: Обнаружено логическое завершение исходного текста модуля
    КонецЦикла;<<?>> (Проверка: Тонкий клиент)
   МимохожийОднако
 
4 - 09.11.16 - 19:54
Убери очепятки для начала. Ответь на (1)
   Lexey_
 
5 - 09.11.16 - 19:57
(3) "Ожидается ключевое слово 'КонецФункции' " где-то незакрытая функция
   Zariiiiii
 
6 - 09.11.16 - 19:59
Хочу для документа "Продажи товаров" получить цену из регистра сведений "ЦеныНоменклатуры". Первый код ошибочно отправила.
 &НаСервереБезКонтекста
Функция ПолучитьЦенуИзРегистра(Номенклатура, Цена, Дата)
    
    Запрос = Новый Запрос;
    Запрос.Текст =
    
         "ВЫБРАТЬ
        |    ЦеныНоменклатуры.Цена
        |    ЦеныНоменклатуры.Период,
        |ИЗ
        |    РегистрСведений.ЦеныНоменклатуры.СрезПервых(&Дата, Цена = &Цена) КАК ЦеныНоменклатурыСрезПервых";
        |
        |ОБЪЕДИНИТЬ ВСЕ
        |ВЫБРАТЬ ПЕРВЫЕ 1
        |    ЦеныНоменклатуры.Цена,
        |    ЦеныНоменклатуры.Период,
        |ИЗ
        |    РегистрСведений.ЦеныНоменклатуры.СрезПервых(&Дата, Цена = &Цена) КАК ЦеныНоменклатурыСрезПервых";
        |
        |УПОРЯДОЧИТЬ ПО
        |    Период УБЫВ";
        
    Запрос.УстановитьПараметр("Дата", Дата);
    Запрос.УстановитьПараметр("Цена", Цена);
    
    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
         Вставить обработку выборки ВыборкаДетальныеЗаписи
    КонецЦикла;
    
    //}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА

        
   
КонецФункции
   Lexey_
 
7 - 09.11.16 - 19:59
код в(0), видимо, не причем
   Lexey_
 
8 - 09.11.16 - 20:00
либо ошибка в этой строке "Вставить обработку выборки ВыборкаДетальныеЗаписи", если это действительно не коммент
   kosts
 
9 - 09.11.16 - 21:35
(6) Подскажи для чего применяешь двойной запрос с объединением. Интересно просто.
   Franchiser
 
10 - 09.11.16 - 22:09
запрос - бред
 
 Рекламное место пустует
   AlxnrVslv
 
11 - 10.11.16 - 12:11
|    ЦеныНоменклатуры.Цена
|    ЦеныНоменклатуры.Период
исправь на
|    ЦеныНоменклатурыСрезПервых.Цена
|    ЦеныНоменклатурыСрезПервых.Период
   Zariiiiii
 
12 - 10.11.16 - 12:22
Разобралась, спасибо всем

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует