Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Подключение к 7.7 через COM

v7: Подключение к 7.7 через COM
Я
   Sun125
 
08.11.16 - 11:08
Пытаюсь подключиться к 1С7.7 через COMобъект:
Попытка    
            База = Новый COMОбъект("V77S.Application"); 
        Исключение   
            База=0;
        КонецПопытки;
        
        Если База = 0 Тогда
            Попытка    
                База = Новый COMОбъект("V77l.Application"); 
            Исключение   
                База=0;
            КонецПопытки;
            
        КонецЕсли;
        
        Если База = 0 Тогда
            Попытка    
                База = Новый COMОбъект("V77.Application"); 
            Исключение   
                База=0;
            КонецПопытки;
        КонецЕсли;

Не получается подключиться, подскажите,пожалуйста, в чем может быть причина?
 
 
   asady
 
1 - 08.11.16 - 11:09
(0) ну нет кома у клюшек
юзай олю
   Sun125
 
2 - 08.11.16 - 11:29
{Форма.Форма.Форма(25)}: Ошибка при вызове конструктора (COMОбъект)
            База = Новый COMОбъект("V77S.Application"); 
по причине:
Недопустимая строка с указанием класса
   shadow_sw
 
3 - 08.11.16 - 11:31
Функция ПодключитьБазуОЛЕ(ПутьБазы) Экспорт
    Пользователь = "";
    Пароль = "";
    Если не((БазаОле="") или (БазаОле=неопределено)) тогда
        Если Вопрос("Есть подключенная база. Подключиться к новой?",
            РежимДиалогаВопрос.ОКОтмена)=КодВозвратаДиалога.Отмена тогда
            Возврат Ложь
        КонецЕсли;
    КонецЕсли;
    БазаОлеТек= Новый COMОбъект("V77.Application");
    РезультатПодключения = БазаОлеТек.Initialize(БазаОлеТек.RMTrade,"/D" + ПутьБазы + " /N" + СокрЛП(Пользователь) + " /P" + СокрЛП(Пароль) + "", "NO_SPLASH_SHOW");
    Если РезультатПодключения = Ложь Тогда
        Предупреждение("Ошибка подключения.");
        Возврат Ложь;
    КонецЕсли;
    БазаОле=БазаОлеТек;
    Возврат Истина;
КонецФункции
   Sun125
 
4 - 08.11.16 - 11:36
(3) БазаОлеТек= Новый COMОбъект("V77.Application"); не работает, ругается на класс
   Sun125
 
5 - 08.11.16 - 11:40
(3) На ПК стоит Win7 64-разрядная. Может с этим связано?
   MadJhey
 
6 - 08.11.16 - 11:44
7.7 должна быть установлена, а не скопирована. Надо один раз запустить 7.7 под правами администратора. В последний раз у меня не запускался com 7.7 из-за того, что нужен был не локальный админ, а доменный.
   Ёпрст
 
7 - 08.11.16 - 11:48
(5) прописать надо V77.Application в реестре
   Ёпрст
 
8 - 08.11.16 - 11:49
   Sun125
 
9 - 08.11.16 - 11:54
(6) Запуск 1С7.7 под админом помог. Спасибо!

Список тем форума
Рекламное место пустует  Рекламное место пустует
Проблемы невозможно решaть нa том же уровне компетентности, нa котором они возникaют. Альберт Эйнштейн
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует