Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Группировки по табличным частям в запросе.

Группировки по табличным частям в запросе.
Я
   Help1с
 
07.11.16 - 11:02
Приветствую.
Формирую ХМЛ документ. Нужно получить в 1с таблицу с полями:
1. НомерДокумента
2. Контрагент
3. ТЧ.Товары 
  3.1 Номенклатура
4. ТЧ.Услуги 
  4.2 Услуга

че-то туплю и не могу сообразить как использовать группировки и обход. В документе разное количество строк по каждой ТЧ.
Из запроса ссылки не получаю, чтобы ускорить быстродействие (выбираю только значение).
Конечно я могу выгрузить результат запроса в ТЗ и там группировать и обходить таблицу как мне нужно, только как мне кажется это повлияет на быстродействие.
Подскажите можно ли в запросе использую группировки обойти таблицу как мне нужно.
Обход запроса вижу так:
Пока ВыборкаПоДокументу.Следующий() Цикл
 НомерДокумента = ВыборкаПоДокументу.Номер;
 Пока ВыборкаПоТЧТовары.Следующий() Цикл  
 КонецЦикла;
 Пока ВыборкаПОТЧУслуги.Следующий() Цикл
 КонецЦикла;
КонецЦикла;

Спасибо.
 
 
   Ёпрст
 
1 - 07.11.16 - 11:05
делай так, что ле.. Потом обходи



ВЫБРАТЬ
    РеализацияТоваровУслуг.Ссылка,
    РеализацияТоваровУслуг.Товары.(
        Номенклатура
    ),
    РеализацияТоваровУслуг.Услуги.(
        Номенклатура
    )
ИЗ
    Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
   Ёпрст
 
2 - 07.11.16 - 11:05
будут тебе отдельные выборки твоих ТЧ документа.
   Help1с
 
3 - 07.11.16 - 11:08
(2) так используются ссылки, я не хочу их выбирать. полей на самом деле больше, я для примера взял.
   mehfk
 
4 - 07.11.16 - 11:08
Делай как-то так:

выбрать что-то, "товары" как ИмяТч из док.товары
union all
выбрать что-то, "услуги" как ИмяТч из док.услуги

...
итоги по ИмяТЧ
   Ёпрст
 
5 - 07.11.16 - 11:08
(3) че ?
   Help1с
 
6 - 07.11.16 - 11:09
(3) + или я не прав и так можно получить значения?
   Ёпрст
 
7 - 07.11.16 - 11:10
На тебе все поля

ВЫБРАТЬ
    *,
    РеализацияТоваровУслуг.Товары.*,
    РеализацияТоваровУслуг.Услуги.*
ИЗ
    Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
   Help1с
 
8 - 07.11.16 - 12:49
(7) спасибо. не совсем то что нужно, но похоже по другому никак.
я хотел получать в запросе примитивные типы (дата, строка, число), попробую так выполнить.
   Ёпрст
 
9 - 07.11.16 - 12:50
(8) получай, кто мешает ?!
   azernot
 
10 - 07.11.16 - 12:52
(8) Ссылка в каком-то смысле - это тоже примитивный тип. Строка 36 символов.
Получение ссылки само по себе, не ведёт к считыванию всех данных объекта, пока ты не получаешь что-то через точку от ссылки.
 
 Рекламное место пустует
   Ёпрст
 
11 - 07.11.16 - 12:53
ВЫБРАТЬ
    РеализацияТоваровУслуг.Номер КАК НомерДокумента,
    РеализацияТоваровУслуг.Дата КАК ДатаДокументаДокумента,
    РеализацияТоваровУслуг.Товары.(
        Номенклатура.Наименование КАК НаименованиеТовара,
        Номенклатура.Код КАК КодТовара
    ) КАК ТабличнаяЧастьТовары,
    РеализацияТоваровУслуг.Услуги.(
        Номенклатура.Наименование КАК НаименованиеУслуги,
        Номенклатура.Код КАК КодУслуги
    ) КАК ТабличнаяЧастьУслуги
ИЗ
    Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
   Help1с
 
12 - 07.11.16 - 13:02
(11) огромное спасибо. не знал что так можно. сейчас проверю. )

Список тем форума
Рекламное место пустует  Рекламное место пустует
Кaк может человек ожидaть, что его мольбaм о снисхождении ответит Тот, кто превыше, когдa сaм он откaзывaет в милосердии тем, кто ниже его? Петр Трубецкой
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует