Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Отправка документов по электронной почте

Отправка документов по электронной почте
Я
   LostCost
 
07.11.16 - 04:50
Добрый день!
Проблема вот в чем, я создал документ, и мне необходима возможность отправлять его по Электронной почте(в различных форматах),  сохранять (в различных форматах), Выводить на печать. Делать этого я совершенно не умею, а создавать подобных документов нужно много....
Может кто-нибудь научить? (Естественно не бесплатно), (но не написать, а именно научить)...
 
 
   Mauser
 
1 - 07.11.16 - 08:01
Посмотри, например, вот здесь http://www.1c-uc3.ru/web-progtip.html
   anatoly
 
2 - 07.11.16 - 08:08
(1) что то я не нашел там ничего про, например, отправку по емейл печ.формы по ворд-шаблону...

(0) скажи конкретно - в каких форматах надо сохранять/отправлять и из какой конфы?
   Fedor-1971
 
3 - 07.11.16 - 08:57
(2) Тебе предложили пройти базовые курсы, можешь и сам выяснить, то что тебе нужно.
Вот тебе начала-начал:
1) открываем СП
2)читаем про ТабличныйДокумент, особенно уделяем внимание Вывести, Показать и Сохранить
3) смотрим в любую типовую, там где идёт формирование табличного документа (отчёт, печатная форма документа)
4) задаём вопросы, если что-то не понятно

Как-бы, конкретный вопрос - конкретный ответ.
   Mauser
 
4 - 07.11.16 - 09:11
(2) Занятие 4, Занятие 6.
Истинный 1Сник должен быть ленив, и не понимать печатных букв, да.
   LostCost
 
5 - 07.11.16 - 14:27
Да нет, 2 формата, Excel и PDF.
Курсы это хорошо, вот только время сильно поджимает...
   anatoly
 
6 - 07.11.16 - 14:30
(3) а я как бы ничего не спрашивал ))
я сам кому хочешь курсы проведу.

просто предлагать на конкретные вопрос слишком общие курсы... ну не знаю.

и это, (3) (4) умники - где там про "отправку по емейл печ.формы по ворд-шаблону..." ?
   anatoly
 
7 - 07.11.16 - 14:31
(4) врешь - ни 4 ни 6 - ни слова про работу с почтой.
   Gantosha
 
8 - 07.11.16 - 14:33
а что значит в этом контексте научить ?
Вам что не понятно ? как отправить по почте это один кейс, что отправить по почте это другой кейс, и так далее.
   Mauser
 
9 - 07.11.16 - 14:37
(7) Скопируй сюда, пожалуйста, программу
   LostCost
 
10 - 07.11.16 - 14:39
Научить, значит дать под запись код, или механизм, чтобы я мог в дальнейшем создав новый документ, смог его сохранить, вывести на печать и отправить по почте в вышеуказанных форматах. Про курсы я про себя писал...
 
 Рекламное место пустует
   LostCost
 
11 - 07.11.16 - 14:40
Программу? это бухгалтерия 3.0 С нетиповой доработкой БИТа Экспедирование, весом в 2 гБ...
   Mauser
 
12 - 07.11.16 - 14:41
Научить, значит дать под запись код [x]
   LostCost
 
13 - 07.11.16 - 14:41
Ну, учитывая что я полный идиот в 1С....
   LostCost
 
14 - 07.11.16 - 14:43
Я пытался в общих командах ОтправкаПоЭлектроннойПочте поставить галку на своем документе, но таким образом не выходит.
   IlyaSR
 
15 - 07.11.16 - 15:05
Учетную запись электропочты создал?
Тогда в доке есть кнопка "Отправить по электронной почте"...жми
   azernot
 
16 - 07.11.16 - 15:11
Функция ПолучитьПрофиль() Экспорт
    
    Профиль = Новый ИнтернетПочтовыйПрофиль;
    
    // SMTP сервер

    Профиль.АдресСервераSMTP = "mail.office.MyCompany";
    
    // Порт SMTP сервера

    Профиль.ПортSMTP = 25;
    
    // POP3 сервер

    Профиль.АдресСервераPOP3 = "mail.office.MyCompany";
    
    // Порт POP3 сервера

    Профиль.ПортPOP3 = 110;
    
    // Пароль к почтовому ящику

    Профиль.Пароль = "123456";
    
    // Пароль пользователя для SMTP сервера

    Профиль.ПарольSMTP = "123456";
    
    // Логин пользователя

    Профиль.Пользователь = "MyCompanyAdmin";
    
    // Логин пользователя для SMTP сервера

    Профиль.ПользовательSMTP = "MyCompanyAdmin";
    
    // Время ожидания выполнения операции в секундах

    
    Профиль.ВремяОжидания = 50; 
    Возврат Профиль;

КонецФункции

Процедура ПослатьПисьмо(Сообщение) Экспорт
    
    Почта = Новый ИнтернетПочта;
    Попытка
        Почта.Подключиться(ПолучитьПрофиль());
    Исключение
        Сообщить(ОписаниеОшибки()); 
        Возврат;
    КонецПопытки;
    
    Попытка
        // Пытаемся послать письмо

        Почта.Послать(Сообщение);
    Исключение
        Сообщить(ОписаниеОшибки()); 
        Возврат;
    КонецПопытки;
    // отключение

    Почта.Отключиться();

КонецПроцедуры

Процедура ОтправитьПоПочте(ТабДокумент, ФорматСохранения = "XLS", МассивАдресовПолучателей, СтруктураСообщения)
    
    Сообщение = Новый ИнтернетПочтовоеСообщение;
    
    Собщение.Отправитель = "info@MyCompany.ru";
    Сообщение.ИмяОтправителя = "My Company";
    
    ПочтовыеАдреса = Сообщение.Получатели;
    Для Каждого Адрес Из МассивАдресовПолучателей Цикл
        ПочтовыйАдрес = ПочтовыеАдреса.Добавить();
        ПочтовыйАдрес.Адрес = Адрес.Адрес;
    КонецЦикла;
    
    Сообщение.Тема =?(ЗначениеЗаполнено(СтруктураСообщения.ЗаголовокСообщения),СтруктураСообщения.ЗаголовокСообщения, "Документы во вложении");
    
    ИнтернетТекстПочтовогоСообщения = Сообщение.Тексты.Добавить();
    ИнтернетТекстПочтовогоСообщения.Текст = ?(ЗначениеЗаполнено(СтруктураСообщения.ТекстСообщения),СтруктураСообщения.ТекстСообщения, "Документы во вложении");
    ИнтернетТекстПочтовогоСообщения.ТипТекста = ?(ЗначениеЗаполнено(СтруктураСообщения.ТекстСообщения),ТипТекстаПочтовогоСообщения.HTML, ТипТекстаПочтовогоСообщения.ПростойТекст);
    
    Если ФорматСохранения = "XLS" ИЛИ ФорматСохранения = Неопределено Тогда  
        ПолноеИмяФайла = КаталогВременныхФайлов()+"\"+ПолучитьИмяВременногоФайла("xls");
        ТабДокумент.Записать(ПолноеИмяФайла,ТипФайлаТабличногоДокумента.XLS); 
    ИначеЕсли ФорматСохранения = "PDF" Тогда 
        ПолноеИмяФайла = КаталогВременныхФайлов()+"\"+ПолучитьИмяВременногоФайла("PDF");
        ТабДокумент.Записать(ПолноеИмяФайла,ФорматСохранения = ТипФайлаТабличногоДокумента.PDF); 
    КонецЕсли;
    
    Сообщение.Вложения.Добавить(ПолноеИмяФайла);
    ПослатьПисьмо(Сообщение);
    
    
КонецПроцедуры


Вознаграждение за пример - перечисли сюда http://podari-zhizn.ru/

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует