Вход | Регистрация


отмена объединить при выводе секций

отмена объединить при выводе секций
Я
   falselight
 
06.11.16 - 16:28
Делаю Строка.Область(1,3,1,4).Объединить();
для объединения полей в выводимой секции строки.
Но после так же выводятся объединенные все последующие строки.
Как сделать что бы объединить было только для одной строки?
 
 
   Лефмихалыч
 
1 - 06.11.16 - 16:29
Разъединить()

а вообще, возможно тебе вместо этой тряхомудии нужно просто Присоединить(), а не Вывести()
   falselight
 
2 - 06.11.16 - 16:30
так не помогло ОбластьСтрока.Область(1,3,1,4).Разъединить();
   falselight
 
3 - 06.11.16 - 16:31
почему то нет реакции на (2)
   falselight
 
4 - 06.11.16 - 16:32
(1) я визуально объединяю ячейки, и хочу их снова разьединить
в выводе следующих строк
   Лефмихалыч
 
5 - 06.11.16 - 16:32
потому, что это сказки какие-то.
Все, начиная с (0) - сказки.
   Лефмихалыч
 
6 - 06.11.16 - 16:33
сначала выведи всё, потом объединяй
   falselight
 
7 - 06.11.16 - 16:38
(5) у меня поле1, поле2, поле3, поле4
после             
ОбластьСтрока.Область(1,2,1,4).Объединить();        ЭлементыФормы.ПолеОтчета.Вывести(ОбластьСтрока, 1, "ИтогПТ", Истина);

остается поле1 поле4

потом делаю

ОбластьСтрока.Область(1,2,1,4).Разъединить();


что бы вывести значения в поле1, поле2, поле3, поле4
но полей поле2, поле3 непоявляется (((((
   falselight
 
8 - 06.11.16 - 16:40
(6) что значит вывели все потом объединяй?
   h-sp
 
9 - 06.11.16 - 16:45
(8) ну ты же сначала вывел в табдок, а потом объединяешь. дебилизм ведь.

в ПолеОтчета тогда объединяй уже.
   falselight
 
10 - 06.11.16 - 16:48
(9) где вы увидели что я вывел а потом объединяю?
 
 Рекламное место пустует
   falselight
 
11 - 06.11.16 - 16:49
(9) я объединил, вывел, а потом мне нужно разъединить
   falselight
 
12 - 06.11.16 - 16:50
объединить объединилось, а разъединить не срабатывает
   h-sp
 
13 - 06.11.16 - 20:11
(12) так в следующий вывод опять объединяешь
   falselight
 
14 - 07.11.16 - 08:43
(13) Что не так сделано подскажите? Объединять объединяет, но потом не разъединяет и выходят ошибки что нет тех полей, которые были объединены
Если ТзПост <> 0 Тогда
    Для каждого ТекСтр Из ТзПост Цикл
        Если т = 0 Тогда
            ЭлементыФормы.ПолеОтчета.НачатьАвтогруппировкуСтрок();
            ОбластьСтрока.Область(1,2,1,4).Объединить();
            ОбластьСтрока.Параметры.Поле1 = "1. Поступление товаров.";
            ИтогПТ                        = ТзПост.Итог("Сумма");
            ОбластьСтрока.Параметры.Поле4 = ФОРМАТ(ИтогПТ, "ЧЦ=10; ЧДЦ=2");
            ЭлементыФормы.ПолеОтчета.Вывести(ОбластьСтрока, 1, "ИтогПТ", Истина);
            ИтогОтчета = ИтогОтчета + ИтогПТ;
            т = 1;
        КонецЕсли;
        ОбластьСтрока.Область(1,2,1,4).Разъединить();
        Если т = 1 Тогда
            ОбластьСтрока.Параметры.Поле1 = "Номенклатура";
            ОбластьСтрока.Параметры.Поле2 = "Количество";
            ОбластьСтрока.Параметры.Поле3 = "Цена";
            ОбластьСтрока.Параметры.Поле4 = "Сумма";
            ЭлементыФормы.ПолеОтчета.Вывести(ОбластьСтрока, 2, "СтрокаПТ", Ложь);
            т = 2;
        КонецЕсли;
        ОбластьСтрока.Параметры.Поле1            = ТекСтр.Номенклатура;
        ОбластьСтрока.Параметры.РасшифровкаПоле1 = ТекСтр.Номенклатура;
        ОбластьСтрока.Параметры.Поле2            = ФОРМАТ(ТекСтр.Количество, "ЧЦ=10; ЧДЦ=3");
        ОбластьСтрока.Параметры.Поле3            = ФОРМАТ(ТекСтр.Сумма / ТекСтр.Количество, "ЧЦ=10; ЧДЦ=2");
        ОбластьСтрока.Параметры.Поле4            = ФОРМАТ(ТекСтр.Сумма, "ЧЦ=10; ЧДЦ=2");
        ЭлементыФормы.ПолеОтчета.Вывести(ОбластьСтрока, 2, "СтрокаПТ", Ложь);
        Сч = Сч + 1;
    КонецЦикла;
Иначе
    ОбластьСтрока.Параметры.Поле1 = "1. Поступление товаров.";
    ЭлементыФормы.ПолеОтчета.Вывести(ОбластьСтрока, 1, "ИтогПТ", Истина);
КонецЕсли;
ЭлементыФормы.ПолеОтчета.ЗакончитьАвтогруппировкуСтрок();
   falselight
 
15 - 07.11.16 - 08:45
(14+) Объединяю только один раз, в шапке. Потом делаю разъединить, так как объединить больше не сработает. Но разъединить не срабатывает и объединенные переменные не появляются, выходят ошибки.
   mehfk
 
16 - 07.11.16 - 08:47
Ливингстара учить - только мпх тупить.
   mistеr
 
17 - 07.11.16 - 09:33
(0) В макете объедини что надо и все.
   Ёпрст
 
18 - 07.11.16 - 10:05
(14)
//ОбластьСтрока.Область(1,2,1,4).Объединить();

//ОбластьСтрока.Область(1,2,1,4).Разъединить();

Объединяй в 
Обл =  ЭлементыФормы.ПолеОтчета.Вывести(ОбластьСтрока, 1, "ИтогПТ", Истина);
   Ёпрст
 
19 - 07.11.16 - 10:06
в результирующей области
   falselight
 
20 - 07.11.16 - 10:22
(19) Ок, понял, спасибо! Буду заниматься этим вопросом
Не получилось с наскока его побороть!!!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует