Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Получение полной фамилии и инициалов

Получение полной фамилии и инициалов
Я
   Riko669
 
06.11.16 - 12:46
День добрый!

У меня такая проблема. В общем есть справочник "Сотрудники", в нем реквизиты (Фамилия, Имя, Отчество, НаименованиеДляРасшифровки). Для первых трех реквизитов прописана процедура "ПриИзменении".

Пример:
&НаКлиенте
Процедура ОтчествоПриИзменении(Элемент)
    Если СокрЛП(Объект.НаименованиеДляРасшифровки)="" Тогда
        ПолучитьФамилиюИнициалыИО();
    КонецЕсли;
КонецПроцедуры

Для последнего реквизита прописана Функция.

Пример:
&НаКлиенте
Функция ПолучитьФамилиюИнициалыИО()
    ИнициалИмени = Лев(Объект.Имя,1);
    Инициалотчества = лев(Объект.Отчество,1);
    НаименованиеДляРасшифровки = Объект.Фамилия + " " + Инициалимени + "." + ИнициалОтчества + ".";
    Сообщить("НаименованиеДляРасшифровки " + НаименованиеДляРасшифровки);
    Возврат НаименованиеДляРасшифровки;
КонецФункции

Мне нужно чтобы при вводе в строки Фамилия, Имя, Отчество, в строке НаименованиеДляРасшифровки получалось Иванов И.И.
Но фишка в том, что это значение у меня не отображается в строке РасшифровкаДляНаименования.
Строка: Сообщить("НаименованиеДляРасшифровки " + НаименованиеДляРасшифровки); она взята для проверки выполняется ли эта функция, и да, она выполняется при заполнении выводится сообщение Иванов И.И., но выводится именно сообщение, а не в строке. Что я не так сделала? Помогите, пожалуйста!
 
 
   h-sp
 
1 - 06.11.16 - 13:10
Объект.НаименованиеДляРасшифровки = ПолучитьФамилиюИнициалыИО();

такое магтческое выражение попробуйте.
   Riko669
 
2 - 07.11.16 - 09:07
Спасибо! В принцепи практически получилось. В строке Наименование расшифровки выводится Фамилия и две разделительные точки, т.е. "Иванов .."
   Базис
 
3 - 07.11.16 - 09:26
Пробел между именем и отчеством сделай.
   Riko669
 
4 - 07.11.16 - 09:30
В самой функции имеете ввиду?
   Riko669
 
5 - 07.11.16 - 14:17
Спасибо всем кто помогал! У меня все получилось, дело было не в самих пробелах, а в процедурах для имени и отчества. Спасибо большое еще раз!)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует