Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Вызвать из общего модуля процедуру внешней обработки

Вызвать из общего модуля процедуру внешней обработки
Я
   MrAvPika
 
05.11.16 - 14:50
Кто нибудь знает как вызвать экспортную процедуру внешней обработки из общего модуля?
 
 
   SleepyHead
 
1 - 05.11.16 - 17:07
(0) Обычно наоборот делают. В чем тайный смысл?
   Suricatt
 
2 - 05.11.16 - 17:12
Внешняя обработка хранится в справочнике.
Сохраняете на диск и далее Новый ВнешняяОбработка
   Suricatt
 
3 - 05.11.16 - 17:14
Немного ошибся:
ВнешняяОбработка.Создать(ИмяФайла)
   Матиус-IV
 
4 - 05.11.16 - 17:24
(2) У ТС ничто нигде не хранится.
   PR
 
5 - 05.11.16 - 19:06
В общем модуле, например "ОбщийМодуль1"

Процедура ВыполнитьПроцедуруВнешнейОбработки(ИспользуемоеИмяФайла, ИмяПроцедуры, Параметры)
    
    Обработка = ВнешниеОбработки.Создать(ИспользуемоеИмяФайла);
    Выполнить("Обработка." + ИмяПроцедуры + "(Параметры)");
    
КонецПроцедуры



В модуле обработки

Процедура <ИмяПроцедуры>(Параметры) Экспорт
    
    //...код...

    
КонецПроцедуры



В модуле, откуда вызывается процедура общего модуля (например, модуль формы той же самой обработки) и где известен контекст обработки или путь к файлу. Пусть это серверная процедура формы обработки, тогда нужно будет определить имя файла, иначе нужно будет его передавать как откуда-то известную строку.

&НаСервере
Процедура ДобавитьФоновоеЗадание()
    
    ОбъектОбъект = РеквизитФормыВЗначение("Объект");
    ПроизвольныйПараметр = Неопределено;
    
    ОбщийМодуль1.Выполнить(ОбъектОбъект.ИспользуемоеИмяФайла, <ИмяПроцедуры>, ПроизвольныйПараметр);
    
КонецПроцедуры

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует