Вход | Регистрация


Печатная форма

Печатная форма
Я
   RINCH
 
05.11.16 - 09:21
Здравствуйте!
Нужно что бы при нажатие на  галку ДеталиАСЦ выводилась одна надпись в печатной ворме, а при нажатие галки ДеталиКлиента Другая что не так подскажите?      

ВыводОбластиДетали = Ложь;

        Если СсылкаНаОбъект.ДеталиКлиента и СсылкаНаОбъект.ВидРемонта.ТипРемонта =Перечисления.ТипыРемонта.Платный Тогда
        ВыводОбластиДетали = Истина;
    КонецЕсли;
                   Если СсылкаНаОбъект.ДеталиАСЦ = Истина Тогда
               ОбластьМакета = Макет.ПолучитьОбласть("Подвал");
               Если СсылкаНаОбъект.ДеталиКлиента = Истина  Тогда
                   ОбластьМакета.Области.Найти("ЗапЧастиКлиента").Очистить();  
                   ТД.Вывести(ОбластьМакета);
               КонецЕсли;
               КонецЕсли;
 
 
   Alexor
 
1 - 05.11.16 - 09:25
ВыводОбластиДетали - где используется?
СсылкаНаОбъект.ДеталиАСЦ = Истина  - семерочник?
   RINCH
 
2 - 05.11.16 - 09:28
(1)
В заказ наряде.
Нет 8.2

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует