Вход | Регистрация


ТиС 9.2 Поле агрегатного объекта не обнаружено

ТиС 9.2 Поле агрегатного объекта не обнаружено
Я
   hawk1
 
03.11.16 - 22:19
Дорабатываю отчет ОстаткиТМЦ чтобы выводились характеристики номенклатуры. В коде прописываю

Если ПредставлениеЦены = "отпускная цена (только розница)"  Тогда
            Пока Запрос.Группировка("ЦенаПрод") = 1 Цикл
                                                       
                ТЗ.НоваяСтрока();                              
                ТЗ.Уровень = 0;
                ТЗ.ТекРасшифровка     = ТМЦ;  
                ТЗ.ПечАртикул       = ТМЦ.Артикул;
                ТЗ.Родитель            = ТМЦ.Родитель;
                ТЗ.ПечЕд             = ?(ВидЕдиницы = 1,ТМЦ.ОсновнаяЕдиница, ТМЦ.БазоваяЕдиница);
                ТЗ.ПечТекстСтроки    = ТМЦСтрока + ?(ТМЦ.МинОстаток=0,"",", мин. остаток = "+СокрЛП(глФРМКоличество(ТМЦ.МинОстаток,ТЗ.ПечЕд)));
                ТЗ.МинОстаток       = ТМЦ.МинОстаток;
                ТЗ.ОсновноеСвойство = ТМЦ.ОсновноеСвойство;
                ТЗ.СтранаПроисхождения = ТМЦ.СтранаПроисхождения;
                ТЗ.Производитель    = ТМЦ.Производитель;
                ТЗ.Бренд            = ТМЦ._Бренд;
                ТЗ.Модель           = ТМЦ._Модель;
                ТЗ.МинПартия        = ТМЦ._МинПартия;   
                ТЗ.Упаковка         = ТМЦ._Упаковка;
                Если ВыводитьЗаказанный = 1 Тогда
                    ТЗ.Заказано = Запрос.ЗаказаноКонОст;
                КонецЕсли;
                ЗаполнитьСтроку(ТЗ, Запрос, СписокСкладов, ВДокумент);
            КонецЦикла;
        иначе
            ТЗ.НоваяСтрока();                              
            ТЗ.Уровень = 0;
            ТЗ.ТекРасшифровка     = ТМЦ;
            ТЗ.Родитель            = ТМЦ.Родитель;        
            ТЗ.ПечАртикул       = ТМЦ.Артикул;
            ТЗ.ПечЕд             = ?(ВидЕдиницы = 1,ТМЦ.ОсновнаяЕдиница, ТМЦ.БазоваяЕдиница);
            ТЗ.ПечТекстСтроки    = ТМЦСтрока + ?(ТМЦ.МинОстаток=0,"",", мин. остаток = "+СокрЛП(глФРМКоличество(ТМЦ.МинОстаток,ТЗ.ПечЕд)));
            ТЗ.МинОстаток       = ТМЦ.МинОстаток;
            ТЗ.ОсновноеСвойство = ТМЦ.ОсновноеСвойство;
            ТЗ.СтранаПроисхождения = ТМЦ.СтранаПроисхождения;
            ТЗ.Производитель    = ТМЦ.Производитель;
            ТЗ.Бренд            = ТМЦ._Бренд;
            ТЗ.Модель           = ТМЦ._Модель;
            ТЗ.МинПартия        = ТМЦ._МинПартия;   
            ТЗ.Упаковка         = ТМЦ._Упаковка;
            Если ВыводитьЗаказанный = 1 Тогда
                ТЗ.Заказано = Запрос.ЗаказаноКонОст;
            КонецЕсли;
            ЗаполнитьСтроку(ТЗ, Запрос, СписокСкладов, ВДокумент);
        КонецЕсли;  

При выполнении получаю ошибку ТЗ.МинОстаток       = ТМЦ.МинОстаток;
{Отчет.ОстаткиТМЦ.Форма.Модуль(979)}: Поле агрегатного объекта не обнаружено (МинОстаток) хотя такой реквизит есть. В чем проблема?
 
 
   МимохожийОднако
 
1 - 03.11.16 - 22:35
Покажи строку 979 и текст запроса
   Смотрящий
 
2 - 03.11.16 - 22:39
В ТЗ нет колонки МинОстаток ?
   Злопчинский
 
3 - 03.11.16 - 22:42
Для элемента группы этот реквизит не существует возможно
И это... Лучше не наименование цены ориентироваться а на константу розничный тип цен

А ещё правильна и это единственно корректно ценцпрод выводить когда склад.розничный=1 а какой там тип цен совершенно пофиг

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует