Вход | Регистрация


Не видно дополнительного отчета в УТ 3.1

Не видно дополнительного отчета в УТ 3.1
Я
   SherifSP
 
03.11.16 - 11:52
Всем привет, создал простенький отчет, добавил отчет как дополнительный, но в списке отчетов его не вижу, подскажите где нахомутал?

#Если Сервер Или ТолстыйКлиентОбычноеПриложение Или ВнешнееСоединение Тогда
#Область ОбработчикиСобытий


Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
    
    // Если отчет открывается не из документа - нужно показывать только типовые соглашения

    
    ПараметрЗаполнен = Ложь;
    
    ПараметрСоглашение = КомпоновкаДанныхКлиентСервер.ПолучитьПараметр(КомпоновщикНастроек.ФиксированныеНастройки, "Документ");
    ПараметрЗаполнен   = ПараметрЗаполнен(ПараметрСоглашение);
    
    ПараметрСоглашение = КомпоновкаДанныхКлиентСервер.ПолучитьПараметр(КомпоновщикНастроек.Настройки, "Документ");
    ПараметрЗаполнен   = ПараметрЗаполнен(ПараметрСоглашение) Или ПараметрЗаполнен;
    
    ПараметрПартнер  = КомпоновкаДанныхКлиентСервер.ПолучитьПараметр(КомпоновщикНастроек.ФиксированныеНастройки, "Партнер");
    ПараметрЗаполнен = ПараметрЗаполнен(ПараметрПартнер) Или ПараметрЗаполнен;
    
    ПараметрПартнер  = КомпоновкаДанныхКлиентСервер.ПолучитьПараметр(КомпоновщикНастроек.Настройки, "Партнер");
    ПараметрЗаполнен = ПараметрЗаполнен(ПараметрПартнер) Или ПараметрЗаполнен;
    
    Если Не ПараметрЗаполнен Тогда
        ПараметрТолькоТиповые = КомпоновкаДанныхКлиентСервер.ПолучитьПараметр(КомпоновщикНастроек.Настройки, "ТолькоТиповые");
        Если ПараметрТолькоТиповые <> Неопределено Тогда
            ПараметрТолькоТиповые.Значение      = Истина;
            ПараметрТолькоТиповые.Использование = Истина;
        КонецЕсли;
    КонецЕсли;
    
    СегментыСервер.ВключитьОтборПоСегментуНоменклатурыВСКД(КомпоновщикНастроек);
    
КонецПроцедуры

#КонецОбласти

#Область СлужебныеПроцедурыИФункции


// Осуществляет проверку заполненности параметра компоновки

//
// Параметры:

//    Параметр - ЗначениеПараметраНастроекКомпоновкиДанных - параметр, заполненность которого необходимо проверить
//

// Возвращаемое значение:
//    Булево - Истина, если параметр заполнен, Ложь, в противном случае

//
Функция ПараметрЗаполнен(Параметр)
    
    Если Параметр <> Неопределено Тогда
        
        ЗначениеПараметра = Параметр.Значение;
        ТипПараметра      = ТипЗнч(ЗначениеПараметра);
        ПараметрЗаполнен  = ЗначениеЗаполнено(ЗначениеПараметра);
        
        Если ТипПараметра = Тип("СписокЗначений") Тогда
            Если ЗначениеПараметра.Количество() = 0 Тогда
                ПараметрЗаполнен = Ложь;
            Иначе
                ПараметрЗаполнен = Истина;
            КонецЕсли;
        КонецЕсли;
        
    Иначе
        
        ПараметрЗаполнен = Ложь;
        
    КонецЕсли;
    
    Возврат ПараметрЗаполнен;

КонецФункции

функция СведенияОВнешнейОбработке() export
  ПараметрыРегистрации = Новый Структура;
  ПараметрыРегистрации.Вставить("Вид", "ДополнительныйОтчет");
  ПараметрыРегистрации.Вставить("Наименование", "Печать товаров и шк");
  ПараметрыРегистрации.Вставить("БезопасныйРежим", Ложь);
  ПараметрыРегистрации.Вставить("Версия", "1.0");
  ПараметрыРегистрации.Вставить("Информация", "Остатки в кубах");
  ТЗ = Новый ТаблицаЗначений;
  ТЗ.Колонки.Добавить("Представление");
  ТЗ.Колонки.Добавить("Идентификатор");
  ТЗ.Колонки.Добавить("Использование");
  ТЗ.Колонки.Добавить("ПоказыватьОповещение");
  ТЗ.Колонки.Добавить("Модификатор");
  Команды = ТЗ.Добавить();
  Команды.Представление = "Печать товаров и шк";
  Команды.ПоказыватьОповещение = Ложь;
  Команды.Использование = "ОткрытиеФормы";
  Команды.Идентификатор = "Печать товаров и шк";
  ПараметрыРегистрации.Вставить("Команды", ТЗ);
  Возврат ПараметрыРегистрации;
КонецФункции
#КонецОбласти

#КонецЕсли
 
 
   SherifSP
 
1 - 03.11.16 - 12:01
Разобрался, тему можно закрывать

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует