Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Отбор в списке

Отбор в списке
Я
   Пользователь1104
 
01.11.16 - 17:17
При выборе реквизита Номенклатура нужно открыть справочник Номенклатура с отбором по номенклатуре документа "000001" из табличной части. Почему так не работает? Если вид сравнения Равно, то выводит запись, а ВСписке не находит.

&НаКлиенте
Процедура НоменклатураНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь;
    ФормаВыбора = ПолучитьФорму("Справочник.Номенклатура.ФормаВыбора");
    ФормаВыбора.Открыть();
    
    ЭлементОтбора = ФормаВыбора.Список.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    ЭлементОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Ссылка");
    ЭлементОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.ВСписке;
    ЭлементОтбора.ПравоеЗначение = СписокДляОтбора();
    ЭлементОтбора.Использование = Истина;    

КонецПроцедуры

&НаСервере
Функция СписокДляОтбора()

    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    ВыбратьИзбраннуюНоменклатуруИзбратьНоменклатуру.Номенклатура
        |ИЗ
        |    Документ.ВыбратьИзбраннуюНоменклатуру.ИзбратьНоменклатуру КАК ВыбратьИзбраннуюНоменклатуруИзбратьНоменклатуру
        |ГДЕ
        |    ВыбратьИзбраннуюНоменклатуруИзбратьНоменклатуру.Ссылка.Ссылка = &Основание";
    
    Запрос.УстановитьПараметр("Основание",Документы.ВыбратьИзбраннуюНоменклатуру.НайтиПоНомеру("000000001"));
    
    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    СписокДляОтбора = Новый СписокЗначений;
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        СписокДляОтбора.Добавить("Ссылка",ВыборкаДетальныеЗаписи.Номенклатура);
    КонецЦикла;
    
    Возврат СписокДляОтбора; 
    
КонецФункции
 
 
   Lexey_
 
1 - 01.11.16 - 17:23
(0) потому что в списке значений "Ссылка", "Ссылка"...
   Ёпрст
 
2 - 01.11.16 - 17:23
.Ссылка.Ссылка
   Пользователь1104
 
3 - 01.11.16 - 17:24
(1) А что должно быть?
   Ёпрст
 
4 - 01.11.16 - 17:24
Добавить(ВыборкаДетальныеЗаписи.Номенклатура);
   Ёпрст
 
5 - 01.11.16 - 17:25
(3) см (4) 
и выкинь одну ссылку в (2)
   Пользователь1104
 
6 - 01.11.16 - 17:28
(5) спасибо. Только в реквизит не записывается выбранный элемент.
   Lexey_
 
7 - 01.11.16 - 17:32
Имена объектов фееричные, конечно: ВыбратьИзбраннуюНоменклатуру.ИзбратьНоменклатуру
   Lexey_
 
8 - 01.11.16 - 17:36
(6) у ПолучитьФорму () есть параметр Владелец, пихаий туда Элемент
   Пользователь1104
 
9 - 01.11.16 - 17:40
(8) спасибо.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует