Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Ошибка Объект не может быть перезаписан

v7: Ошибка Объект не может быть перезаписан
Я
   geniusbsd
 
01.11.16 - 12:53
День Добрый 
Нужно изменить Владельца Элемента справочника в форме Элемента Справочника  Кнопка с процедурой

Процедура ИзменитьВладельца()
СпрКарт = СоздатьОбъект("Справочник.КартриджиКлиента"); 
Если СпрКарт.НайтиПоКоду(Код) = 1 Тогда
Карт = СпрКарт.ТекущийЭлемент(); 
Карт.Владелец=Клиент;
Карт.Записать();
КонецЕсли;
КонецПроцедуры

Что я делаю не так?
 
 
   MadDAD
 
1 - 01.11.16 - 12:59
(0)
А так работает?

Процедура ИзменитьВладельца()
СпрКарт = СоздатьОбъект("Справочник.КартриджиКлиента"); 
Если СпрКарт.НайтиПоКоду(Код) = 1 Тогда
СпрКарт.Владелец=Клиент;
СпрКарт.Записать();
КонецЕсли;
КонецПроцедуры
   geniusbsd
 
2 - 01.11.16 - 13:03
Так тоже нет. ошибка объектзаблокирован
   lera01
 
3 - 01.11.16 - 13:07
(2) Так ты его же ищешь из его открытой формы? Обалдеть!
   igork1966
 
4 - 01.11.16 - 13:11
(0) Что мешает присвоить владельца прямо в объекте в форме?
   geniusbsd
 
5 - 01.11.16 - 13:12
Так что, делать открытие отдельной обработки и в ней Изменять владельца?Мне нужна эта кнопка на форме элемента.
   geniusbsd
 
6 - 01.11.16 - 13:14
(4) Пробовал так 
Процедура ПриЗаписи()
Владелец=Клиент
КонецПроцедуры
ошибка Объект не может быть перепозиционирован!
   igork1966
 
7 - 01.11.16 - 13:15
(5) Для того чтобы сесть на стул в комнате не нужно предварительно выйти из нее и снова зайти.
   MadDAD
 
8 - 01.11.16 - 13:20
(6)
Так это.

Не нужно ничего искать.
Нужно просто по кнопке сделать:

Процедура ИзменитьВладельца()
Владелец=Клиент;
Записать();
КонецПроцедуры
   geniusbsd
 
9 - 01.11.16 - 13:44
(8) Так я делал в первую очередь
Объект не может быть перепозиционирован!
   Ёпрст
 
10 - 01.11.16 - 14:06
ну, кам минимум, есть 3 способа.
 
 Рекламное место пустует
   Ёпрст
 
11 - 01.11.16 - 14:06
изменить владельца в открытой форме елемента
   Ёпрст
 
12 - 01.11.16 - 14:07
точнее, 4
   geniusbsd
 
13 - 01.11.16 - 14:26
(12) Подскажите какие

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует