Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Вывод табличной части документа в форму списка журнала документов

Вывод табличной части документа в форму списка журнала документов
Я
   Arnulf
 
31.10.16 - 05:44
Всем доброго времени суток! Имеется журнал документов, который регистрирует 3 типа документов : Поступление, перемещение, списание. В табличной части документов имеется графа "Номенклатура". Задача состоит в том, чтобы "Номенклатура" записывалась в табличной части журнала документов в отдельную колонку. Прошу помочь с осуществлением данной задачи.
 
 
   MiniMuk
 
1 - 31.10.16 - 05:46
отдельную колонку для журнала уже сделал?
   Arnulf
 
2 - 31.10.16 - 05:52
нет еще
   Arnulf
 
3 - 31.10.16 - 06:01
да, сделал дал имя "описаниеТабличнойЧасти".
   MiniMuk
 
4 - 31.10.16 - 06:38
(3) как сделал? данные для нее храниться будут  в базе?
   DDwe
 
5 - 31.10.16 - 06:46
(0) А если в документе 500 строк с номенклатурой, как это будет в журнале выглядеть?
   Arnulf
 
6 - 31.10.16 - 06:48
(5) Записать первый из документов.
   Arnulf
 
7 - 31.10.16 - 06:49
(4) да
   DDwe
 
8 - 31.10.16 - 06:51
(6) Куда записать первый из документов?
   Arnulf
 
9 - 31.10.16 - 06:56
(8) *номенклатуру документа можно брать первую из списка табличной части этого документа.
   MiniMuk
 
10 - 31.10.16 - 06:59
(7)
-как сделал?
-да
Ладно, советую делаешь подписку, при проведении документа заполняешь реквизит в котором храниться номенклатурой из первой строки
 
 Рекламное место пустует
   Arnulf
 
11 - 31.10.16 - 07:28
(10) Можно чайнику поподробнее пожалуйста)
   DDwe
 
12 - 31.10.16 - 08:12
(11) А как изначально задача стоит?
   DDwe
 
13 - 31.10.16 - 08:19
Если у него будет сотня документов, с количеством строк в несколько сотен, в эту колонку можно вообще любую номенклатуру писать, разницы ни какой ))
   Arnulf
 
14 - 31.10.16 - 08:23
(12)

Задача состоит в следующем: Имеется журнал документов с название "ЖурналСклада", данный журнал содержит в себе список документов ("Поступление", "Списание", "Перемещение"). У документов есть табличная часть куда записывается "номенклатура", мне нужно чтобы номенклатура документа (хотя бы первая из списка этого самого документа) записывалась в отдельную колонку списка журнала документов "ЖурналСклада".
   DDwe
 
15 - 31.10.16 - 08:31
(14) Хорошо, а смысл?
   DDwe
 
16 - 31.10.16 - 08:32
(15)+ Т.к. это не задача, это то, что тебе велели сделать.
   Arnulf
 
17 - 31.10.16 - 08:39
(15) Ну вот такое задание  ?\_(?)_/?
   DDwe
 
18 - 31.10.16 - 08:40
(17) Не хочешь не говори.
   Arnulf
 
19 - 31.10.16 - 08:42
(18) так как можно сделать?) Помогите пожалуйста.
   DDwe
 
20 - 31.10.16 - 08:43
(19) Ты объясни, что ты хочешь сделать, а главное зачем.
   Arnulf
 
21 - 31.10.16 - 08:48
(20)
Хочу чтобы номенклатура документа записывалась в таблице журнала документов в отдельно колонке, можно первую из списка документа, можно через запятую.... Делается это чтобы не заглядывать в содержание каждого документа, а посмотрев на список иметь хотя бы малое представление содержания документа. ВОТ.
   Windyhead
 
22 - 31.10.16 - 09:29
(21) Пиши в комментарий документа(или заведи доп реквизит строковый) и формируй эту строку при записи документа.
Реквизит выдернешь  графой в журнал.
   AceVi
 
23 - 31.10.16 - 09:57
(22) Плюсую, в зуп так и сделано(отдельный строкой реквизит что куда пишиться краткое ФИО все сотров в документе).
   Arnulf
 
24 - 01.11.16 - 05:53
(23) Процедура ПередЗаписью?
   ASU_Diamond
 
25 - 01.11.16 - 07:02
Хочет чтобы пользователи видели какая номенклатура в документе не заходя в документ. Подход не правильный к решению задачи
   ASU_Diamond
 
26 - 01.11.16 - 07:05
Процедура СписокПриПолученииДанных(Элемент, ОформленияСтрок)
    
    МассивЗаказов = Новый Массив;// для передачи в параметр запроса 

    Соответствие = Новый Соответствие;// для заполнения в строках табличного поля 


    лЗапросОписанияДокумента=Новый Запрос;
    лЗапросОписанияДокумента.Текст="ВЫБРАТЬ
                                   |    ВнутреннийЗаказТовары.Ссылка КАК Документ,
                                   |    ТМЦ.Наименование
                                   |ИЗ
                                   |    Документ.ВнутреннийЗаказ.Товары КАК ВнутреннийЗаказТовары
                                   |        ЛЕВОЕ СОЕДИНЕНИЕ Справочник.Номенклатура КАК ТМЦ
                                   |        ПО ВнутреннийЗаказТовары.Номенклатура = ТМЦ.Ссылка
                                   |ГДЕ
                                   |    ВнутреннийЗаказТовары.Ссылка В(&МассивЗаказов)";
    лЗапросОписанияДокумента.УстановитьПараметр("МассивЗаказов", МассивЗаказов); 

    Выборка = лЗапросОписанияДокумента.Выполнить().Выбрать(); 

    лДок="";лОписаниеДок="";
    Пока Выборка.Следующий() Цикл 
        Если лДок<>Выборка.Документ Тогда
            Если лДок<>"" Тогда
                Соответствие.Получить(лДок).Ячейки.Описание.Значение = лОписаниеДок; 
            КонецЕсли; 
            лДок=Выборка.Документ;
            лОписаниеДок="";
        КонецЕсли; 
        лОписаниеДок=лОписаниеДок+СокрЛП(Выборка.Наименование)+",";
    КонецЦикла; 
    Если лДок<>"" Тогда
        Соответствие.Получить(лДок).Ячейки.Описание.Значение = лОписаниеДок; 
    КонецЕсли; 
    
КонецПроцедуры
   ASU_Diamond
 
27 - 01.11.16 - 07:06
как-то вот так в журнале реализовывается.
   ASU_Diamond
 
28 - 01.11.16 - 07:07
(+26) в форме журнала добавлена дополнительная колонка "Описание"


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует