Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Контрагент в Табличной части "Товары"

Контрагент в Табличной части "Товары"
Я
   Pavel55555
 
28.10.16 - 13:19
Доброго дня!
Платформа 8.3 Толстый клиент. УТ 10.3
Документ "Поступление товаров и услуг", задача -  в списке табличной части "Товары" в новой колонке вывести контрагента товара т.е. "Основной поставщик", не в документе поступления! а именно в табличной части, другими словами вывод ссылки на контагента текущего товара.

Колонку "Поставщик" создал, данные "СправочникСсылка.Контрагенты"

Не могу сообразить как реализовать, штатными средствами или процедуру сочинять или процедуру с запросом?
Подскажите откуда ноги растут!
Спасибо!
 
 
   Лефмихалыч
 
1 - 28.10.16 - 13:21
(0) а как по номенклатурной позиции определить этого основного поставщика?
   Альбатрос
 
2 - 28.10.16 - 13:21
Способов мильон, все зависит от того, как ты хочешь чтоб это выглядело
   Альбатрос
 
3 - 28.10.16 - 13:24
(1) Так реквизит есть в номенклатуре
   Михаил Козлов
 
4 - 28.10.16 - 13:26
Колонка нужна без данных (без реквизита табличной части): показывать текст ячейки в ПриПолученииДанных.
   Pavel55555
 
5 - 28.10.16 - 13:27
(3) В номенклатуре есть Поле выбора ОсновнойПоставщик он как бы завязан за этим товаром.
   Pavel55555
 
6 - 28.10.16 - 13:29
(4) колонка есть, реквизит убрал, ПриПолученииДанных что запрос писать?
   Лиза777
 
7 - 28.10.16 - 13:30
можно и в ТоварыПриВыводеСтроки()  написать этот вывод
   Альбатрос
 
8 - 28.10.16 - 13:30
(6) Номенклатура.ОсновнойПоставщик, не?
   Pavel55555
 
9 - 28.10.16 - 13:31
(7) В том то и дела не могу догнать как написать этот вывод :(
   Pavel55555
 
10 - 28.10.16 - 13:32
Процедура ТоварыПриПолученииДанных(Элемент, ОформленияСтрок)
?????????????????    
КонецПроцедуры
 
 Рекламное место пустует
   Pavel55555
 
11 - 28.10.16 - 13:32
(8) Да Номенклатура.ОсновнойПоставщик
как написать этот вывод :(
   Михаил Козлов
 
12 - 28.10.16 - 13:34
(10)
ДЛЯ каждого оф ИЗ ОформленияСтрок Цикл
   оф.Ячейки.Поставщик.УстановитьТекст(оф.ДанныеСтроки.Номенклатура.ОсновнойПоставщик);
КонецЦикла;
   bootini
 
13 - 28.10.16 - 13:40
Если нужно только отображать только текущего ОснПоставщика, то ПриВыводеСтроки или ТоварыПриПолученииДанных, если нужно хранить, в реквизите ТЧ, то заполняй поставщика в ТоварыПриНачалеРедактирования
   Pavel55555
 
14 - 28.10.16 - 13:43
(12) БОЛЬШОЕ ЧЕЛОВЕЧЕСКОЕ СПАСИБО! ВСЁ ЧОТКО.
Возникает вопрос я только начал изучать 1С. где можно прочитать про эти команды:
оф.Ячейки. что означает
оф. что означает
А как допустим добраться до табличной части в номенклатуре, например Места хранения
оф.Ячейки.МестаХранения.УстановитьТекст(оф.ДанныеСтроки.Номенклатура.тчМестаХранения);
Тип значения у него: РегистрСведенийСписок.МестаХраненияНоменклатуры
Как то так?
   Pavel55555
 
15 - 28.10.16 - 13:44
(13) Спасибо я это учту!
   Михаил Козлов
 
16 - 28.10.16 - 13:48
(14) тчМестаХранения, скорее всего, не табличная часть, а табличное поле на форме, куда выводятся записи РС "МестаХраненияНоменклатуры" с отбором по измерению Номенклатура.
Если Вы хотите и в форме документа показывать места хранения, то сначала определитесь как несколько мест хранения отобразить в виде текста. Например, через запятую. Или выбрать место хранения по умолчанию. А потом программно сформировать это текст.
   Pavel55555
 
17 - 28.10.16 - 13:56
(16) Да кстати мест хранения два Витрина и Склад
Да это табличное поле имя МестаХранения
Тип значения: РегистрСведенийСписок.МестаХраненияНоменклатуры
В нем 3 колонки
Склад, Приоритет, Место Хранения
   Pavel55555
 
18 - 28.10.16 - 14:01
(16) Наверно придется выводить две колонки:
Витрина и Склад
и в них писать запрос для кадного?
   bootini
 
19 - 28.10.16 - 14:03
(17) Значит или запросом или
https://helpf.pro/faq/view/678.html
   Vladal
 
20 - 28.10.16 - 14:04
(14) В книге "Практическое пособие разработчика". Для обычного приложения Радченко сам писал, для управляемых форм вместе с Хрусталевой.
   Джинн
 
21 - 28.10.16 - 14:05
Очередная попытка великих "бизьнесьменов" почесать левое ухо правой ногой через спину?
   Pavel55555
 
22 - 28.10.16 - 14:16
(20) у нас обычные формы
   Pavel55555
 
23 - 28.10.16 - 14:24
(20) Это случайно не Радченко, Хрусталева
1С:Предприятие 8.3 "Практическое пособие разработчика" - примеры и типовые приемы 2013 год.
   Pavel55555
 
24 - 28.10.16 - 14:37
(16) А может остатки вывести как общие по организации и не делить их по складу и так далее...
   Pavel55555
 
25 - 28.10.16 - 14:39
Нет остатки остатками и места хранения нужно делить
   LeReve
 
26 - 28.10.16 - 14:42
(14) >я только начал изучать 1С.

Беги, глупец...
   Pavel55555
 
27 - 28.10.16 - 15:27
(26) Спасибо за комплимент...

(19) Запрос такого плана:
Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    МестаХраненияНоменклатуры.МестоХранения
        |ИЗ
        |    РегистрСведений.МестаХраненияНоменклатуры КАК МестаХраненияНоменклатуры";
    
    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();


Что то не то... 
:(
   Михаил Козлов
 
28 - 28.10.16 - 15:29
(27) Так Вы получите все записи регистра.
Поищите тексты запросов в Вашей конфигурации - найдете много примеров, как их писать.
   Pavel55555
 
29 - 28.10.16 - 15:42
(28) Вот в списке Номеклатуре доп поле с Местами храниния и остатком: две процедуры
1-я
Процедура ТабличноеПолеОстаткиТоваровВыбор(Элемент, ВыбраннаяСтрока, Колонка, СтандартнаяОбработка)
    
    Если ЭлементыФормы.Список.ТекущиеДанные <> Неопределено
       И НЕ ЭлементыФормы.Список.ТекущиеДанные.ЭтоГруппа Тогда
        РаботаСДиалогами.ОбработатьВыборТаблицаОстатков(Элемент, ВыбраннаяСтрока, Колонка, СтандартнаяОбработка, ЭлементыФормы.Список.ТекущиеДанные.Ссылка);
    КонецЕсли; 
    
КонецПроцедуры

2-я
Процедура ТабличноеПолеОстаткиТоваровПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    
    РаботаСДиалогами.ПриВыводеСтрокиБезЦены(Элемент, ОформлениеСтроки, ДанныеСтроки, Истина, ЭлементыФормы.Список.ТекущиеДанные);
    РаботаСДиалогами.ПриВыводеСуммОстатковНоменклатуры(ОформлениеСтроки, ДанныеСтроки, мСписокПрефиксовЦен, ВВалютеЦены);
    
КонецПроцедуры

Но это не запрос.... :(
   Pavel55555
 
30 - 28.10.16 - 15:48
Вывод при выборе строки
   Pavel55555
 
31 - 28.10.16 - 15:55
(28) Не могу найти документ в выводом мест хранений в табличных частях, кроме как вывод чека "АСПД Накладная на склад" там запрос, не совсем то...
   bootini
 
32 - 28.10.16 - 15:58
Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    МестаХраненияНоменклатуры.МестоХранения
        |ИЗ
        |    РегистрСведений.МестаХраненияНоменклатуры КАК МестаХраненияНоменклатуры
        |ГДЕ
        |    МестаХраненияНоменклатуры.Номенклатура = &Номенклатура";
    
    Запрос.УстановитьПараметр("Номенклатура", Номенклатура);

    
    РезультатЗапроса = Запрос.Выполнить().Выгрузить();
   bootini
 
33 - 28.10.16 - 16:01
Отбор = Новый Структура("Номенклатура");
Отбор.Номенклатура = Номенклатура;
ВыборкаМестаХранения= РегистрыСведений.МестаХраненияНоменклатуры .Выбрать(Отбор);
 
 
   Pavel55555
 
34 - 28.10.16 - 17:40
(33) Спасибо, сейчас попробую
   Pavel55555
 
35 - 28.10.16 - 18:01
(32) Что не получается..
Запрос в ТЧ создавать или модуле документа?
Я создал в ТЧ, колонка пуская
   Pavel55555
 
36 - 29.10.16 - 14:15
(16) Подскажите где можно найти приблизительный запрос "МестаХранения" с отбором по Складу, склад указывается в документе...


Список тем форума
  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует