Вход | Регистрация


Не работают обработчики событий в модуле документа, в расширении.

Не работают обработчики событий в модуле документа, в расширении.
Я
   lexx256
 
28.10.16 - 10:32
Платформа 8.3.9.1818. В модуль расширения документа "Заказ клиента" добавлен следующий код:

&После("ОбработкаПроведения")
Процедура CRM1_ОбработкаПроведения(Отказ, РежимПроведения)
    Сообщить("1");
КонецПроцедуры


&После("ПриЗаписи")
Процедура CRM1_ПриЗаписи(Отказ)
    
    Сообщить("2");
    
КонецПроцедуры


&Перед("ПередЗаписью")
Процедура CRM1_ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
    
    Отказ=Истина;
    Сообщить("0");
    
КонецПроцедуры

Документы записываются и проводятся, никакие сообщения не выводятся. Проверял на двух разных базах. Само расширение загружается без ошибок. Кто-нибудь использовал обработчики в модуле документов в расширениях?
 
 
   vollove
 
1 - 25.11.16 - 11:30
(0) сними галку безопасный режим в расширении

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует