Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Немонопольное удаление помеченных на удаление

v7: Немонопольное удаление помеченных на удаление
Я
   vadim777
 
28.10.16 - 10:27
Скачал http://catalog.mista.ru/public/19666/, она меня озадачила.
Запускаю, вроденачинает работать,через время как бы тихо завершается.
Понатыкал отладочной печати, и что обнаружилось:
Процедура ПерезаполнитьТЗ()
.....
    Для сч = 1 По Список.РазмерСписка() Цикл
        знач_ = Список.ПолучитьЗначение(сч, );
        s = знач_.Вид();
        d = ТипЗначенияСтр(знач_);
        Список.УстановитьЗначение(сч, s,, );
        Список2.ДобавитьЗначение(d, );
    КонецЦикла;

Когда процесс заходит в этот цикл, то управление отдается 1С - можно работать как обычно. А цикл продолжает также работать. Как такое возмножно?
 
 
   Это_mike
 
1 - 28.10.16 - 10:29
а ОбработкиОжидания - нигде нет?
   vadim777
 
2 - 28.10.16 - 10:32
(1) Нигде
   vadim777
 
3 - 28.10.16 - 10:34
(0) Дополнение: 1С на сервере 2008, база на ms sql2008. Но думаю это не влияет.
   vadim777
 
4 - 28.10.16 - 10:37
Как только процесс вышел из цикла, обработка вновь управление забрала на себя,и пока процедура не отработала, больше управление 1С не отдавала. Странно все это...
   Ёпрст
 
5 - 28.10.16 - 10:42
Посмотрел, не подтверждаю.
Нет передачи управления в 1с .
   Базис
 
6 - 28.10.16 - 10:43
Подозрительны разные названия списков  Список и Список2. Нет ли изменений в списке при выборке записей из списка?
   NikVars
 
7 - 28.10.16 - 10:44
(0) Попробуй вывести какую-то информацию через сообщить.
Например, размер списка перед циклом и размер списка2, например, в через каждый десяток. Интересен объем этих списков.
   Ёпрст
 
8 - 28.10.16 - 10:45
(0)Если ты имеешь ввиду выполнение кода в приОткрытии() и в это время ты можешь по меню лазить - так это баян со времён Рупора.
   NikVars
 
9 - 28.10.16 - 10:46
Суть списка.... В списке значение заменяется на его вид...
   Ёпрст
 
10 - 28.10.16 - 10:46
И это работает только при первом открытии.
 
 Рекламное место пустует
   Ёпрст
 
11 - 28.10.16 - 10:46
И баяну, лет 16 :)
   vadim777
 
12 - 28.10.16 - 10:49
(8) Точно, это вызывается из ПриОткрытии().
А кто такой Рупор?
   Ёпрст
 
13 - 28.10.16 - 10:50
(12) ©РупорАбсурда
   Ёпрст
 
14 - 28.10.16 - 10:50
   vadim777
 
15 - 28.10.16 - 10:52
(14) Так это баян,глюк, или фича?
   Ёпрст
 
16 - 28.10.16 - 10:53
(15) Фича 1с, баян со времён 7.5

Если в ПриОткрытии создать долгий цикл, то можно работать в 1с пока он не закончится, но только при первом открытии обработки. Второй раз откроешь - эффекта не будет

Достаточно так написать:

Процедура ПриОткрытии()
    Пока 1=1 Цикл
    КонецЦикла;
КонецПроцедуры
   vadim777
 
17 - 28.10.16 - 10:57
(16)Спасибо, не знал...

Список тем форума
Рекламное место пустует  Рекламное место пустует
Здесь во втором сообщении вам дадут решение, а в двадцатом дадут правильное решение. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует