Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Чем обработать такой документ в 7.7

v7: Чем обработать такой документ в 7.7
Я
   myr4ik07
 
27.10.16 - 22:45
Это ответ от сервиса в интернете http://prntscr.com/czro0m
я его запихнул в хмл документ, как этот документ обработать и получить БезНал или Нал?
 
 
   myr4ik07
 
1 - 27.10.16 - 22:47
или может как правильно записать хмл, что бы потом его можно было прочитать?!
   Garykom
 
2 - 27.10.16 - 23:18
   Garykom
 
3 - 27.10.16 - 23:18
   myr4ik07
 
4 - 27.10.16 - 23:21
(3) ты и в правду думаешь что я предложенную ссылку не видел? Ты пробовал разобрать мою структура файла этим способом? Я умею пользоваться поисковиком, не надо за меня это делать, я эти вже дранные статьи скопированные из одного места в другое с теми же ошибками за 3 день разбора уже не раз видел
   Кадош
 
5 - 27.10.16 - 23:25
(4) с таким гонором ты далеко не уедешь. Тем более если ты за 3 дня не смог найти решение для такого простого вопроса
   myr4ik07
 
6 - 27.10.16 - 23:27
(5) я очень, я сильно тебя прошу показать мне скриншот результата, выборки только значений БезНал и Нал с такой структуры файла, если это так легко?!
   myr4ik07
 
7 - 27.10.16 - 23:27
простой блин, только рассказывать умеют, простой
   myr4ik07
 
8 - 27.10.16 - 23:28
   myr4ik07
 
9 - 27.10.16 - 23:32
(5) и если "а оно мне надо" - скажешь, то не надо тут треп разводить про простую задачу
   myr4ik07
 
10 - 27.10.16 - 23:33
(5) кстати, https://copyraite.blogspot.com/2016/10/xml-77.html мне не надо, мне нужно MSXML.DOMDocument
 
 Рекламное место пустует
   Mauser
 
11 - 27.10.16 - 23:41
(6), (7), (8), (9), (10) А ты весь код таким методом пишешь или бывает еще хуже?
   Злопчинский
 
12 - 27.10.16 - 23:50
То есть значит не осилил рекурсией разобрать?
То есть мну среди ночи подрываться комп включать и скидывать тебе рабочую процедуру последовательного чтения тегов?
   Кадош
 
13 - 27.10.16 - 23:53
(12) придется тебе подрываться. Украинцам думают, что теперь им должны не только подсказывать, но и делать за них всю работу
   Злопчинский
 
14 - 27.10.16 - 23:55
Украинцев чтото прорвало, как не в себе последнее время, поперли семерочные запросы, из нэньки...
   Garykom
 
15 - 27.10.16 - 23:55
(7) Скажи ты в универе учился?
   Злопчинский
 
16 - 27.10.16 - 23:56
Эхх мне ж ишшо по впну из гостевого питера лезть в родной офис в подмосковье...
   Garykom
 
17 - 27.10.16 - 23:57
(15)+ если да то должен знать про конечные автоматы, если нет то пора уже приступать к учебе http://www.intuit.ru/studies/courses/1064/170/lecture/4614...

ЗЫ Любой парсер это по факту КА
   myr4ik07
 
18 - 28.10.16 - 00:08
При чем здесь украинцы, африканцы, японцы?!
Рекурсию осилил но как получить значения с определенного <значения> нет, выходит, что это просто строка, а не узел хмл
   Злопчинский
 
19 - 28.10.16 - 00:15
ну блин открыть и почитать сил видимо не хватило?
   Злопчинский
 
20 - 28.10.16 - 00:15
Процедура ПриОткрытии()
    Иксемель = СоздатьОбъект("Microsoft.XMLDOM");
    Иксемель.Load("d:\temp\test.xml");
    Корень = Иксемель.DocumentElement;
    
    ОбработатьУзел(Корень, 0);//тест чтения

    
    Иксемель = "";    
    
КонецПроцедуры//ПриОткрытии()
   Злопчинский
 
21 - 28.10.16 - 00:16
Процедура ОбработатьУзел(Узел, Уровень=0)
    Состояние(Уровень);
    
    КолвоУзлов = Узел.childNodes.length;
    Для СчУзлов = 0 По КолвоУзлов-1 Цикл
        
        ТекУзел = Узел.childNodes.item(СчУзлов);
        Если ТекУзел.nodeType <> 1 Тогда Продолжить; КонецЕсли;
        
        Стр = Формат("","С"+Уровень*8);
        
        СтрАтрибуты = "";
        Для счАтрибутов = 0 По ТекУзел.attributes.length-1 Цикл
            Атрибут     = ТекУзел.attributes.item(счАтрибутов);
            СтрАтрибуты    = СтрАтрибуты + ?(СтрАтрибуты="","",";") + Атрибут.nodename+"="+Атрибут.value;
        КонецЦикла;
        
        ТекстУзла = "";
        Если ТекУзел.childNodes.length = 1 Тогда
            Если  ТекУзел.childNodes.item(0).nodetype = 3 Тогда ТекстУзла = ТекУзел.childNodes.item(0).text; КонецЕсли;
        КонецЕсли;
        
        Стр = Стр + ТекУзел.tagName + ?(СтрАтрибуты="","","("+СтрАтрибуты+")" ) + ": " +ТекстУзла;
        Сообщить(Стр);
        
        ОбработатьУзел(ТекУзел, Уровень+1);
    КонецЦикла;
    
    Состояние("");
КонецПроцедуры// ОбработатьУзел()
   Злопчинский
 
22 - 28.10.16 - 00:18
Мавр сделал свое дело, мавр уходит...
(эти люди еще и восьмерят...)
   Aleksey
 
23 - 28.10.16 - 00:20
А почему эти 3 строчки нельзя как текст прочитать?
   myr4ik07
 
24 - 28.10.16 - 00:21
(23) та этих строчек может быть не три, кто его знает, что отдаст другой запрос к сервису в виде хмл строки
   Злопчинский
 
25 - 28.10.16 - 00:21
   myr4ik07
 
26 - 28.10.16 - 00:23
(21) я в шоке, обработался хмл бомбецки, в точку, прямо в 100-ку, нет слов


точнее есть, я желаю вам того, что и себе желаю, из добра!
   Злопчинский
 
27 - 28.10.16 - 00:23
при выполнении социального заказа с окраины применил бдд, тдд, скрам, аджайл, канбан, постгрескюэль и не забыл почистить кэш
   Mauser
 
28 - 28.10.16 - 00:29
(27) Начистить кэш [x]


Список тем форума
Рекламное место пустует  Рекламное место пустует
Здесь можно задать вопрос "Как сделать?" и получить кучу ответов, что тебе это делать не надо. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует