Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Заполнение реквизита при открытии внешней обработки

Заполнение реквизита при открытии внешней обработки
Я
   glprog
 
27.10.16 - 16:41
Добрый день!

Понимаю что задача элементарная, но разобраться не смог.
1С 8.3. Внешняя обработка. УФ. Есть реквизит обработки Дата. На форме обработки есть соответствующее поле. Нужно чтобы при открытии внешней обработки поле "Дата" заполнялось текущей датой.
 
 
   aka AMIGO
 
1 - 27.10.16 - 16:44
Есть в модуле процедура типа "ПриОткрытии()" ?
Вот в ней и присвоить дате значение ТекущаяДата() или похожее, существующее в 8.3
   glprog
 
2 - 27.10.16 - 16:51
У меня вот так. Не работает.
[pre]Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

Документ = РеквизитФормыВЗначение("Объект");
    
Документ.Дата    = ТекущаяДата();

ЗначениеВРеквизитФормы(Документ, "Объект");


КонецПроцедуры
[/pre]
   mikecool
 
3 - 27.10.16 - 17:03
(2) не используй зарезервированные слова
   Мойдодыр
 
4 - 27.10.16 - 17:04
(2) какое здесь слово зарезервированное?
   glprog
 
5 - 27.10.16 - 17:05
Я уже понял. Редко здесь пишу.
   glprog
 
6 - 27.10.16 - 17:05
Я думаю имеется ввиду [pre]
   newbling
 
7 - 27.10.16 - 17:43
(6) Имеется ввиду Документ
   glprog
 
8 - 27.10.16 - 17:58
(7) Черт! Где ты раньше был! :) Заработало. Спасибо.
(3) и тебе вдогонку.
   glprog
 
9 - 28.10.16 - 09:25
Рано я радовался. Все равно не работает. Если не трудно, покажите рабочий код по вопросу.
   МимохожийОднако
 
10 - 28.10.16 - 09:35
В соседней ветке сегодня кидали любопытную ссылку для начинающих http://v8.1c.ru/metod/faq2/answer.jsp?id=651
 
 Рекламное место пустует
   Лефмихалыч
 
11 - 28.10.16 - 09:37
(2)
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка) 
Объект.Дата = ТекущаяДатаСеанса();
КонецПроцедуры
   glprog
 
12 - 28.10.16 - 09:52
(11) Не работает. Поле остается пустым.
   glprog
 
13 - 28.10.16 - 09:54
Обработку запускаю через Файл->Открыть
   МимохожийОднако
 
14 - 28.10.16 - 09:55
(12) Тогда воткни в процедуру ПриОткрытии()
   glprog
 
15 - 28.10.16 - 10:07
(14) Да, так работает. Спасибо.
&НаКлиенте
Процедура ПриОткрытии(Отказ)

 Объект.Дата = ТекущаяДата();

КонецПроцедуры

Думал что понял логику УФ. Оказалось не очень.
   Лефмихалыч
 
16 - 28.10.16 - 10:34
(15) значит и это (11) тоже работает
   Мойдодыр
 
17 - 28.10.16 - 10:38
(16) Нет, скорее всего загружается пустая дата из сохранненных настроек.
А приОткрытии срабатывает после

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует