Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Помогите, как с расшфировкой макета

Помогите, как с расшфировкой макета
Я
   ytex
 
27.10.16 - 15:40
Добрый день. У табличного документа добавил событие - ОбработкаРасшифровки.

...
    ТабДок = ЭтотОбъект.ТабДок;
    ТабДок.Очистить();
    Макет = РеквизитФормыВЗначение("Отчет").ПолучитьМакет("Макет");
    
    ОбластьШапки = Макет.ПолучитьОбласть("Шапка");
    ТабДок.Вывести(ОбластьШапки);
    
    ОбластьСтроки = Макет.ПолучитьОбласть("Строка");
    
    
    Запрос = Новый Запрос;
    ...
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        ОбластьСтроки.Параметры.Номер = ВыборкаДетальныеЗаписи.Номер;
        ОбластьСтроки.Параметры.Артикул = ВыборкаДетальныеЗаписи.Артикул;
        ОбластьСтроки.Параметры.Количество = ВыборкаДетальныеЗаписи.КоличествоГП;
        ТабДок.Вывести(ОбластьСтроки);
    КонецЦикла;
    ТабДок.ТолькоПросмотр = Истина;
...

&НаКлиенте
Процедура ТабДокОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)
    ТабДокОбработкаРасшифровкиНаСервере();
КонецПроцедуры

&НаСервере
Процедура ТабДокОбработкаРасшифровкиНаСервере()
    // Вставить содержимое обработчика.
КонецПроцедуры
...

подскажите, как сделать так, чтобы щелкая в отчете по номеру открывался документ?
 
 
   korppinen
 
1 - 27.10.16 - 15:55
ПАраметр расшифроки-то определите! В свойствах ячейки это.

Список тем форума
Рекламное место пустует  Рекламное место пустует
Прочитай, хотя бы, Митичкина "Разработка в системе 1С:Предприятие 8". Волшебник
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует