Вход | Регистрация


Получить объект 7-ки через ole в 8-ке

Получить объект 7-ки через ole в 8-ке
Я
   myr4ik07
 
27.10.16 - 14:37
Нужно создать в 7-ке доукмент через оле с 8-ки

Процедура СоздатьНажатие(Элемент)

ДокOLE  = БазаТам.CreateObject("Документ.Приемка");
обКонтрагент = БазаТам.CreateObject("Справочник.Контрагенты");
обДок = СпрOLE.Новый();
Если  НайтиКонтрагента(ЭлементыФормы.списокКонтрагентов.ВыделенныйТекст,обКонтрагент) = 0 Тогда
            Предупреждение("Контрагент в базе 7.7 не найден");
            Возврат;
        Иначе 
            Контрагент = обКонтрагент.ТекущийЭлемент();
        КонецЕсли;

ДокOLE.Записать();
КонецПроцедуры


Функция НайтиКонтрагента(Наименование,обКонтрагент)
        
    Возврат обКонтрагент.НайтиПоНаименованию(Наименование,0,1);    
    
КонецФункции


в результет в 7-ке в реквизите контрагент не заполнено
 
 
   myr4ik07
 
1 - 27.10.16 - 14:38
извиняюсь, все норм, нашел кизяк
   myr4ik07
 
2 - 27.10.16 - 14:41
ДокOLE.Контрагент = обКонтрагент.ТекущийЭлемент();


ну и + не
обДок = СпрOLE.Новый();
а
обДок = ДокOLE .Новый();

Список тем форума
Рекламное место пустует  Рекламное место пустует
AdBlock убивает бесплатный контент. 1Сергей
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует