Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Пытаюсь программно задать значение списка выбора для перечисления

Пытаюсь программно задать значение списка выбора для перечисления
Я
   Ivan_495
 
27.10.16 - 11:34
Пытаюсь программно задать значение списка выбора для перечисления статус.
В модуле управляемой формы добавил код

&НаКлиенте
Процедура СтатусНачалоВыбораИзСписка(Элемент, СтандартнаяОбработка)

    СтандартнаяОбработка=Ложь;
    Переч=Перечисления.Статус;
СписокСтатусов=Элементы.Статус.СписокВыбора;
              СписокСтатусов.Очистить();
              СписокСтатусов.Добавить(Переч.Закрыто);
              СписокСтатусов.Добавить(Переч.КИсполнению);
              
КонецПроцедуры
Ставлю точку останова . не останавливается?
 
 
   Ivan_495
 
1 - 27.10.16 - 11:35
Установлен РежимВыбораИзСписка
   Рэйв
 
2 - 27.10.16 - 11:45
1.убери из ПриНачалеВыбора
2.При создании на сервере:

//---

   Переч=Перечисления.Статус;

   Сп=Новый СписокЗначений;
   Сп.Добавить(Переч.Закрыто);
   Сп.Добавить(Переч.КИсполнению);
   
   Элементы.Статус.СписокВыбора.ЗагрузитьЗначения(Сп.ВыгрузитьЗначения());

Должно нормально заработать
   Ivan_495
 
3 - 27.10.16 - 11:47
&НаКлиенте
Процедура СтатусНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    // Вставить содержимое обработчика.

     Если Объект.Наименование="Закрыто или к исполнению" тогда
    Переч=Перечисления.Статус;
СписокСтатусов=Элементы.Статус.СписокВыбора;
              СписокСтатусов.Очистить();
              СписокСтатусов.Добавить(Переч.Закрыто);
              СписокСтатусов.Добавить(Переч.КИсполнению);
 КонецЕСли;
КонецПроцедуры
вот так работает
   Ivan_495
 
4 - 27.10.16 - 11:49
НачалоВыбораИзСписка чем отличатся от НачалоВыбора ?
   Рэйв
 
5 - 27.10.16 - 12:00
(4)Из назания не понятно разве?
первое при начале выбора через список, второе стандартно через три точки
   Ivan_495
 
6 - 27.10.16 - 12:15
а почему так не работает?
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    //Вставить содержимое обработчика

    Если Параметры.Ключ.Пустая() = Истина тогда
        Если Объект.Наименование="Закрыто или к исполнению" тогда
            Элементы.Статус.РежимВыбораИзСписка=Истина;
            Переч=Перечисления.Статус;
            СписокСтатусов=Элементы.Статус.СписокВыбора;
            СписокСтатусов.Очистить();
            СписокСтатусов.Добавить(Переч.Закрыто);
            СписокСтатусов.Добавить(Переч.КИсполнению);
        иначе
                    
        КонецЕСли;
    КонецЕСли;

КонецПроцедуры
   Ivan_495
 
7 - 27.10.16 - 12:16
РежимВыбораИзСписка настраивать нельзя?
   Ivan_495
 
8 - 27.10.16 - 12:21
РежимВыбораИзСписка в модуле формы настраивать нельзя?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует