Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Как интегрировать в самописку отчет о движении документа?

Как интегрировать в самописку отчет о движении документа?
Я
   tciban
 
27.10.16 - 10:28
Добрый день, уважаемые коллеги! Вот понадобилось в отладочных челях последить за движениями документа в самописке. Взял из УТ 11 отчет, ДвиженияДокумента, вставил. А вот что делать далее - не пойму. В УТ11 этот отчет доступен в каждом документе, у меня его не видно. Что сделал не так? Подозреваю, что это как то связано с группой команды отчета...
 
 
   Tarlich
 
1 - 27.10.16 - 10:43
ОбщиеКоманды ->СтруктураПодчиненности ....?
   Мойдодыр
 
2 - 27.10.16 - 10:46
(1) Уже не так все делается
   tciban
 
3 - 27.10.16 - 10:51
(1) Вот со структурой подчиненности все легко и понятно...
   tciban
 
4 - 27.10.16 - 12:24
Так в чем дело то? Куда копать?
   asady
 
5 - 27.10.16 - 12:36
(0) экий вы батенька затейник!

теперь это называется словом "интегрировать"

просто содинэсить код в свою нетленку уже не по фэн-шую?
   CMblCL
 
6 - 27.10.16 - 12:44
(0) смотрю зуп 2.5, в каждом доке

// Процедура вызывается при выборе пункта подменю "Движения документа по регистрам" меню "Перейти".

// командной панели формы. Процедура отрабатывает печать движений документа по регистрам.
//

Процедура ДействияФормыДвиженияДокументаПоРегистрам(Кнопка)

    РаботаСДиалогами.НапечататьДвиженияДокумента(Ссылка);

КонецПроцедуры// ДействияФормыДвиженияДокументаПоРегистрам()


и в общем модуле

// Печатает движения документа

//
// Параметры:

//  ДокументСсылка - ссылка на документ, движения которого печатаем
//

Процедура НапечататьДвиженияДокумента(ДокументСсылка) Экспорт
    
    Форма = Отчеты.ДвиженияДокумента.ПолучитьФорму(,,Новый УникальныйИдентификатор);
    Форма.Открыть();
    Форма.Документ = ДокументСсылка;
    Форма.СформироватьИВывестиОтчет();
    
КонецПроцедуры// НапечататьДвиженияДокумента()
   Мойдодыр
 
7 - 27.10.16 - 12:46
Какой ЗУП 2.5 когда тут уф
   Mort
 
8 - 27.10.16 - 12:54
В тип команды нужные доки пропиши. Это первое что приходит на ум.
   Mort
 
9 - 27.10.16 - 12:54
*тип параметра
   Mankubus
 
10 - 27.10.16 - 13:01
(0) смотрим модуль менеджера
// Заполняет список команд отчетов.

// 
// Параметры:

//   КомандыОтчетов - ТаблицаЗначений - состав полей см. в функции МенюОтчеты.СоздатьКоллекциюКомандОтчетов
//

Процедура ДобавитьКомандыОтчетов(КомандыОтчетов) Экспорт

    ВариантыОтчетовУТПереопределяемый.ДобавитьКомандуСтруктураПодчиненности(КомандыОтчетов);

    ВариантыОтчетовУТПереопределяемый.ДобавитьКомандуДвиженияДокумента(КомандыОтчетов);

КонецПроцедуры
 
 Рекламное место пустует
   tciban
 
11 - 27.10.16 - 13:03
(8) Такой вариант я давно сделал, так работает. Но вот в УТ11 ничего такого не прописано и все работает! Вот и охота понять в чем дело?
   tciban
 
12 - 27.10.16 - 13:07
(10) О! Похоже вот оно! Спасибо за наводку!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует