Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Отображение на форме обработки картинки из рег-ра сведений

Отображение на форме обработки картинки из рег-ра сведений
Я
   ferry
 
27.10.16 - 10:12
Добрый день! Что-то туплю. Есть регистр сведения с ресурсом Картинка типа Хранилище значений. Надо на форме обработки отобразить изображение которое в нем содержится. Делаю так
&НаКлиенте
Процедура ТаблицаПечатиПриАктивизацииСтроки(Элемент)
    Если Элементы.ТаблицаПечати.ТекущиеДанные=Неопределено Тогда Возврат; КонецЕсли;
    ПолучитьКартинкуСервер(Элементы.ТаблицаПечати.ТекущиеДанные.Номенклатура);
КонецПроцедуры

&НаСервере
Процедура ПолучитьКартинкуСервер(Номенклатура)
    Рег = Регистрысведений.ХарактеристикиНоменклатурыОбщие.СоздатьНаборЗаписей();
    Рег.Отбор.Номенклатура.Установить(Номенклатура);
    Рег.Прочитать();  
    Если Рег.Количество()=0 тогда
        ИзображениеНаФорме="";
    Иначе    
        Попытка
            ИзображениеНаФорме=ПолучитьНавигационнуюСсылку(Рег[0].ИсходныйКлючЗаписи,"Картинка"); 
        Исключение
            Сообщить("Упс");
        КонецПопытки;
    КонецЕсли;
 КонецПроцедуры

Но у Рег[0] нет свойства ИсходныйКлючЗаписи. Как тогда использовать ПолучитьНавигационнуюСсылку?
 
 
   ferry
 
1 - 27.10.16 - 10:17
ИзображениеНаФорме реквизит на форме с Видом  поле картинки типа строка.
   Lexey_
 
2 - 27.10.16 - 10:24
(0) РегистрСведенийМенеджер.СоздатьКлючЗаписи(<ЗначенияКлюча>)
Параметры:

<ЗначенияКлюча> (обязательный)

Тип: Структура.
Структура, содержащая значения для заполнения свойств ключа записи.
Имена элементов структуры должны соответствовать именам ключевых полей.
   Defender aka LINN
 
3 - 27.10.16 - 10:34
(0) "Но у Рег[0] нет свойства ИсходныйКлючЗаписи"
Тогда за каким чертом ты пытаешься его получить?
   ferry
 
4 - 27.10.16 - 10:41
При отображении картинки в записи регистра сведений это свойство есть и используется так
ИзображениеНаФорме =ПолучитьНавигационнуюСсылку(запись.ИсходныйКлючЗаписи,"Картинка");
А как сделать в моем случае я не знаю...
Переписала так, но изображения все равно нет

Рег = Регистрысведений.ХарактеристикиНоменклатурыОбщие;
    Отбор = Новый Структура;
    Отбор.Вставить("Номенклатура",Номенклатура);    
    КлючЗаписи=Рег.СоздатьКлючЗаписи(Отбор);
    Если КлючЗаписи=Неопределено тогда
        ИзображениеНаФорме="";
    Иначе    
        Попытка
            ИзображениеНаФорме=ПолучитьНавигационнуюСсылку(КлючЗаписи,"Картинка"); 
        Исключение
            Сообщить("Упс");
        КонецПопытки;
    КонецЕсли;
   ferry
 
5 - 27.10.16 - 11:23
апну
   Lexey_
 
6 - 27.10.16 - 11:25
(5) отладчик что говорит?
   Defender aka LINN
 
7 - 27.10.16 - 11:33
(4) Навигационная ссылка на ключ записи? Оригинально
   Lexey_
 
8 - 27.10.16 - 11:44
(7) а че бы нет?
   ferry
 
9 - 27.10.16 - 11:51
отладчик ошибку не выдает..просто изображение пустое
в навигационной ссылке содержится что-то вроде
e1cib/data/РегистрСведений.ХарактеристикиНоменклатурыОбщие.Картинка?Номенклатура=c39deaabc8cecfb611e18fc630f7fc1a
   Lexey_
 
10 - 27.10.16 - 11:53
(9) картинка в регистре есть хоть?
 
 Рекламное место пустует
   ferry
 
11 - 27.10.16 - 11:53
да, картинка есть
   ferry
 
12 - 27.10.16 - 12:08
все, спасибо...проблема решилась...второе решение верное...

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует