Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

внешняя печатная форма. две команды

внешняя печатная форма. две команды
Я
   Luganchanin
 
26.10.16 - 18:09
есть задача во внешнюю обработку вставить несколько команд
ТаблицаКоманд = Получить Таблицу Команд();
    ДобавитьКоманду(ТаблицаКоманд, "кратко ТОРГ-2", "ТОРГ2", "ВызовСерверногоМетода", Истина, "ПечатьMXL");
    ДобавитьКоманду(ТаблицаКоманд, "кратко ТОРГ-3", "ТОРГ3", "ВызовСерверногоМетода", Истина, "ПечатьMXL");

а потом каким образом в процедуре Печать узнать какую из команд выбрал пользователь?

Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт

    УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(
        КоллекцияПечатныхФорм,
        УказатьНаименованиеКомандыПечати(),
        УказатьНаименованиеВнешнейПечатнойФормы(),
        ПолучитьПечатнуюФормуТОРГ("ТОРГ2", Ложь, МассивОбъектов, ОбъектыПечати));
КонецПроцедуры
 
 
   Жан Пердежон
 
1 - 26.10.16 - 18:23
Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "ТОРГ2") Тогда
    УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(
        КоллекцияПечатныхФорм,
        УказатьНаименованиеКомандыПечати(),
        УказатьНаименованиеВнешнейПечатнойФормы(),
        ПолучитьПечатнуюФормуТОРГ("ТОРГ2", Ложь, МассивОбъектов, ОбъектыПечати));
КонецЕсли;
   Luganchanin
 
2 - 26.10.16 - 18:26
(1) пробовал я уже так. Ошибку выдает:
{ОбщийМодуль.ДополнительныеОтчетыИОбработки.Модуль(238)}: В обработчике печати не был сформирован табличный документ для: ТОРГ2
   Жан Пердежон
 
3 - 26.10.16 - 18:32
(2) и как это соотносится с (0)?
   Жан Пердежон
 
4 - 26.10.16 - 18:43
Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "ТОРГ2") Тогда
    УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(
        КоллекцияПечатныхФорм,
        "ТОРГ2",
        "кратко ТОРГ-2",
        ПолучитьПечатнуюФормуТОРГ("ТОРГ2", Ложь, МассивОбъектов, ОбъектыПечати));
КонецЕсли;

скачал бы уже бсп
   Luganchanin
 
5 - 27.10.16 - 09:37
Неужели никто в одну внешнюю обработку не вкладывал двух и более команд?!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует