Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Как просматривать историю курса валюты?

Как просматривать историю курса валюты?
Я
   eric
 
26.10.16 - 15:15
Добрый день! ребят помогите 
В форме элемента справочника «Валюты» необходимо предоставить возможность пользователю просматривать историю курса валюты.
 
 
   Dark_Warrior
 
1 - 26.10.16 - 15:16
ТЧ на форме, в ней данные из РС?
   Джинн
 
2 - 26.10.16 - 15:21
(0) Э... Глазами не предлагать?
   Fish
 
3 - 26.10.16 - 15:25
(0) У меня в типовой для этого есть специальная ссылочка на форме элемента: "Курсы валют".
   eric
 
4 - 26.10.16 - 15:35
я в общем создал форму списка но что-то намудрил с запросом
ВЫБРАТЬ
    КурсыВалют.Курс,
    КурсыВалют.Период
ИЗ
    РегистрСведений.КурсыВалют КАК КурсыВалют
ГДЕ
    КурсыВалют.Валюта = &Валюта



Можете подсказать в чём ошибка

Ошибка при выполнении запроса. Ошибка при выполнении запроса.
по причине:
Ошибка получения данных
по причине:
Ошибка создания набора данных "НаборДанныхДинамическогоСписка"
по причине:
Ошибка при исполнении запроса набора данных
по причине:
{(8, 22)}: Не задано значение параметра "Валюта"
КурсыВалют.Валюта = <<?>>&Валюта
   rbcvg
 
5 - 26.10.16 - 15:37
(4) ошибка в том, что не задано значение  параметра "Валюта".
скорее всего...
   Lexey_
 
6 - 26.10.16 - 15:37
(4) "Можете подсказать в чём ошибка" - "Не задано значение параметра "Валюта" "
   eric
 
7 - 26.10.16 - 15:38
(5) (6) а как задать значение?
   rbcvg
 
8 - 26.10.16 - 15:40
(7) Запрос (Query)
УстановитьПараметр (SetParameter)
Синтаксис:

УстановитьПараметр(<Имя>, <Значение>)
Параметры:

<Имя> (обязательный)

Тип: Строка.
Имя устанавливаемого параметра. Оно должно соответствовать требованиям, предъявляемым к именованию переменных встроенного языка.
<Значение> (обязательный)

Тип: Произвольный. 
Значение устанавливаемого параметра.
Описание:

Устанавливает параметр запроса. Параметры доступны для обращения в тексте запроса. С помощью этого метода можно передавать переменные в запрос, например, для использования в условиях запроса.

Доступность:

Сервер, толстый клиент, внешнее соединение.
Пример:

Запрос.УстановитьПараметр("ДатаКонца", РабочаяДата);
Запрос.УстановитьПараметр("Товар", ВыбТовар);
   HeKrendel
 
9 - 26.10.16 - 15:46
Регистр сведений, курсы валют, открыть, далее отбор по валюте, бинго
   eric
 
10 - 26.10.16 - 16:23
&НаСервере
Процедура ПриОткрытииНаСервере()
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    |КурсыВалют.Курс,
    |КурсыВалют.Период,
    |КурсыВалют.Валюта"
ИЗ
    РегистрСведений.КурсыВалют КАК КурсыВалют
ГДЕ
    КурсыВалют.Валюта = &Валюта
    
    
    Запрос.УстановитьПараметр("Валюта", Валюта);
    //

    //Результат = Запрос.Выполнить();

    //

    //ВыборкаДетальныеЗаписи = Результат.Выбрать();



КонецПроцедуры


Помогите

{Справочник.Валюты.Форма.ФормаСписка.Форма(15,1)}: Неопознанный оператор
<<?>>ИЗ (Проверка: Сервер)
 
 Рекламное место пустует
   Джинн
 
11 - 26.10.16 - 16:27
(10) Помочь кавычки расставить?
   rbcvg
 
12 - 26.10.16 - 16:29
(11) палочек вот таких не хватает |

делай в конструкторе, он сам все расставит
   rbcvg
 
13 - 26.10.16 - 16:29
(12) -> (10)
   anatoly
 
14 - 26.10.16 - 16:38
читать СП и ЖКК!
или просто позвать программиста.
   eric
 
15 - 26.10.16 - 17:01
Ребят ещё раз прошу помощи
&НаСервере
Процедура ПриОткрытииНаСервере()
    Запрос = Новый Запрос;
    Запрос.Текст = 
    "ВЫБРАТЬ
    |    КурсыВалют.Период,
    |    КурсыВалют.Валюта,
    |    КурсыВалют.Курс
    |ИЗ
    |    РегистрСведений.КурсыВалют КАК КурсыВалют
    |ГДЕ
    |    КурсыВалют.Валюта = &Валюта";
    
    Запрос.УстановитьПараметр("Валюта",Валюта);
    
    Результат = Запрос.Выполнить();
    //

    ВыборкаДетальныеЗаписи = Результат.Выбрать();


КонецПроцедуры


Ошибка:
{Справочник.Валюты.Форма.ФормаСписка.Форма(21,37)}: Переменная не определена (Валюта)
    Запрос.УстановитьПараметр("Валюта",<<?>>Валюта); (Проверка: Сервер)
   Fish
 
16 - 26.10.16 - 17:03
(15) Перевожу: "Переменная не определена (Валюта)". Надо бы определить.
   eric
 
17 - 26.10.16 - 17:03
(16) Как?
   Fish
 
18 - 26.10.16 - 17:04
И это. Ты же в (0) писал "В форме элемента справочника «Валюты» необходимо предоставить возможность ", а сам полез в форму списка.
   eric
 
19 - 26.10.16 - 17:11
(18) Случайно создал не ту форму
Подскажите как определить переменную?
   Fish
 
20 - 26.10.16 - 17:14
(19) Через равно :)
ТвояПеременная = "ЗначениеТипаСправочникСсылка".

Или проще:

Запрос.УстановитьПараметр("Валюта","АСюдаВместоНепонятнойПеременнойПихайСправочникСсылка");
   Lexey_
 
21 - 26.10.16 - 17:14
(19) переменные можно определять как явно
Перем А;
так и неявно
А = 5;
   eric
 
22 - 26.10.16 - 17:46
(20) (21) и сейчас опять эта же ошибка

Ошибка при выполнении запроса. Ошибка при выполнении запроса.
по причине:
Ошибка получения данных
по причине:
Ошибка создания набора данных "НаборДанныхДинамическогоСписка" 
по причине:
Ошибка при исполнении запроса набора данных
по причине: 
{(8, 22)}: Не задано значение параметра "Валюта" 
КурсыВалют.Валюта = <<?>>&Валюта
   Lexey_
 
23 - 26.10.16 - 17:49
(22) и сейчас ты не задал значение параметра "Валюта"
   aleks_default
 
24 - 26.10.16 - 17:57
(23)он походу буквы видит, но складывать в слова не умеет
   eric
 
25 - 26.10.16 - 18:00
(23) (24) да что не так я просто не могу понять?
   Lexey_
 
26 - 26.10.16 - 18:01
(25) не так то, что ты без основ пытаешься что-то делать, почитай теорию для начала
   eric
 
27 - 26.10.16 - 18:02
(26) Теорию  я обязательно почитаю, но помогите пожалуйста с этим примером
   mehfk
 
28 - 26.10.16 - 18:15
(25) Бери больше, кидай дальше. Пока летит - отдыхай.
   eric
 
29 - 26.10.16 - 18:23
(24) (26) Подскажите как передать параметр в динамический список?
   Sv4org
 
30 - 27.10.16 - 12:16
(29) В запросе мы используем параметр Товар, в который и будет передаваться ссылка на текущую строку в списке номенклатуры, содержащуюся в параметре формы списка приходных накладных ФильтрПоТовару.

Для этого в обработчике события формы списка ПриСозданииНаСервере напишем код для установки значения параметра запроса Товар:

&НаКлиенте
Процедура ПриОткрытии(Отказ)
 ПриОткрытииНаСервере();
КонецПроцедуры

&НаСервере
Процедура ПриОткрытииНаСервере()
        
   Список.Параметры.УстановитьЗначениеПараметра("Товар", Параметры.ФильтрПоТовару);    

КонецПроцедуры


Здесь Список.Параметры - это список параметров запроса динамического списка для реквизита Список. Значение параметра Товар устанавливается равным значению параметра формы ФильтрПоТовару.

В результате по нажатию кнопки Приходные накладные в форме списка номенклатуры мы будем получать список только тех приходных накладных, в которых присутствует номенклатура, выделенная в данный момент в списке номенклатуры.
   Sv4org
 
31 - 27.10.16 - 12:17
(29) В твоём Случае

&НаСервере
Процедура ПриОткрытииНаСервере()
        
    Список.Параметры.УстановитьЗначениеПараметра("Валюта", Параметры.Валюта);    

КонецПроцедуры
   eric
 
32 - 27.10.16 - 12:19
(31) Сделал но ошибка та же

Ошибка при выполнении запроса.
Ошибка при выполнении запроса.по причине:
Ошибка получения данныхпо причине:
Ошибка создания набора данных
"НаборДанныхДинамическогоСписка"по причине:
Ошибка при исполнении запроса набора данныхпо причине:{(8, 22)}:
Не задано значение параметра "Валюта"КурсыВалют.Валюта = <<?>>&Валюта
   eric
 
33 - 27.10.16 - 12:23
Помогите кто ни будь это решить
 
 


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует