Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Как получить случайную выборку?

Как получить случайную выборку?
Я
   Slon747
 
26.10.16 - 14:06
Вообще, реально ли получить случайную выборку справочника с помощью запроса?
 
 
   Irbis
 
1 - 26.10.16 - 14:07
Неа, тем более запросом. Где условие есть всегда.
   Fragster
 
2 - 26.10.16 - 14:08
(0) вот тут есть в 17 сообщении костыль: v8: Временные таблицы и индексы в запросах
   Живой Ископаемый
3 - 26.10.16 - 14:08
   Волшебник
 
Модератор
4 - 26.10.16 - 14:09
ВЫБРАТЬ Ссылка 
ИЗ Справочник.Имя 
ГДЕ Ссылка В (&СписокСлучайныхСсылок)
   Живой Ископаемый
5 - 26.10.16 - 14:10
2(4) Первые 1
   Живой Ископаемый
6 - 26.10.16 - 14:12
а, ну собственно можно генерить текст запроса
ВЫБРАТЬ ПЕРВЫЕ"+ ПолучитьСлучайноеЧислоВРамкахКоличестваЭлементаСправочника(),
и потом брать из выборки последнюю запись
   PLUT
 
7 - 26.10.16 - 14:17
(26) лотерею пишешь?
   Irbis
 
8 - 26.10.16 - 14:19
А потом последует вопрос как получить ПолучитьСлучайноеЧислоВРамкахКоличестваЭлементаСправочника() или &СписокСлучайныхСсылок
   Cyberhawk
 
9 - 26.10.16 - 14:21
(0) Дай определение "случайную выборку справочника"
   Fragster
 
10 - 26.10.16 - 14:21
(8) в (2) все есть
 
 Рекламное место пустует
   Лефмихалыч
 
11 - 26.10.16 - 14:31
(0) вот тут насыпано http://forum.infostart.ru/forum26/topic128003/
   Рэйв
 
12 - 26.10.16 - 14:32
Вот тебе сапсем случайные:-)

З=Новый Запрос;
Гена=Новый ГенераторСлучайныхЧисел;
З.Текст="Выбрать Спр.Ссылка Из Справочник.Банки КАК Спр";
тРез=З.Выполнить().Выгрузить();
тРез.Колонки.Добавить("Номер");
тИтог=тРез.Скопировать();
тИтог.Очистить();
Верх=тРез.Количество();
Низ=1;
Предел=Гена.СлучайноеЧисло(Низ,Верх);
Сообщить(Предел);

Для Каждого Стр Из тРез Цикл
    Стр.Номер=Гена.СлучайноеЧисло(Низ,Верх);
КонецЦикла;    
тРез.Сортировать("Номер") ;
Сч=0;
Для Каждого Стр Из тРез Цикл
    Сч=Сч+1;
    Если Сч>Предел Тогда
        Прервать;
    КонецЕсли;    
    Нов=тИтог.Добавить();
    Нов.ссылка=Стр.Ссылка;
КонецЦикла;    
Сообщить("Выбрано:"+тИтог.Количество());
тИтог.ВыбратьСтроку();
   Ildarovich
 
13 - 26.10.16 - 14:42
Вот тут http://catalog.mista.ru/public/336783/ решалась именно эта задача (Пример 3).

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует